Jump to content
LaunchBox Community Forums
torben656

LaunchBox.Next Feature Request

Recommended Posts

So I noticed in the 8.2 beta that LaunchBox is going to have a new interface. I know it's necessary for LaunchBox to move forward but I would just like to add a request. And that is optimization for low-end hardware. Because most of the time LaunchBox (or BigBox) is used for projects like turning old PCs into Arcade Cabinets. So, um. I hope this request will get noticed. :|

Edited by torben656
Grammar Errors haha

Share this post


Link to post
Share on other sites

I don't think having low end hardware support is bad at all but assuming most people are interested in using it on a repurposed computer in an arcade machine is just not based on anything factual.

  • Like 2

Share this post


Link to post
Share on other sites

BigBox doesn't run well on old PCs. It doesn't even run well on my 5ghz 8700k  + 980 Ti + NVMe SSD setup. It struggles to run smooth on my 2 year old IBM laptop. I highly doubt it runs well on older PCs.
I've seen many of budget arcade setups (older PCs, Pi, linux, etc.) from other communities, but none of their specs could run BigBox.

Don't get me wrong. Optimization is a great thing, but I agree with DOS76 here. "Most of the time LaunchBox (or BigBox) is used for projects like turning old PCs into Arcade Cabinets" is a BIG assumption without any basis.

Share this post


Link to post
Share on other sites

Explain how it runs perfectly fine on both my systems then.

Windows 7
AMD Athlon 3800+ @ 2.4 GHz
2 gigs ram
Radeon 7850 (1 gig DDR5 vram)
Some generic 160 gig hard drive
Windows 10
AMD 8350 @ 4 GHz
16 gigs ram
GTX 970 graphics card
2 TB Western Digital Red

If it doesn't run well on a 5 Ghz 8700k + 980 Ti you may wanna look into making your system run properly.

Share this post


Link to post
Share on other sites

Perhaps your definition of "perfectly fine" and mine are different.

BigBox doesn't run well when I'm browsing through my library once per app launch. My library consists of thousands of games with videos and I make a good use of fast fingers for browsing and skipping through letters.
When I browse through them, it stutters a bit. Everything is installed on SSD.
The stutter goes away once I have browsed through them once (per app launch).

I'm sure my system is perfectly fine. I run daily maintenance and monitor them while I use them. Thank you very much.

Share this post


Link to post
Share on other sites

My definition of perfectly fine is it runs smooth. On the crappy old Athlon 3800 yeah I have to make some settings tweaks and a light weight theme but it runs smooth. But my 8350 runs BigBox butter smooth will all the goodies, videos and thousands of games.

I stand by my statement that if you are having performance issues then you have something wrong with your system.

Share this post


Link to post
Share on other sites

If you are just running through your library one game by one, yeah my system runs smooth. If I'm aggressively skimming through the library by jumping through letters, yeah it has a minor stutter.

I wouldn't say it's performance issues. It's just loading the logos and videos for the first time. It's a minor strutter, but enough for me to feel guilty to say "it runs fine".

I also stand by my statement that I'm sure my system is perfectly fine. You just probably don't browse aggressively as I do.

Good for you it runs fine on your weaker systems. I look forward to more consistent performance from BigBox in the future.

Share this post


Link to post
Share on other sites

I can say that My PC (Which is in a definitive needs of a upgrade!) couldn't keep a smooth experience before I upgraded it a little bit.

Originally I had 8Gb of rams and only HDDs for LB. at below 10K total games count, it was running ok considering you already cached most of the images through scrolling your whole library.

I5 3570K 3.4ghz stock (easily 4.0 ghz with a little tweaking)

670 GTX

8Gb of Rams

120gb SSD and over 12TB of HDDs.

But when I upgraded my LB and medias to an 500 GB SSD plus doubling my rams up to 16Gb, it's running a lot more smoother than it was before! It made a HUGE difference. But I know what you mean by the occasional very "Minor" but noticeable stutter. Don't know how many games you got in your library, but I'm currently at over 20K and it's running more than ok for me.

Launchbox.Next though... WOW this thing runs smooth on anything, even my laptop from work! I don't know if those optimization can be applied to BigBox also (BigBox.Next?), but If it can, that would be awesome :)

Edited by ZeroX9876

Share this post


Link to post
Share on other sites
12 hours ago, ZeSystem said:

If you are just running through your library one game by one, yeah my system runs smooth. If I'm aggressively skimming through the library by jumping through letters, yeah it has a minor stutter.

By your logic nothing runs perfectly on any system.

Share this post


Link to post
Share on other sites

Hopefully Jason can do something like this. I guess if he did do this for BigBox than "low end" would have to be defined. Eventually old hardware loses out to new software. Part of the reason for min spec on some software. After all when using an old pc for emulation you have to make concessions on what platforms you are going to emulate since some require a minimum spec to run the emulation well. 

Share this post


Link to post
Share on other sites

Mine stutters all the time, I'm just used to it of course, running launchbox off an external HDD using usb 2.0 XD.

Share this post


Link to post
Share on other sites

So...  it says I have 8.2 beta 3 but I don't have an option to enable Launchbox.next? Am I missing something?

It's just a scaling issue and was a tiny dropdown to the far right. I see it now. Thanks! :D

What's strange is that I'm running 1920x1080 and even turning scaling on windows to 100% its still doing the same thing. Weird.

Launchbox.next.png

Edited by RetroAsylum

Share this post


Link to post
Share on other sites

can't they make bigbox browsing async so that user input all ways takes priority and anything else is second? like scrolling fast just priorities smooth scrolling and let the stutter happen for when loading the images/details etc, i wouldn't even mind a delay on loading the details/images/videos if the navigation becomes smooth.

right now i even get issues where it lags a bit and the details get jumbled up with another games information and video until i go up or down and back on the game name.

Share this post


Link to post
Share on other sites

The new Launchbox Next will be theme-able, it will use the same theme engine as BigBox but of course people will have to make themes for it.

Share this post


Link to post
Share on other sites

Hopefully this is the proper thread about requesting features for LaunchBox.Next. If so then I'm sure you already know I was hoping for an easier way to select random games instead of going to "Tools" and selecting from there each time.

One of my latest requests would be to use other Emulators through it that aren't just RetroArch and a few others that kinda have been overlooked or forgotten such as zSNES for Super Nintendo or the 3DNES for NES. My Fiancee and I have come to find such fun in 3DNES due to how it makes everything that was 2D Pixels into 3D pixelated objects, but the GUI in it takes almost forever just to go from one game to the next. I was hoping maybe there was a way that LaunchBox could easily get you right into the game title of choosing in one click instead of a few and waiting in between them after searching and all. 

Share this post


Link to post
Share on other sites
Quote

One of my latest requests would be to use other Emulators through it that aren't just RetroArch and a few others that kinda have been overlooked or forgotten such as zSNES for Super Nintendo or the 3DNES for NES.


What is the problem you're having with running zSNES through LaunchBox? I haven't used it in quite some time, but I downloaded it now to try, and it was pretty straight-forward to set up in LaunchBox :) Incidentally I exclusively use stand-alone emulators, not RetroArch :)

Edited by proghodet

Share this post


Link to post
Share on other sites
1 hour ago, proghodet said:


What is the problem you're having with running zSNES through LaunchBox? I haven't used it in quite some time, but I downloaded it now to try, and it was pretty straight-forward to set up in LaunchBox :) Incidentally I exclusively use stand-alone emulators, not RetroArch :)

Maybe I overlooked something? Most of what I seen was for Snes9x or RetroArch when I was starting out on learning and getting things set up. Maybe things got updated where this now open to zSNES? Seems I may have to back and give it another look and see if it's a simple setup of a Directory to zSNES.exe then

I have settled for one of RetroArch's SNES cores for the moment, but when I do that I now have problems getting it to run through HDMI even when I change the Screen Index. With zSNES it's never been a problem through HDMI and I'm not all sure why some left it for Snes9x though. 

Edited by RULLUR

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...