Jump to content
LaunchBox Community Forums
Tromzy

Launching AM2R from Launchbox

Recommended Posts

I have AM2R (Another Metroid 2 Remake) on my PC and I can launch it fine through its executable, but for some reason, I cannot launch it through Launchbox / Big Box. I added the game manually, put the path to the executable, scrapped the game, but it does not launch.

 

I must say that I use a reshade to add scanlines to the game, so maybe that's where the problem lies ; though, I don't have to add custom command line or anything when I launch the game through its executable outside Launchbox. Steam launches the game fine too.

 

Is there a way to see logs or anything that could give me a hint on what happens (or does not happen) ?

Share this post


Link to post
Share on other sites

Can you check in the Edit Game window to ensure that under the Emulation tab that you have it set to not use any emulator?

Share this post


Link to post
Share on other sites
Just now, Charco said:

Can you check in the Edit Game window to ensure that under the Emulation tab that you have it set to not use any emulator?

Yeah, I have AM2R and it launches just fine for me so there must be a error somewhere.

Share this post


Link to post
Share on other sites

Thanks for the answers. The game does not launch through an emulator, I checked that ; and the path is correct, I double-checked it. I have no idea why it does not launch.

Edited by Tromzy

Share this post


Link to post
Share on other sites

I'll check this evening after work and post some screenshots of my settings. It definitely works for me, so I'm sure we can get this sorted out for you.

Share this post


Link to post
Share on other sites

Thanks for the screenshots ; I have the same settings as you, so I'll try without Reshade and see if the problem lies there.

Share this post


Link to post
Share on other sites

So, I tried to remove Reshade and now the game launches but all I get is a black screen, although sound works.

Share this post


Link to post
Share on other sites

The game launches fine from Launchbox in windowed mode, but it is a very poor workaround...

Share this post


Link to post
Share on other sites

Can you not change to full screen in the game options and it will save on exit for the next launch?

Share this post


Link to post
Share on other sites

are you on Windows 10? If so try these 2 things click on the exe for the game and go to properties>compatibility then turn of full screen optimization and see if that fixes it if not try turning off dpi scaling next.

Share this post


Link to post
Share on other sites

I've tested AM2R v1.1, 1.3.2, and 1.3.3 and they all launch fine either by clicking the exe or using LaunchBox. I am on Windows 7.

Share this post


Link to post
Share on other sites

@Tromzy I have problems with launching this game through LB as well.

The game loads perfectly fine launching the exe or shortcut file directly but through LB I get this error.5abbf5b2ce9ab_2018-03-2815_01_38-AM2R.png.eac5c2fc1b6d978925385d5c5503c1cb.pngI'm not using Reshade with it and if I disable fullscreen optimization that gives me a black screen when loading the game using the exe or shortcut.

I am truly stumped on this one, this is the only game I have seen that has done this and it makes no sense at all since loading the games exe or shortcut file directly is not a problem, it's only loading through LB that gives the error.

Share this post


Link to post
Share on other sites

Well, I'm sorry that you have the problem too, but I'm also glad that I'm not alone ! I tried every advice and it changes nothing, unfortunately.

Share this post


Link to post
Share on other sites

It really is a strange one because all LB is doing is calling the exe or shortcut just like clicking either of those on their own.

Share this post


Link to post
Share on other sites

Okay, something weird is happening : I put Reshade again in the AM2R folder, tried disabling DPI scaling, launched the game through LB and... It worked ! Then I unchecked "Disable DPI scaling", launched the game through LB again and it still works ! Reshade works, fullscreen too. I'm baffled by this but hey, at least it works now...

Edited by Tromzy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...