Jump to content
LaunchBox Community Forums
MayorQwert

Shuffling BigBox Background Music

Recommended Posts

Hey! So I have my BigBox set up as a front-end for my Multicade, with numerous arcade titles to play, going so far as to add arcade music to the "Launchbox/Music/Background" folder so that it will shuffle through various arcade musics while the game screen is up. It works excellently and I even added album art and info for each game so it displays the song name, game it's from and who the artist is, along with a nice image of the game box art when a new song plays. To make sure the album art is retained for every song, I have each game's music in a different folder within the Background folder. It displays everything fine, but the issue I'm having is it's not shuffling the music, no matter how I set it up.

 

Here's a better description of the problem: When I launch Big Box, it does select a random song, but afterwards it will sequentially play every song from that game (folder), before moving to the next game alphabetically and playing all the music from it as well. If I force it to next song with the BigBox binding, it will indeed select a random song, but afterwards will go back to playing them alphabetically. I have shuffle turned on in settings, but no matter what it won't actually shuffle them if I leave it sitting. It's annoying, as I want it to ideally shuffle every track together, while also retaining album art and info (if I stick them all in a folder together it will mess up the album art).

 

Does anybody have any suggestions?

SoundSettings.thumb.PNG.a3c3f378630ebb243e3ad67a1681895e.PNG

music.thumb.PNG.589f756c715485726b629b69803c5768.PNG tile.thumb.PNG.3d7f21724a4ec486513f1cf68308d4f8.PNG

Edited by MayorQwert

Share this post


Link to post
Share on other sites

Bumping this, as I still can't seem to find a workaround. No matter what, after a few songs it always starts playing through the folders and songs sequentially. First songs from Battle Garegga in alphabetic order, next Battletoads, Boogie Wings, etc. I tried dumping everything into a common folder, but album art is all messed up when that happens. Any suggestions?

Share this post


Link to post
Share on other sites

Anybody have any issues with randomized background music in Big Box? Bumping yet again as this is still an ongoing issue.

Share this post


Link to post
Share on other sites

I'm running into this issue too! The first song is random but then it appears to play alphabetically. I'm going to try taking the music files out of their subdirectories and have all of the files directly under the "Background" folder and let you know how it goes.

Edited by Joderick

Share this post


Link to post
Share on other sites
1 hour ago, Joderick said:

I'm running into this issue too! The first song is random but then it appears to play alphabetically. I'm going to try taking the music files out of their subdirectories and have all of the files directly under the "Background" folder and let you know how it goes.

So glad to FINALLY find someone else having this issue! I think I recall trying that but to no avail. No idea why it does this.

Share this post


Link to post
Share on other sites

I've been having this issue as well. All my music is in the root of the Background music folder. Its kinda dampening the experience some.

Edited by galvatrondeva

Share this post


Link to post
Share on other sites

So for me, this seems to have something to do with Attract Mode being on. When I disable Attract Mode, restart BigBox, It will play the song i have now come to hate. However it moves past it on its own and work as intended. I cannot seem to have Attract Mode and true Random Background music at the same time. 

 

I wonder  if that is the same for the rest of you having this issue?

Share this post


Link to post
Share on other sites
On 2/22/2019 at 9:18 PM, galvatrondeva said:

So for me, this seems to have something to do with Attract Mode being on. When I disable Attract Mode, restart BigBox, It will play the song i have now come to hate. However it moves past it on its own and work as intended. I cannot seem to have Attract Mode and true Random Background music at the same time. 

 

I wonder  if that is the same for the rest of you having this issue?

I tested it with and without attract mode and unfortunately noticed no difference! I managed to mitigate this somewhat why using Flexible Renamer and Robobasket to both filter individual songs into subfolders and then (using Flexible Renamer) shuffle those folder names such that a rudimentary shuffling system can be established. This is very tedious and not good practice but with the large library I have collected having proper song shuffling is paramount to my BigBox experience.

 

However, the main problem that keeps annoying me to no end is that, no matter what, after a game is played the list will eventually restart back to the first track. The amount of time it takes to do so strangely enough seems to depend on how many songs have been played up until the point the game has been played, but without fail it always resets the list, regardless of how far it made it beforehand. The same is true if I try to skip forwards/back in the songlist, resulting in the playback resetting to the first track. With over 1000 music tracks in my Bigbox library this is seriously hindering the enjoyment I can get out of this unfortunately, as I wish to use my BigBox as an 'Arcade Jukebox' of sorts when games aren't being played. I've been experimenting with other methods to get around using the abysmal media player but haven't found any that seem to quite cut it. My last attempt centered around using an external media player (Such as WinAMP) that can use windows system media controls (play/pause, stop, etc.) in conjunction with autohotkeys. Basically, I start playback on the media player and have it paused when an emulator is launched and played once again when the emulator is closed. This works for the most part, however even when "Always on Top" is on it unfortunately does not display the song title/album/artist/artwork in the corner like usual, which is a major deal breaker considering the meticulous work that I have put into collecting metadata for these tracks. Also, if one attempts to quit the game too fast, it is possible that the script can terminate whereas the emulator does not, leading to the game staying up and having music play over it.

I just really wish the Devs would address this persistent problem, yes media playback is just an extra feature to the actual game playing but considering the work that has gone into adding media functionality in recent updates I think an overhaul to the BigBox media playback is completely justifiable as a concern.

 

Please, someone fix this! 😟

Share this post


Link to post
Share on other sites

Late to the thread, but I’ve noticed this same problem. It’s slowly making me hate the animal crossing theme, which is a real shame.

Share this post


Link to post
Share on other sites

Question about background music in general, is it possible to just have one song going on repeat in the background?
I am planning on upgrading to prem soon, and just want a basic track running in the background while browsing games. 
And than have it turn off  when starting a game

Share this post


Link to post
Share on other sites
On 6/18/2019 at 7:54 AM, John Dastardly said:

Question about background music in general, is it possible to just have one song going on repeat in the background?
I am planning on upgrading to prem soon, and just want a basic track running in the background while browsing games. 
And than have it turn off  when starting a game

Bumping this question because this would be a great feature

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...