Jump to content
LaunchBox Community Forums
Lordmonkus

Launchbox 8.2 Released - Change Log

Recommended Posts

Version 8.2 - Released April 11, 2018

- New Feature: LaunchBox.Next is now available; it's a complete overhaul for the main LaunchBox interface. IT'S LARGELY STILL IN DEVELOPMENT, but you can try it out by clicking the LaunchBox.Next button in the header or running the new LaunchBox.Next.exe file from the LaunchBox folder.

- New Feature: Five new options have been added to the View menu in LaunchBox to hide games missing videos, front box art, screenshots, clear logos, and/or background images. These options will trigger a process to populate a missing media cache that will allow quick navigation. There's also an option underneath these five items to "Refresh All Missing Media" in case you've manually added or removed images directly from the file system.

- New Feature: Images can now be deleted directly from the game details sidebar in LaunchBox via a new right-click menu

- New Feature: The list view in LaunchBox now allows you to hide and show columns by right-clicking on the column headers, and will save your preferences as well as the column order

- Improvement: The included CriticalZone theme for Big Box has been updated to version 2; huge thanks to CriticalCid for his continued work on the theme! To use it, select the new "CriticalZoneV2 - Default" theme under Options > Views in Big Box. More versions of the theme are also available on the LaunchBox forums.

- Improvement: A new "Wheel Easing" option has been added to Big Box that makes wheels and CoverFlow appear smoother by easing animations in and out. It's on by default but can be disabled under Options > Views.

- Improvement: A new "Show Platform Banner Images" option was added to Big Box to allow you to hide the platform banner images if you don't want them obstructing the view of the background; the setting is available under Options > Images.

- Improvement: A new "Allow Computer to Sleep while not in Attract Mode" option has been added to the Big Box General options for users who want Big Box to allow their computers to sleep

- Improvement: Scanning for added ROMs performance has been drastically improved

- Improvement: The default platforms and settings for the Retroarch emulator have been updated with more platforms and more modern core choices

- Improvement: RetroHumanoid's amazing theme videos have been added as an option to the Platform/Playlist theme video downloads

- Improvement: A new "RotationAmount" property has been added to the Big Box FlowControl (for theme developers styling the wheels). This allows theme developers to create a more cohesive-feeling wheel with items that rotate as the wheel turns.

- Fixed: Sorting by title in the LaunchBox list view now correctly sorts by Sort Title

- Fixed: When using the search box in LaunchBox, the scroll position was not reset which was sometimes confusing because it appeared that not all results were shown

- Fixed: The images portion of the Edit Game dialog had some minor positioning issues on higher DPIs

- Fixed: Steam killed off our API key once again, again breaking the Steam import wizard. We've changed it to ask the user to get their own API key from Steam in order to resolve the issue.

  • Thanks 2

Share this post


Link to post
Share on other sites

I noticed, just now, that if you are using LaunchBox.next is doesn't prompt for the update.  When I switched to regular LB I immediately got the prompt.

Share this post


Link to post
Share on other sites

I always have this bug where the welcome menu will always show up, even when disabled from the options AND after ticking "Don't show this window again".

Share this post


Link to post
Share on other sites

I have never seen that bug, the welcome screen does come up after each update though which is normal.

Share this post


Link to post
Share on other sites

I know, but in my case, it comes up every time, even not after an update.

Share this post


Link to post
Share on other sites

Does the "splash screen" option in the main preferences affect that?

Share this post


Link to post
Share on other sites
Posted (edited)
15 hours ago, Tromzy said:

I always have this bug where the welcome menu will always show up, even when disabled from the options AND after ticking "Don't show this window again".

Make sure after ticking "Don't show this window again" that you press the "close" button at the bottom right of the Launchbox splash window, only then it will save the setting.

If instead you close the splash window by pressing the Windows close button (the "X" on the top right of the splash window), which I was used to doing,  it will -not- save the setting, making the window appear everytime you start Launchbox....

I guess  @Jason Carr ,it would be nice if the setting would also be saved when people close the splash screen through the top right Windows "X" (close window)  button.

Edited by Rod

Share this post


Link to post
Share on other sites
On 13/04/2018 at 3:10 PM, Rod said:

Make sure after ticking "Don't show this window again" that you press the "close" button at the bottom right of the Launchbox splash window, only then it will save the setting.

If instead you close the splash window by pressing the Windows close button (the "X" on the top right of the splash window), which I was used to doing,  it will -not- save the setting, making the window appear everytime you start Launchbox....

I guess  @Jason Carr ,it would be nice if the setting would also be saved when people close the splash screen through the top right Windows "X" (close window)  button.

Haha it's funny because I just tried that and it worked ! And then I came here to say it and saw your post. :D

Share this post


Link to post
Share on other sites

Latest beta of BigBox is either crashing or exiting to desktop on its own if I leave it running for awhile (at least an hour).  I do have attract mode on.  This is happening every time.  It did not happen before.

Share this post


Link to post
Share on other sites
On 4/14/2018 at 8:26 PM, Tromzy said:

Haha it's funny because I just tried that and it worked ! And then I came here to say it and saw your post. :D

Ha ha great, there must have been some telepathy, good to have that solved :)

@Jason Carr Would it be possible to have the splash screen option ("don't show this window again") saved also when a user closes the window through the top right "X" ?  Currently it only saves the option value when the window is closed through your "close" button at the bottom right.

 

Share this post


Link to post
Share on other sites
On 4/14/2018 at 1:57 PM, Xpendable said:

Latest beta of BigBox is either crashing or exiting to desktop on its own if I leave it running for awhile (at least an hour).  I do have attract mode on.  This is happening every time.  It did not happen before.

@Xpendable What theme are you running? Any plugins?

9 minutes ago, Rod said:

Ha ha great, there must have been some telepathy, good to have that solved :)

@Jason Carr Would it be possible to have the splash screen option ("don't show this window again") saved also when a user closes the window through the top right "X" ?  Currently it only saves the option value when the window is closed through your "close" button at the bottom right.

 

@Rod I'll look into that. Perhaps that functionality got messed with when we switched to using the Chromium engine.

Share this post


Link to post
Share on other sites
Just now, Jason Carr said:

@Xpendable What theme are you running? Any plugins?

@Rod I'll look into that. Perhaps that functionality got messed with when we switched to using the Chromium engine.

Ok thanks :)

Share this post


Link to post
Share on other sites

It has been 24 hours and BigBox is still running. I need to consider that maybe my kids are exiting it. 

Share this post


Link to post
Share on other sites

It happened again.  I had BigBox running and left for about 2 hours and came back and it was sitting at the desktop and BigBox was no longer running.  No-one else was home so I know nobody was messing with it.  I'm also continuing to have the problem where sounds effects in Mame are often stuttering... This problem in Mame does not exist when launched from HyperSpin.  It is only when launched from BigBox.  In fact, both HyperSpin and LaunchBox/BigBox are using the exact same installation of Mame.  I've disabled all transitions, and I'm now using text (not logos) for my game wheel.

Share this post


Link to post
Share on other sites

The stuttering sound problem for MAME games seems to have improved somewhat after switching to text only (not logos) in the wheels, but is still present on some games.  Those same MAME games have no stuttering whatsoever when launched from HyperSpin.  My guess is BigBox is more resource intensive than HyperSpin (which itself is supposed to be fairly resource intensive) when it's in the background.  I don't know if it's how BigBox is using threads, memory, or what.  At least on my class of machine, it doesn't do all that great.  It is an older computer... Running on an Asus P5G41 motherboard with a DuoCore processor and a lower-end (think GT) Nvidia graphics card.  Also it only has 4GB of ram.  I used to use this PC as my Windows Media Center computer in my family room with a Ceton 4-channel HD tuner card.  It performed that task well until I retired it.  I did just order another 4GB of ram for it to bring it up to 8GB.  I'm hoping that will help things.  I also have some newer Nvidia cards that I can throw on it, but I'm not sure that will make much of a difference.  OS is Windows 7.  I've stripped unnecessary hardware from it and purged almost all programs, including antivirus.  (I had been running BitDefender, but after the recent false positives, I have decided to ditch that pile of crap).  I might, at some point, replace the hard drive with an SSD.

 

Share this post


Link to post
Share on other sites

Since you mention you have an Nvidia graphics card are you using the GeForce Experience software with it ?

If so try removing that, a couple of driver versions ago I noticed it was causing some minor performance issues for me, removing GeForce Experience fixed it.

Share this post


Link to post
Share on other sites
Posted (edited)

Oh, and I wanted to mention one other thing.  I can 100% absolutely confirm that BigBox is exiting on it's own, and it's happening quite often.  I can't keep BigBox running overnight.  Nobody is ever around when it exits.  I don't see any errors on the screen or any indication that anything went wrong, it's just not running anymore.  Extremely frustrating.  I haven't yet checked the event viewer to see if anything's being recorded there.  But something is definitely going on.  I'll launch BigBox, play a few games, then exit the game and have it sit at the BigBox menu.  Attract mode is off, so it sits at whatever game details is being shown.  I'll leave there and come back later and it's sitting at the desktop and BigBox is no longer running.  I'm tempted to write a simple C# watchdog program to record the exits and maybe even restart it when it happens.  If I do that, I'll share my findings in the interests of helping you track down what the issue might be.

Edited by Xpendable

Share this post


Link to post
Share on other sites
1 minute ago, Lordmonkus said:

Since you mention you have an Nvidia graphics card are you using the GeForce Experience software with it ?

If so try removing that, a couple of driver versions ago I noticed it was causing some minor performance issues for me, removing GeForce Experience fixed it.

No, I do not have GeForce Experience installed on this computer.  At least I don't think I do.  I will recheck this.

Share this post


Link to post
Share on other sites

I mean, I don't know if it will fix it for you but I know it was an issue for me until I removed it.

Share this post


Link to post
Share on other sites

I confirmed that GeForce Experience is not installed.  I did write a watchdog program last night and it is running BigBox now and will log to both the console window and to a file each time BigBox exits and it will restart it if it does.  Hmm, I just realized I should probably have also logged the exit code if any, but that may not show anything, depending on how the application is written.  I will admit that my watcher won't know the difference between manually exiting the program versus a crash.  i do have BigBox set to locked with a pin and only I know the pin, so I know my girls aren't pressing anything to exit BigBox as far as I know.  Anyway, it ran overnight for just over 17+ hours without any exits.  

I also did check the Windows event viewer logs last night and have nothing at all from BigBox/LaunchBox.  I noticed the Logs directory for LaunchBox is empty.  I just changed the DebugLog setting in settings.xml to true to see if it creates any output.  Yes, it does, but interesting enough, the log does not appear to record anything about what games are selected and launched or anything else other than starting/stopping/resuming music.  I also had an error at the top about missing xaudio8_2.dll or something.  That maybe explains why I never heard any background music...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×