Jump to content
LaunchBox Community Forums
James CyberLink

Requesting help: Beetle Saturn on Retroarch doesn't work!

Recommended Posts

It keeps sending me to the BIOS screen with "Drive Empty" messages! I've tried everything I can think of, running the .cue files, the other files, all of it! What the heck do I do?!

Share this post


Link to post
Share on other sites

Most likely your disk images aren't correct and need to be fixed or replaced.

Running the cue file is correct but there are a lot of bad Saturn disk images out there.

Share this post


Link to post
Share on other sites
28 minutes ago, Lordmonkus said:

Most likely your disk images aren't correct and need to be fixed or replaced.

Running the cue file is correct but there are a lot of bad Saturn disk images out there.

I don't think that's the case: I'm using a good disk image of NIGHTS: Into Dreams, and it's working fine on Yabause, but whenever I try it with Beetle Saturn on Retroarch, the emulator I'd rather use, it gives me the Drive Empty issue, so it surely must be an emulator issue!

Share this post


Link to post
Share on other sites

Just google "Saturn archive" you'll find all you need there when you register for free.

Share this post


Link to post
Share on other sites
30 minutes ago, neil9000 said:

Just google "Saturn archive" you'll find all you need there when you register for free.

 

15 minutes ago, DOS76 said:

Archive,org

Tried going there, all the files are showing a padlock, indicating you can't download them, on the top Google results anyway.

Edited by James CyberLink

Share this post


Link to post
Share on other sites

Had this same issue and finally got it sorted out.  Open Launch Box then right click on a Saturn Game and choose edit.  Then under the launcher tab check to see which rom file the launcher is pointed to.  In my case each game was pointing to "gamename (Track 01).bin" instead of "gamename".cue  Changing this to point to the games .cue file fixed the issue.  Also of note I was able to run all of the games through Retroarch using the Beetle/Mednafen Core.  It was only when I attempted to run them in LaunchBox that I received the Drive Empty Message.  And that was with the mednafen_saturn_libretro.dll core selected for Sega Saturn under Associated Platform.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...