Jump to content
LaunchBox Community Forums
Leg0z

Cannot exit Cemu when using batch files to launch games

Recommended Posts

My Setup is a little different for Cemu so please read before jumping down my throat about missing autohotkey script

  • Dualshock 4 running a modified version of ds4windows that has motion detection output that Cemu can hook into (Motion aiming in BOTW)
  • Launchbox and Big Box works brilliantly with exiting other emulators with the controller shortcut. But it will not fully exit Cemu, just makes it not full screen.
  • I did have the autohotkey script in place for Cemu that fixed the exiting issue but it is not longer working because...
  • I use a batch file per Wii U game to add it to launchbox. This allows me for each game to say "controller 1 is a gamepad and controller 2 is a wiimote and here are the custom CPU and graphic settings for this game". So I can specify for each game the controller types, graphic and cpu settings. Is there another way of doing this without batch files?
  • I add each batch file to Launchbox like you would a non steam game.
  • Everything launches and runs fine, I just cant exit without a keyboard

Any suggestions? I've tried launching a seperate AHK at the time of launching a cemu game but it doesnt seem to work as it's almost as if cemu completely takes over the gamepad. I've even tried putting in a ds4windows script without any luck. And I've even tried launching it through steam with a controller shortcut to alt+f4. Nothing. Any suggestions?

Share this post


Link to post
Share on other sites

I doubt i'll be able to help as your setup is nothing like mine, i have no idea what ds4windows is but anyway will try...

 

What is your seperate ahk script? Post your code up.

If u have a batch file to launch the game, launchbox might think that the batch file is the game. When the batch file exits, launchbox thinks the game is over and any ahk script in the emulator tab will exit. To test this you can add some code to the cemu ahk tab. Start a cemu game. Go to task manager with the game still running and see if there is a ahk script running under launchbox... although i could be wrong about this.

Have you tried running ahk as admin. 

Edited by jayjay

Share this post


Link to post
Share on other sites

I had that problem and fixed it by adding this code to the autohotkey Script tab of the emulator:

MouseMove, 3840, 2160, 0, R ;

!Enter::return ;

!Esc::return ;

$Esc::
{
    Process, Close, {{{StartupEXE}}}
}

In your case, you might have to change the bat to be an additional application launched before the emulator (remove launching CEMU, that will be handled by LB).

Edited by Suhrvivor

Share this post


Link to post
Share on other sites

While there may be a simpler solution to this the one that comes to mind for me is to use something like Controller Companion or something similar like AntiMicro or Xpadder. I use Controller Companion myself and it is very easy to set per program profiles so you should be able to set it to load a profile with Cemu to map 2 buttons on your controller to Alt + F4.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...