Jump to content
LaunchBox Community Forums
Dane

RetroArch's controls completely screwed up on their own

Recommended Posts

Seems like when I fix something another problem occurs. I just went to play a two player game on the SEGA Megadrive through RetroArch and the controls magically screwed up on their own as I certainly did not attempt to change anything. What has happened is in the input menu for player 1 and 2 at the very top where it normally says RetroPad, or gives the option for it, that is no longer an option. The controls work for player 1 but the buttons do not work for player 2 and player 2's d-pad also controls player 1's d-pad. I tried the NES and RetroPad is an option in RA's input options but it makes no difference as it is doing exactly as I described for the SEGA Megadrive. What the hell is going on?! Has anyone has this happen before. I deleted my config files for RA in the main directory and started RA back up again, but no difference. I am giving up for the night as I am too frustrated as I have been trying for nearly an hour to no avail but if anyone would be kind enough to shed some light if they know it would be greatly appreciated.

Edited by Dane

Share this post


Link to post
Share on other sites

Did you just update to 1.7.3 ? I think 1.7.3 did something to change the controller configs, I can't say it did for certain but I did notice I had to remap some of my core controller remaps. This wasn't a big deal since they are pretty simple, just took a minute and saved new core remaps.

Share this post


Link to post
Share on other sites
5 hours ago, Lordmonkus said:

Did you just update to 1.7.3 ? I think 1.7.3 did something to change the controller configs, I can't say it did for certain but I did notice I had to remap some of my core controller remaps. This wasn't a big deal since they are pretty simple, just took a minute and saved new core remaps.

No I am still on 1.7.1. I tried entering in the buttons manually but it did not work. It all of a sudden would not recommend the controllers A, B, X and Y buttons. The only thing I can enter manually is player 1 controller's d-pad. I was thinking of just deleting RA from my computer today and redownloading it again from scratch. I will just save the files in my config folder as I spent way too much time on those to do again.

Edited by Dane

Share this post


Link to post
Share on other sites
9 hours ago, Lordmonkus said:

Did you just update to 1.7.3 ? I think 1.7.3 did something to change the controller configs, I can't say it did for certain but I did notice I had to remap some of my core controller remaps. This wasn't a big deal since they are pretty simple, just took a minute and saved new core remaps.

I deleted RA and redownloaded it all over again this time from 1.7.1 to the new 1.7.3 and still the same problem. I can play a 1 player game just fine but with two players the two player controller controls player one's d-pad as well as its own. When you say you had to "remap some of my core controller remaps" is just just in settings > input > Input User 1 Binds? Or did you do this some other way?

Share this post


Link to post
Share on other sites
10 minutes ago, Lordmonkus said:

I did it in the Quick Menu and saved a core remap file.

I absolutely hated RA when I first got into as I found it too complicated. Though as I have become more accustomed to the UI I've started to love it. One good thing I have found about RA, up until now, is that it auto configs the controls well if you have a compatible controller. Though if you do not, or something goes wrong it is such a convoluted system to configure controls manually in any way. Though now I have invested too much into RA to abandon it. I have stockholm syndrome with RA, its like it feeds me but beats the shit out of me at the same time and it is a love-hate-relationship. I wouldn't have a clue how to save a core remap file but will look into it, thank you.
1.thumb.png.fc5fae34cbd974e7a8b2c10b4c9dfcf8.png

Share this post


Link to post
Share on other sites

It's all good, I managed to change it just in the normal input binds and applied it to all and it is working now. Though, I did try that before and it would not let me, I guess there was a Gremlin in the system being a jerk.

Share this post


Link to post
Share on other sites
45 minutes ago, Dane said:

I wouldn't have a clue how to save a core remap file

It's in the Quick Menu for a core when you have a game loaded.

Share this post


Link to post
Share on other sites
3 hours ago, Lordmonkus said:

It's in the Quick Menu for a core when you have a game loaded.

I did have a peak in there but luckily I did not need to do it as the controls did not seem to respond as I wished in that section. It is all good now so fingers crossed it does not decide to play up again. Thank you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...