Jump to content
LaunchBox Community Forums
Bleu_Skie

Launchbox next not opening

Recommended Posts

I have been using launchbox next for a while now and really enjoy the general speediness of it. About a week ago (on 8.3) I had a crash. I'm not sure why and I can't recall what I did to cause it, but I am now unable to open launchbox next. I have tried upgrading to a beta buld and I have just tried a brand new installation (where I just tried to immediately open next) and next won't open in either. I'm actually not sure where to go from here to troubleshoot, so any advice would be helpful. 

Share this post


Link to post
Share on other sites
4 hours ago, DOS76 said:

So does regular LB open in both of these installs?

Yeah, normal LB works fine as far as I can tell. In all 3 cases (original 8.3, beta, and new install)

Edited by Bleu_Skie
To be more specific

Share this post


Link to post
Share on other sites

Have you tried opening the exe from within the folder and are you running an Antivirus program that is all of a sudden quarantining it

Share this post


Link to post
Share on other sites
46 minutes ago, DOS76 said:

Have you tried opening the exe from within the folder and are you running an Antivirus program that is all of a sudden quarantining it

Yes, I have done that. Also restarted the pc. I dont think my antivirus would do that without a notification, but I will exempt the folder and see if that does the trick..... Nope, still goes through the normal start up box and then nothing. I already had it set to run as administrator as well.

Share this post


Link to post
Share on other sites

Normally, I wouldn't be too concerned since the normal LB works, but I saw one of the youtube vids that said next will become the main version. If it doesn't open for me, that is a bit worrisome lol. I made a quick video showing my issue. I'm not sure if it will help tho. 

 

 

Share this post


Link to post
Share on other sites

Well i have never seen that before, i am really not sure what is happening there. My only guess is Windows is missing some files/drivers that next needs but normal Launchbox doesnt. I will tag @Jason Carr here to see if he has any idea, but i believe he is away this week so i am not sure when he will see it.

Also i noticed you are always opening as administrator, why? Its not recommended to run Launchbox as administrator as it can cause issues.

Share this post


Link to post
Share on other sites
32 minutes ago, neil9000 said:

Well i have never seen that before, i am really not sure what is happening there. My only guess is Windows is missing some files/drivers that next needs but normal Launchbox doesnt. I will tag @Jason Carr here to see if he has any idea, but i believe he is away this week so i am not sure when he will see it.

Also i noticed you are always opening as administrator, why? Its not recommended to run Launchbox as administrator as it can cause issues.

I'm not sure either. It was working fine until some random crash I really should have payed more attention to lol.... I run as admin just to make sure there isn't some access problem somewhere. It seems to be recommended for most things, so I got into the habit of always doing it. 

EDIT: but I did just try it without running as admin and no change.

Edited by Bleu_Skie

Share this post


Link to post
Share on other sites

@Bleu_Skie Thanks for the report. If you can zip up and PM me your LaunchBox\Data folder, hopefully I can pinpoint the issue. Make sure you private message me the folder instead of posting it here in the post publicly. Thanks. :)

Share this post


Link to post
Share on other sites
2 hours ago, Jason Carr said:

@Bleu_Skie Thanks for the report. If you can zip up and PM me your LaunchBox\Data folder, hopefully I can pinpoint the issue. Make sure you private message me the folder instead of posting it here in the post publicly. Thanks. :)

Sent it on over *fingers crossed*

Share this post


Link to post
Share on other sites

I checked out your data @Bleu_Skie. When I loaded up .Next I noticed that the window settings were set fairly strangely:

    <FormLocationX>-32000</FormLocationX>
    <FormLocationY>-32000</FormLocationY>
    <FormMaximized>false</FormMaximized>
    <FormSizeX>199</FormSizeX>
    <FormSizeY>34</FormSizeY>

These are located in the Settings.xml file. This resulted in the window showing up in the very top left corner of my screen, very small, though it did still show up. Not sure if that could be what's going on? You can try deleting those lines from your Settings.xml to see if that helps anything. If it's not showing up at all though, then it looks like I have a bug to fix.

Share this post


Link to post
Share on other sites
8 hours ago, Jason Carr said:

I checked out your data @Bleu_Skie. When I loaded up .Next I noticed that the window settings were set fairly strangely:


    <FormLocationX>-32000</FormLocationX>
    <FormLocationY>-32000</FormLocationY>
    <FormMaximized>false</FormMaximized>
    <FormSizeX>199</FormSizeX>
    <FormSizeY>34</FormSizeY>

These are located in the Settings.xml file. This resulted in the window showing up in the very top left corner of my screen, very small, though it did still show up. Not sure if that could be what's going on? You can try deleting those lines from your Settings.xml to see if that helps anything. If it's not showing up at all though, then it looks like I have a bug to fix.

I deleted those lines and Next still wont open for me. Seems like it tries, but then closes itself like in that video I uploaded. Normal LB is just fine tho to be clear. I tried opening next through normal LB and through the executable. After I deleted those lines I checked again and saw this:

  <FormLocationX>0</FormLocationX>
    <FormLocationY>0</FormLocationY>
    <FormMaximized>false</FormMaximized>
    <FormSizeX>1969</FormSizeX>
    <FormSizeY>723</FormSizeY>

 

Also I did recall one other odd thing before next stopped working for me. No idea if it is related. I usually leave Launchbox up at all times on my main PC so it is easier to use with parsec if I want. Well, I was playing rocket league one day and it kept popping up saying it was updating or opening. I cant recall which, but it forced attention to LB and I had to click back in the Rocket league window to keep playing. I just closed LB while I was playing Rocket league after the 3rd or 4th time. Now I'm not sure exactly when this happened in the timeline of next not working for me, but it was unusual, so thought I'd mention it. Next was the one I had open when this was happening. It was still fine at that time.

Edited by Bleu_Skie

Share this post


Link to post
Share on other sites
3 hours ago, Bleu_Skie said:

I deleted those lines and Next still wont open for me. Seems like it tries, but then closes itself like in that video I uploaded. Normal LB is just fine tho to be clear. I tried opening next through normal LB and through the executable. After I deleted those lines I checked again and saw this:

  <FormLocationX>0</FormLocationX>
    <FormLocationY>0</FormLocationY>
    <FormMaximized>false</FormMaximized>
    <FormSizeX>1969</FormSizeX>
    <FormSizeY>723</FormSizeY>

 

Also I did recall one other odd thing before next stopped working for me. No idea if it is related. I usually leave Launchbox up at all times on my main PC so it is easier to use with parsec if I want. Well, I was playing rocket league one day and it kept popping up saying it was updating or opening. I cant recall which, but it forced attention to LB and I had to click back in the Rocket league window to keep playing. I just closed LB while I was playing Rocket league after the 3rd or 4th time. Now I'm not sure exactly when this happened in the timeline of next not working for me, but it was unusual, so thought I'd mention it. Next was the one I had open when this was happening. It was still fine at that time.

Alright, well it appears the issue is not related to your data, since I tried your data on my machine and had no issues opening it.

When you check Task Manager to see if LaunchBox is still running, keep in mind that LaunchBox will move to the Background Processes section if there's no window open. Can you check to see if LaunchBox is in the background processes after attempting to run it?

  • Thanks 1

Share this post


Link to post
Share on other sites
20 hours ago, Jason Carr said:

Alright, well it appears the issue is not related to your data, since I tried your data on my machine and had no issues opening it.

When you check Task Manager to see if LaunchBox is still running, keep in mind that LaunchBox will move to the Background Processes section if there's no window open. Can you check to see if LaunchBox is in the background processes after attempting to run it?

Well, I went to go see if it appeared in the background processes and it just simply worked. I apparently had a pretty sizable windows update last night and now LB Next works. I have no idea what solved my issue, but it seems to be something up with windows.

So thanks for looking into this. No idea what the problem was, but it resolved itself thankfully :P

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...