Jump to content
LaunchBox Community Forums

LaunchBox not that portable after all?


Recommended Posts

Hi,

Installed LaunchBox on a local drive, ran fine, copied the LaunchBox folder to a networked drive location (I have lots of PCs spread around the house). Ran it, using the same PC(So dependencies are fine) but from a remote folder instead and got the following error...

 

An attempt was made to load an assembly from a network location which would have caused the assembly to be sandboxed in previous versions of the .NET Framework. This release of the .NET Framework does not enable CAS policy by default, so this load may be dangerous. If this load is not intended to sandbox the assembly, please enable the loadFromRemoteSources switch. See http://go.microsoft.com/fwlink/?LinkId=155569 for more information.

App:     LaunchBox
Version: 8.3
Type:    System.NotSupportedException
Site:    System.Reflection.RuntimeAssembly nLoadFile(System.String, System.Security.Policy.Evidence)
Source:  mscorlib

   at System.Reflection.RuntimeAssembly.nLoadFile(String path, Evidence evidence)
   at System.Reflection.Assembly.LoadFile(String path)
   at (Object , ResolveEventArgs )
   at Unbroken.LaunchBox.Desktop.Program.CurrentDomainAssemblyResolve(Object sender, ResolveEventArgs args)
   at System.AppDomain.OnAssemblyResolveEvent(RuntimeAssembly assembly, String assemblyFullName)

Recent Log:

   16:41:17 Exception

Seems to have a problem with the .Net loadFromRemoteSources compile switch?

Link to post
Share on other sites
  • 2 months later...

I found a solution to this problem. 

.NET framework does not allow assemblies to be loaded from a network location.

You can modify this behaviour by doing the following:

Edit Launchbox.exe.config

place the following line below <runtime>

<loadFromRemoteSources enabled="true"/>

You can also do this for bigbox.exe.config

  • Like 3
  • Thanks 1
Link to post
Share on other sites
  • 2 months later...
  • 8 months later...

I have come here to specifically reply to this, as a thanks, for helping me resolve my issue. For some reason, (Windows 10 update?) LaunchBox would crash during the "initializing" phase of booting up (after clicking the .exe). I enabled logs, checked them and confirmed what was written above. I used the above fix and it worked. Thanks @arsim2222.

Cheers

Link to post
Share on other sites
  • 8 months later...
  • 7 months later...
  • 4 weeks later...
On 12/23/2020 at 10:17 AM, tritanium1 said:

This workaround was broken by the latest update and move to .NET core libraries.  Anyone know of a new workaround?

Create a Symbolic Link to the network share, from a local directory. I have mine under my user directory as though it was installed locally, though it doesn't really seem to matter.

 

When you access it through the Symbolic Link, it appears as good as if it were installed locally.

 

Theres probably some issue with pathing or something that gets resolved when the path is "local"

Link to post
Share on other sites
  • 2 weeks later...
  • 4 weeks later...
On 1/30/2021 at 3:08 PM, cleverest said:

Just had the same issue with my Synology NAS mapped folder...thanks for posting this, but I really wish this could be fixed without using Symbolic links.

For me to get this to work without symbolic links, I added the NAS to my trusted sites. So:

Windows key>Internet Options>Security>Local Intranet>Sites>Advanced>Add this website to the zone>"your nas">Add

in my case I added "\\QNAP", it automatically changed to a file://qnap, but worked immediately.

Edited by matris
  • Like 1
Link to post
Share on other sites

LaunchBox is not intended to be used from a NAS which if you got it working that's great but I doubt you will find official support documentation for it since its outside of the intended use case.

Link to post
Share on other sites
  • 2 weeks later...

I understand that it is maybe outside of the intended use case, but it's for me the only way to manage/control my 22TB Launchbox installation. Besides the problems I had that were mentioned above it is running perfectly fine now. Especially since I have added SSD caching to my NAS and upgraded to a 10Gbit network backbone.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...