Jump to content
LaunchBox Community Forums
Jason Carr

8.8-beta-1 Released

Recommended Posts

@Jason Carr

Do you think , you could make Parents categories start "colapsed" instead of expanded? Its really painfull to scroll or colapse each time when adding new item to it

 

expanded.jpg

P.S

That's playlists

Edited by Undertherainbow

Share this post


Link to post
Share on other sites
3 minutes ago, Undertherainbow said:

@Jason Carr

Do you think , you could make Parents categories start "colapsed" instead of expanded? Its really painfull to scroll or colapse each time when adding new item to it

 

expanded.jpg

I can't say that's on the top of my priority list, but okay lol. I have to have at least the items that are checked visible/parents expanded so that it's not confusing, so I can't just always collapse everything.

Share this post


Link to post
Share on other sites
2 minutes ago, Jason Carr said:

I can't say that's on the top of my priority list, but okay lol. I have to have at least the items that are checked visible/parents expanded so that it's not confusing, so I can't just always collapse everything.

checked items expanded is fine. Just not all. In case of tons of playlists it makes job superb tedious , edit>scrolls down ..ops missed it, scroll up.. :)

Edited by Undertherainbow

Share this post


Link to post
Share on other sites
2 hours ago, Jason Carr said:

Unfortunately, showing both games and platforms/categories/playlists in the same view would be a major change in Big Box, and would probably break all the themes, so it's not something that we're likely to do any time soon. The solution that I would recommend is to simply add an All Games playlist under the platform.

That is what I did with the Atari 2600 entry, it's a playlist of all the games in the Atari 2600 platform which is a work around for now but I do hope you can do it the way I was suggesting. It would look and function much better.

Share this post


Link to post
Share on other sites
12 minutes ago, Jason Carr said:

Please be clear on whether you're referring to platforms, platform categories, or playlists. Also, a screenshot of your structure would be helpful.

I apologize for that I know better..My situation is rectified it dint save the first couple it appers 

  • Like 1

Share this post


Link to post
Share on other sites

OK so I created a Platform called Atari. I set the parent as Consoles i then added 2600.7800 etc. I then created another platform called prototypes.All worked perfect.i clicked on the Atari tab pic attached and an error popped up then the system disappeared,PIc Attached.

Capture.PNG

Capture1.PNG

Share this post


Link to post
Share on other sites
1 minute ago, rexryan said:

OK so I created a Platform called Atari. I set the parent as Consoles i then added 2600.7800 etc. I then created another platform called prototypes.All worked perfect.i clicked on the Atari tab pic attached and an error popped up then the system disappeared,PIc Attached.

Capture.PNG

Capture1.PNG

Hmm, can you zip up and PM me your LaunchBox\Data folder? Also, keep in mind that if you're creating something like Prototypes, it shouldn't be a Platform; it should be a playlist instead. Not sure if that has anything to do with the issues.

Share this post


Link to post
Share on other sites

OK maybe i am missing something but still get error when creating new playlist or category  :  "You must specify at least one location for this playlist to display in Platform Categories."

But i cant see nothing only this :

1.thumb.jpg.606dd1d6dbd405f1a8c826c37763a05d.jpg

Share this post


Link to post
Share on other sites
2 hours ago, Jason Carr said:

Beta 2 is out now with fixes for the above issues:

- Deleting things should no longer cause errors

- Playlists and platforms should now show correctly in the root in Big Box (if you locate them there)

The only known remaining issue regarding the new nested stuff is that if you delete a parent that has children, sometimes you can orphan the children. I'll probably fix this in a future beta just by throwing them in the root in that case. I also still need to modify the right-click menu in the sidebar.

Ok, now the Platforms are shown in the root. But now the contents of the root folder are not sorted correctly in BigBox. I don't know in which order they are listed. It seems to be random.

Edited by deliyuerek85

Share this post


Link to post
Share on other sites
Just now, deliyuerek85 said:

Ok, now the Platforms are shown in the root. But now the contents of the root folder are not sorted correctly. I don't know in which order they are listed. It seems to be random.

Yeah I was just about to post about this as well. I set my Recently Played playlist to show up in platform category view but it doesn't to go in order properly once I go into Big Box. It goes Arcade, Recently Played, Computers, Consoles and such. Sorting titles don't seem to work at all for playform categories in big box for me, not sure if they did before or not, can't remember now.

Share this post


Link to post
Share on other sites

Brilliant update Jason! This feature will take the organisational capabilities of Launchbox onto another level. Nice work. Sounds like the teething issues are being addressed pretty pronto too.

Going to try it out as soon as the update has finished. Quick question - there's a lot of talk about nesting categories & platforms etc. Can it be used to group ROMs? For example, having USA and JAP under NES, for example?

Share this post


Link to post
Share on other sites
4 hours ago, Jason Carr said:

IDo you mean on the add/edit screens or in the sidebar?

On the Add/Edit Parents Tab if possible please.

Share this post


Link to post
Share on other sites

Just loaded up the new beta (8.2) for the first time. 2 of my platform categories (computers and consoles) just show 0. There used to be 5 or 6 platform in each before! Any advice? See pic:

 

Capture.JPG

EDIT: switching around the view settings seems to have fixed it!

Edited by Dan

Share this post


Link to post
Share on other sites

@Jason Carr Had some serious performance issues with Beta 1/2, LaunchBox would load and just be be blank for about 5 seconds, then populate, also in BB in Platform Category mode, Video loading was terrible to where some would take 5 seconds to catch up to what video to actually play.

I rolled back to 8.7 and all the performance issue were gone everything really snappy and no issues in BB at all.

Love the new feature, but for me the performance hit is too much, watching system monitor was seeing LB/BB spiking to around 80% cpu usage and staying that way for extended periods even if i left LB sitting doing nothing, took some time to fall off (this wasn't all the time).

I would say maybe it was an issue my end, but rolling back to 8.7 fixed all the issues i was having.

Share this post


Link to post
Share on other sites

One small bug I noticed just now. After adding a sub-category under Atari 7800 within the category "Classics". It doesn't show all systems within the folder-tree like before, as shown here. Even after I remove the same sub-category, it still reads "No results were found". Nothing major but certainly noticeable🙄

Untitled-1.thumb.jpg.c481bbda2f8f8daa1171cd1dba2c1d1b.jpgUntitled-2.thumb.jpg.a591c7bc3bb92e56d1c9a190faf096a5.jpg

Share this post


Link to post
Share on other sites

I have noticed, that the games in the Playlists are not sorted correctly in BigBox. For example, I have a playlist, where the games should be sorted by "Date added". But they are now sorted randomly. But that issue is only in BigBox.

Another bug that I have discovered is, that my playlists, where the games should listed, that are released between a specific time period, are not populated anymore:

Unbenannt1.thumb.JPG.f82d38b9d893583c0a1db93fc51dc76c.JPG

But in the edit menu they can be seen:

Unbenannt2.thumb.JPG.43ba3a83a1e151a4fe95da3ca1341ca3.JPG

Share this post


Link to post
Share on other sites

OK i fixed manually platform categories but still have this :

1.thumb.jpg.b8978abb41f14cbde70ced7fecd7a66a.jpgCant see top layer of text. (3840x2160) 300% scale windows 10

EDIT: in 1024x768 100% scale i can see all text

Edited by PattersonCZ
add new info

Share this post


Link to post
Share on other sites
8 hours ago, PattersonCZ said:

OK i fixed manually platform categories but still have this :

1.thumb.jpg.b8978abb41f14cbde70ced7fecd7a66a.jpgCant see top layer of text. (3840x2160) 300% scale windows 10

EDIT: in 1024x768 100% scale i can see all text

I had this problem as well, disabling dpi scaling for launchbox.exe fixed it

Edited by mdreffet

Share this post


Link to post
Share on other sites
44 minutes ago, mdreffet said:

I had this problem as well, disabling dpi scaling for launchbox.exe fixed it

didnt work , i try  “Override high DPI scaling behavior”  by application - not work , nothing changed
                                                                                                            by system - work but blurry
                                                                                                            by system advanced - just broke launchbox

 

i dont have disable dpi scaling in win10 only options above

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...