Jump to content
LaunchBox Community Forums
Lordmonkus

BigBox Input Lag Investigation

Recommended Posts

@Z3R0B4NG If you look at my first post in this thread there is a link to another thread where someone posted a video of the specific issue. 

  • Thanks 1

Share this post


Link to post
Share on other sites

Hey all, I'm diving into this today. I've done some significant testing on three systems so far, the oldest of which is a Core 2 Duo. I've had the best luck getting hitches on that system, but only in the platforms/categories lists (not in the games lists). I'm still not sure if I'm seeing the same problem, as typically I get the hitches about three times in the platforms lists and then they go away completely until I close out and restart.

My current question is this: what views and themes are you using when it occurs? Are you using the text lists or the clear logo wheels? Or CoverFlow?

I know @noiseordinance was experiencing the issue in the text game lists (videos are posted in the other thread). I need to test them with that particular theme though. What theme is that @noiseordinance?

At least in some cases, it seems that the hitches are being caused by Big Box trying to load details for the selected game or platform while scrolling to other games/platforms. It still escapes me why I don't experience those issues though on any of my machines. I might just have to try some blind changes here again to try and get this fixed.

Share this post


Link to post
Share on other sites
5 minutes ago, Jason Carr said:

Hey all, I'm diving into this today. I've done some significant testing on three systems so far, the oldest of which is a Core 2 Duo. I've had the best luck getting hitches on that system, but only in the platforms/categories lists (not in the games lists). I'm still not sure if I'm seeing the same problem, as typically I get the hitches about three times in the platforms lists and then they go away completely until I close out and restart.

My current question is this: what views and themes are you using when it occurs? Are you using the text lists or the clear logo wheels? Or CoverFlow?

I know @noiseordinance was experiencing the issue in the text game lists (videos are posted in the other thread). I need to test them with that particular theme though. What theme is that @noiseordinance?

At least in some cases, it seems that the hitches are being caused by Big Box trying to load details for the selected game or platform while scrolling to other games/platforms. It still escapes me why I don't experience those issues though on any of my machines. I might just have to try some blind changes here again to try and get this fixed.

Could it be BigBox/Settings/Views/ Wheel-Coverflow minimum speed settings and/or Wheel Easing settings impacting some users? If I set it lower than 200 milliseconds and wheel easing to off it gets more choppier on my system and theme so I leave those on 200 milliseconds and wheel easing to on, not sure if these are the default settings.

Share this post


Link to post
Share on other sites
6 minutes ago, Mr. RetroLust said:

Could it be BigBox/Settings/Views/ Wheel-Coverflow minimum speed settings and/or Wheel Easing settings impacting some users? If I set it lower than 200 milliseconds and wheel easing to off it gets more choppier on my system and theme so I leave those on 200 milliseconds and wheel easing to on, not sure if these are the default settings.

That is a very good point. Would be good to hear what people's settings are, assuming they're experiencing the issue with the wheels.

1 minute ago, noiseordinance said:

@Jason Carr I have since switched to the default theme and have all transitions turned off. No improvement.

Are there any themes out there that bypass all images and videos that I can test on?

What views are you using with the default theme? The text lists or the clear logo wheels? I'm not aware of any themes that bypass everything, unfortunately. That would be interesting to test though. What you could do is copy your LaunchBox with the data to a new folder, and just don't copy any media. It should be fairly small without media.

Share this post


Link to post
Share on other sites
1 minute ago, Jason Carr said:

What views are you using with the default theme? The text lists or the clear logo wheels? I'm not aware of any themes that bypass everything, unfortunately. That would be interesting to test though. What you could do is copy your LaunchBox with the data to a new folder, and just don't copy any media. It should be fairly small without media.

I typically use text list views only. I'll do what you recommended tonight about copying Launchbox over. Thanks!

  • Like 1

Share this post


Link to post
Share on other sites

Alright, a new beta is out that I'm hoping will improve things, but honestly it's still a bit of a shot in the dark. It does seem to have improved things on my slowest machines, but I'm not necessarily convinced that I ever had the problem on my machines to begin with.

Regardless, if you've been experiencing controller lag, please test the new beta and let me know how it goes. We'll have to do some extensive testing before we can confirm if the issue is really fixed, since it seems to be somewhat sporadic for the folks that it affects.

  • Like 1

Share this post


Link to post
Share on other sites

OK, i've seen the videos, i am positive i never had that specific problem.  
but from looking at it, i see 2 things happening there.  
first the controller lags / slows down or stops temporarily, second this happens just long enough so a game entry is selected and the next video and media is loaded by BigBox, which then again slows everything down just enough to interrupt the motion some more.  
The game entries that are being loaded would not be loaded if the motion was smooth to begin with, so that loading part makes the problem worse but is only a side effect, not the cause for the problems, technically you should just scroll through the names list on the side without anything else happening.  

...plus it works fine with the keyboard in those videos without changing any settings or whatever, so i think we can 100% exclude a performance problem here (PC or BigBox!), the problem has to be the controller input specifically.  

So lets start with making sure the Controller itself isn't the cause.  
Go to your Game Controller Settings  

gamepad_properties_1.png

and make sure the D-pad signal isn't interrupted or flickering while pressed.  
What you see here is exactly the input BigBox should be getting from the pad.  

It would probably be best if you could display that window on a second monitor while having BigBox doing its thing on the other screen
so you can observe the input from the pad while the lag in BigBox is happening.  

I just think a hardware issue would explain why some people have this problem but most don't, it might be a defective D-Pad, it might be a defective Xbox wireless receiver, or just the signal being interrupted by outside sources, it might be a USB bandwidth problem etc. all stuff that can easily happen to more than one person, but would not happen to everyone at the same time.  

So, please check this on your end and report back. (and it would be good if two or three people would test this, just to be on the safe side).  

Share this post


Link to post
Share on other sites
1 minute ago, Z3R0B4NG said:

OK, i've seen the videos, i am positive i never had that specific problem.  
but from looking at it, i see 2 things happening there.  
first the controller lags / slows down or stops temporarily, second this happens just long enough so a game entry is selected and the next video and media is loaded by BigBox, which then again slows everything down just enough to interrupt the motion some more.  
The game entries that are being loaded would not be loaded if the motion was smooth to begin with, so that loading part makes the problem worse but is only a side effect, not the cause for the problems, technically you should just scroll through the names list on the side without anything else happening.  

...plus it works fine with the keyboard in those videos without changing any settings or whatever, so i think we can 100% exclude a performance problem here (PC or BigBox!), the problem has to be the controller input specifically.  

So lets start with making sure the Controller itself isn't the cause.  
Go to your Game Controller Settings  

gamepad_properties_1.png

and make sure the D-pad signal isn't interrupted or flickering while pressed.  
What you see here is exactly the input BigBox should be getting from the pad.  

It would probably be best if you could display that window on a second monitor while having BigBox doing its thing on the other screen
so you can observe the input from the pad while the lag in BigBox is happening.  

I just think a hardware issue would explain why some people have this problem but most don't, it might be a defective D-Pad, it might be a defective Xbox wireless receiver, or just the signal being interrupted by outside sources, it might be a USB bandwidth problem etc. all stuff that can easily happen to more than one person, but would not happen to everyone at the same time.  

So, please check this on your end and report back. (and it would be good if two or three people would test this, just to be on the safe side).  

Though this is possible, it's not very likely. I think people would be having horrible issues in games if the controller drivers were hitching like that.

More than likely it's a thread prioritization issue in Big Box, which I'm certainly hoping is fixed in the latest beta (but like I said, I can't even really test for it).

Still, thanks for diving into this @Z3R0B4NG.

Share this post


Link to post
Share on other sites

First rule of Tech Support, turn it off and on again, second rule: make sure the cables/connections are plugged in/working as intended. 😜 

  • Like 1

Share this post


Link to post
Share on other sites

@Jason Carr I had a bit of time to play around tonight. So first thing is I removed the media directories from Launchbox and loaded Bigbox. As expected all images and videos were absent. The unresponsive controller issue persisted using the default theme.

Then I loaded the beta. Everything was running beautifully on first launch, going in and out of games. But when I shut down the app and then restarted it the unresponsive controller issue reemerged. It's sort of the same thing that happened with the prior betas where things initially felt like they were running smoothly but shortly after the problem would recur. I don't know if that makes things more or less difficult to figure out? Sorry. :/

I ran the controller config recommended by @Z3R0B4NG and there was no stuttering of the D-pad or joystick, though I don't have a second monitor to run the config on simultaneously. Is there a way to open Bigbox in windowed mode to see if the controller input is stuttering while Bigbox is loaded?

Share this post


Link to post
Share on other sites
9 hours ago, noiseordinance said:

@Jason Carr I had a bit of time to play around tonight. So first thing is I removed the media directories from Launchbox and loaded Bigbox. As expected all images and videos were absent. The unresponsive controller issue persisted using the default theme.

Then I loaded the beta. Everything was running beautifully on first launch, going in and out of games. But when I shut down the app and then restarted it the unresponsive controller issue reemerged. It's sort of the same thing that happened with the prior betas where things initially felt like they were running smoothly but shortly after the problem would recur. I don't know if that makes things more or less difficult to figure out? Sorry. :/

I ran the controller config recommended by @Z3R0B4NG and there was no stuttering of the D-pad or joystick, though I don't have a second monitor to run the config on simultaneously. Is there a way to open Bigbox in windowed mode to see if the controller input is stuttering while Bigbox is loaded?

Well that is telling at least. If Big Box isn't loading any media, you would think that it's not a performance issue that's causing the problem, at least in your case. I'm starting to think maybe @Z3R0B4NG is right. ;)

We may also have a couple different issues here for different people, which could be why this has been such a disaster to solve.

  • Haha 1

Share this post


Link to post
Share on other sites
9 hours ago, noiseordinance said:

@Jason Carr I had a bit of time to play around tonight. So first thing is I removed the media directories from Launchbox and loaded Bigbox. As expected all images and videos were absent. The unresponsive controller issue persisted using the default theme.

Then I loaded the beta. Everything was running beautifully on first launch, going in and out of games. But when I shut down the app and then restarted it the unresponsive controller issue reemerged. It's sort of the same thing that happened with the prior betas where things initially felt like they were running smoothly but shortly after the problem would recur. I don't know if that makes things more or less difficult to figure out? Sorry. :/

I ran the controller config recommended by @Z3R0B4NG and there was no stuttering of the D-pad or joystick, though I don't have a second monitor to run the config on simultaneously. Is there a way to open Bigbox in windowed mode to see if the controller input is stuttering while Bigbox is loaded?

You know what, can you zip up and PM me your LaunchBox\Data folder? For all we know it could be specific to your collection.

Share this post


Link to post
Share on other sites

@noiseordinance So this is an interesting development:

Not sure if it will really help to solve things, but if there's a way to change controller priority settings for actual 360/Xbone controllers, that could explain why some people are having issues.

Share this post


Link to post
Share on other sites

I've been using Xpadder for the past couple of days with a lag free experience, which tells me that at least the problem doesn't rely on the controller signal making it to my computer. Only major thing I lose going this route is controller automation through Bigbox to close apps like Retroarch, Mame, and the like. But I think for now I'm just going to program escape commands in Xpadder and skip Bigbox's implementation of controller support. Thanks to those who are investigating this!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...