Jump to content
LaunchBox Community Forums
Jason Carr

8.9-beta-1 Released

Recommended Posts

The first 8.9 beta is out now with the following:

- Improvement: Empty playlists will now show up in the LaunchBox sidebar when viewing platform categories; this should reduce confusion when adding a new playlist and leaving it empty

- Improvement: When manually adding a new platform via right-click in the platform categories list, LaunchBox will now warn you that it's not recommended to manually add platforms and to use the import processes instead. It also warns the user that categories and playlists should be used instead of platforms for nesting purposes.

- Fixed: Add to Playlist functionality was accidentally still restricted to premium

- Fixed: Editing a playlist that had no parents was putting it back into the root by default

- Translation updates

The current plan is to put out a bugfix release on Wednesday, assuming these betas go well. These updates/fixes aren't major issues, but they have caused enough confusion to warrant a bugfix release. Let me know how this beta fairs.

  • Like 6
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Hi @Jason Carr

in the new beta I still have the issue with the 'year' playlists. 🙁

Unbenannt1.thumb.JPG.f82d38b9d893583c0a1db93fc51dc76c.JPG

In the edit window the games are there.

Unbenannt2.thumb.JPG.43ba3a83a1e151a4fe95da3ca1341ca3.JPG

Edited by deliyuerek85

Share this post


Link to post
Share on other sites
18 minutes ago, deliyuerek85 said:

Hi @Jason Carr

in the new beta I still have the issue with the 'year' playlists. 🙁

Unbenannt1.thumb.JPG.f82d38b9d893583c0a1db93fc51dc76c.JPG

In the edit window the games are there.

Unbenannt2.thumb.JPG.43ba3a83a1e151a4fe95da3ca1341ca3.JPG

Thanks for the reminder. I *think* this is a culture issue and I think I have it fixed for the next beta. I can't replicate it on my end though, so you'll have to let me know once the beta comes out, probably tomorrow.

Share this post


Link to post
Share on other sites
Posted (edited)

@Jason Carr

Yes, I think too that it has to do with the date format of my country or something. I live in germany an our date format is dd.mm.yyyy. I will let you know if it is fixed in the next beta. Thanks!

Edited by deliyuerek85
  • Like 1

Share this post


Link to post
Share on other sites

Beta 2 is out now with some translation updates and a hopeful fix for @deliyuerek85's issue above. I'm not aware of any other serious issues since yesterday's beta, so hopefully that's accurate. The plan is still to put out the 8.9 bugfix release tomorrow.

  • Like 1

Share this post


Link to post
Share on other sites

Jason: continuing the testing plan from the 8.8 thread. I am now on 8.9 full release. This is the latest from you, correct?

Share this post


Link to post
Share on other sites
1 minute ago, Bedwyr said:

Jason: continuing the testing plan from the 8.8 thread. I am now on 8.9 full release. This is the latest from you, correct?

Yes

Share this post


Link to post
Share on other sites

Ok, under 8.9 the behavior did not repeat. I could probably confirm that by running the tests once more with an update pending.

  • Like 1

Share this post


Link to post
Share on other sites

Still having the problem of certain media not showing in the game details pane. For example, many of my NES games have a front cart image, but they are not showing in the game details pane.

Share this post


Link to post
Share on other sites
On 10/10/2018 at 5:44 PM, Bedwyr said:

Ok, under 8.9 the behavior did not repeat. I could probably confirm that by running the tests once more with an update pending.

Okay, very good to know. I think it's safe to assume that it's being caused by the update popup somehow. I'll look into that. Thanks for all that testing @Bedwyr.

3 hours ago, Dan said:

Still having the problem of certain media not showing in the game details pane. For example, many of my NES games have a front cart image, but they are not showing in the game details pane.

The game details sidebar has never shown *all* types of media, though I agree that it probably should, or at least we should provide the option. I believe that currently it just shows screenshots and fanart.

Share this post


Link to post
Share on other sites
3 hours ago, Dan said:

Still having the problem of certain media not showing in the game details pane. For example, many of my NES games have a front cart image, but they are not showing in the game details pane.

 You can force it by adding those image types to either the Screenshot or Fanart image priorities.image.thumb.png.2c5f4797af5efc50fd6ab50a4e231a47.png

Share this post


Link to post
Share on other sites
9 minutes ago, neil9000 said:

 You can force it by adding those image types to either the Screenshot or Fanart image priorities.image.thumb.png.2c5f4797af5efc50fd6ab50a4e231a47.png

Yes, but there will be some side effects to that, so that's not really recommended.

Share this post


Link to post
Share on other sites
1 minute ago, Jason Carr said:

Yes, but there will be some side effects to that, so that's not really recommended.

Fair enough.

Share this post


Link to post
Share on other sites

Well at least that explains the behaviour. Look forward to the ability to see all the game details & media. Also, some better way to view the files, rather than having to scroll right down, would be good!

Edited by Dan

Share this post


Link to post
Share on other sites

BTW, what image source are you guys using for 3D boxes? Mine are much more angled; this might be a decent in-between appearance.

Share this post


Link to post
Share on other sites
1 minute ago, Bedwyr said:

BTW, what image source are you guys using for 3D boxes? Mine are much more angled; this might be a decent in-between appearance.

If you mean the snes one specifically, they are from emumovies, as you say the ones on our database are much more slanted, i dont like them personally.

Share this post


Link to post
Share on other sites

I think the slanty ones are Hyperspin in origin. I have subs to both.

Share this post


Link to post
Share on other sites
3 minutes ago, Bedwyr said:

I think the slanty ones are Hyperspin in origin. I have subs to both.

Maybe, but they scrape from our database, i just uncheck 3D box from our database and grab them from emumovies.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×