Jump to content
LaunchBox Community Forums

9.0-beta-1 Released


Jason Carr

Recommended Posts

it seems like my arcade area is loading & searching much slower from b4 to b5(i just loaded 6 and its the same). I tried dumping my image cache but it still seems like there is a lag.

when the system starts up the sidebar is completely loaded but it takes a good 14 seconds to load the ROM images in the center area.

also, searching seems to take more time than normal about 10 seconds to start searching.

I've never "noticed" LB being slow til now.

Video: https://www.dropbox.com/s/a4viiobwgpuyey0/lb.mov?dl=0

 

Edited by natemac00
Link to comment
Share on other sites

Just played around a bit with the auto-generated child playlists thing. Very cool, I like it. But I have found a couple of things but I'll be brief. Make a set of playlists under a category and then delete the category and those child playlists will then be displayed in the root of the sidebar instead of also being deleted. Somehow doing this also grabbed my GameCube platform and showed a copy in the root instead of being under consoles. Deleting the dupe also deleted the original forcing me to reimport my GameCube sets. Just thought you should know that it took me maybe 90 seconds to break it, I seem to be very good at breaking stuff. :P I knew it would be buggy so was prepared to fiddle and I only tested with one platform just in case, but it taking my GameCube and making a dupe was very unexpected. Anyways, Thanks! Looking forward to being able to use this feature to it's fullest! ?

  • Like 1
Link to comment
Share on other sites

you should have just right clicked the GC platform that was in the root went to edit then went to the parent tab and removed the check box from the root instead of deleting it but hopefully Jason can get those issues worked out so it doesn't happen at all.

Link to comment
Share on other sites

21 hours ago, Jason Carr said:

Please remember that this is a beta release. Testing is needed with the new clean up media process, but please make sure you make a backup first, just in case.

I've spent the last 2 hours testing the new clean up media process by comparing the files that were deleted after the completion of this process. So far all the deleted files were media files that are no longer matching roms that are currently present on my system. This is expected because I regularly get updated No-Intro dat files to update my sets and as a result, new roms are added, some are renamed and others are deleted. When that happens, I delete the games for that platform in LB and re-run the import process to prevent dead references.

I will continue to test for a few more hours but I did encounter a problem which I feel is worth mentioning.

No-Intro sometime uses the the tilde character "~" as a separator in their filenames and this causes the import process to fail in finding a match for a game title. In the test below, the correctly named file "Air-Sea Battle ~ Target Fun (USA).rar" was duplicated and renamed to "Air-Sea Battle - Target Fun (USA).rar" so that I can test how the import wizard behaves with the presence of those file separators. I then imported both files to see how the import process would react. Sure enough, LB was able to recognize the file with the dash "-" but unfortunately failed to import media and metadata for the file with the tilde "~".

I hope this is something that can be fixed but I understand that you have many other priorities and this may have to wait. I hope this can be added to your todo list. ?   

2018-10-31_16-25-53.thumb.png.5e4e95d1e2a216060e93ab956fabbfb4.png2018-10-31_16-28-08.thumb.png.022bac488025f8c262ffa82ab3e4394b.png 

  • Like 1
Link to comment
Share on other sites

18 hours ago, natemac00 said:

it seems like my arcade area is loading & searching much slower from b4 to b5(i just loaded 6 and its the same). I tried dumping my image cache but it still seems like there is a lag.

when the system starts up the sidebar is completely loaded but it takes a good 14 seconds to load the ROM images in the center area.

also, searching seems to take more time than normal about 10 seconds to start searching.

I've never "noticed" LB being slow til now.

Video: https://www.dropbox.com/s/a4viiobwgpuyey0/lb.mov?dl=0

 

I found some slow downs that I just fixed for the next beta. Stay tuned.

15 hours ago, cammelspit said:

Just played around a bit with the auto-generated child playlists thing. Very cool, I like it. But I have found a couple of things but I'll be brief. Make a set of playlists under a category and then delete the category and those child playlists will then be displayed in the root of the sidebar instead of also being deleted. Somehow doing this also grabbed my GameCube platform and showed a copy in the root instead of being under consoles. Deleting the dupe also deleted the original forcing me to reimport my GameCube sets. Just thought you should know that it took me maybe 90 seconds to break it, I seem to be very good at breaking stuff. :P I knew it would be buggy so was prepared to fiddle and I only tested with one platform just in case, but it taking my GameCube and making a dupe was very unexpected. Anyways, Thanks! Looking forward to being able to use this feature to it's fullest! ?

Most of that is by design, sans for the fact that GameCube started showing up in the root; I'm not sure why that would happen if you're removing a category underneath GameCube (but maybe I'm understanding that incorrectly). This does raise some important usability concerns though:

  • Thinking that deleting an item will only delete it in one spot is incorrect
  • Thinking that deleting an item will delete its children is incorrect

I guess both of those have to do with deletes, so perhaps we just need to make the deletion process more clear, or at least put in warnings (that people will probably never read... ;)

Link to comment
Share on other sites

30 minutes ago, Pacman56 said:

I've spent the last 2 hours testing the new clean up media process by comparing the files that were deleted after the completion of this process. So far all the deleted files were media files that are no longer matching roms that are currently present on my system. This is expected because I regularly get updated No-Intro dat files to update my sets and as a result, new roms are added, some are renamed and others are deleted. When that happens, I delete the games for that platform in LB and re-run the import process to prevent dead references.

I will continue to test for a few more hours but I did encounter a problem which I feel is worth mentioning.

No-Intro sometime uses the the tilde character "~" as a separator in their filenames and this causes the import process to fail in finding a match for a game title. In the test below, the correctly named file "Air-Sea Battle ~ Target Fun (USA).rar" was duplicated and renamed to "Air-Sea Battle - Target Fun (USA).rar" so that I can test how the import wizard behaves with the presence of those file separators. I then imported both files to see how the import process would react. Sure enough, LB was able to recognize the file with the dash "-" but unfortunately failed to import media and metadata for the file with the tilde "~".

I hope this is something that can be fixed but I understand that you have many other priorities and this may have to wait. I hope this can be added to your todo list. ?   

2018-10-31_16-25-53.thumb.png.5e4e95d1e2a216060e93ab956fabbfb4.png2018-10-31_16-28-08.thumb.png.022bac488025f8c262ffa82ab3e4394b.png 

Good catch. I'll add this to my list. Since dashes are working, I think it should be easy enough just to replace tildes with dashes.

Link to comment
Share on other sites

Beta 7 is out now with the following:

- Improvement: When bulk editing the associated emulator for games, LaunchBox will now automatically update the emulator for all additional apps that are also set to use the same emulator as the parent game

- Improvement: Resolved more platform category and playlist-specific performance issues in Big Box

- Fixed: The LaunchBox sidebar count was not updating when the games list is populated and the count is refreshed

- Fixed: Game controllers were not navigating the drop-down lists in the Big Box filters popup

- Fixed: Big Box was still sometimes creating unnecessary/irrelevant empty video folders for playlists

- Fixed: The emulators list when bulk editing games was not sorted alphabetically

- Fixed: Additional applications in the LaunchBox game right-click menu were sometimes using the icon from the game's emulator instead of the icon from the additional application's emulator

  • Like 7
Link to comment
Share on other sites

10 minutes ago, natemac00 said:

Just tried the bulk editing in beta 7, still didn’t work for me.

vid: https://www.dropbox.com/s/q4ku73gwdqe6cfi/ScreenRecording_10-31-2018 16-58-26.MP4?dl=0

It looks like this is because the emulator on the game does not match the emulator on the additional apps.

40 minutes ago, Jason Carr said:

- Improvement: When bulk editing the associated emulator for games, LaunchBox will now automatically update the emulator for all additional apps that are also set to use the same emulator as the parent game

This is an important distinction because it allows you to change the emulator for a single app, and those will not be automatically updated with bulk edit.

Link to comment
Share on other sites

8 minutes ago, Jason Carr said:

It looks like this is because the emulator on the game does not match the emulator on the additional apps.

This is an important distinction because it allows you to change the emulator for a single app, and those will not be automatically updated with bulk edit.

I had this discussion in another post.

if I double click on the game and it is set to open up Rev.A it will open it up in Demul. But if I right-click on the game and choose to open up the same Rev.A it now opens it up in MAME.

is there an instance where I would even want different revision of a game to use different emulators?

 You already have ‘open with’ option to change emulators on the fly...  if I’m bulking editing, shouldn’t it bulk edit everything?

im not saying I’m right, just trying to make my case.

Link to comment
Share on other sites

6 minutes ago, natemac00 said:

I had this discussion in another post.

if I double click on the game and it is set to open up Rev.A it will open it up in Demul. But if I right-click on the game and choose to open up the same Rev.A it now opens it up in MAME.

is there an instance where I would even want different revision of a game to use different emulators?

 You already have ‘open with’ option to change emulators on the fly...  if I’m bulking editing, shouldn’t it bulk edit everything?

im not saying I’m right, just trying to make my case.

I'd say the only reason it's an issue currently is because you previously used the bulk edit when it didn't automatically update the additional apps. The solution is easy; just batch edit the emulator back to the value that matches the apps, then batch edit it again to whatever you want it to be.

There are some reasons why you would want to use separate emulators. Believe it or not there are ROM versions (for arcade/MAME at least) that work better with certain versions of MAME and/or different emulators. There's also the situation where you might have emulators lined up as utilities or something of that nature. We implemented it separately in the additional apps for a reason originally, so it's not a safe assumption that they should all be the same.

  • Thanks 1
Link to comment
Share on other sites

20 minutes ago, Jason Carr said:

The solution is easy; just batch edit the emulator back to the value that matches the apps, then batch edit it again to whatever you want it to be.

This is perfect and a much better solution... and did work.

I didn’t realize if  they all looked the same it would change them all but if it saw differences it wouldn’t touch it, that’s great.

  • Like 1
Link to comment
Share on other sites

Is it me, or do the up and down buttons no longer work after pressing the 'Filter' button in BigBox? I seem to recall not having any issues on previous versions. I can still press left or right, but I can't move up or down to select  'developer,' 'genre,' etc.

Link to comment
Share on other sites

8 hours ago, Typhon said:

Is it me, or do the up and down buttons no longer work after pressing the 'Filter' button in BigBox? I seem to recall not having any issues on previous versions. I can still press left or right, but I can't move up or down to select  'developer,' 'genre,' etc.

With a keyboard or controller? Just tested both and looks to be working ok. 

Link to comment
Share on other sites

@Jason Carr I have an issue in Big Box that I think is related to the image cache. I have a Favorites playlist for each individual console, and each playlist has it's own clear logo. If I go first to let's say PlayStation Favorites, the clear logo will be correct, but if I back out and go to any other platform's favorites playlist, the clear logo will still be for PlayStation. The only way to fix this is to clear the image cache, but then it will do the exact same thing with whichever platform I go to first.

 

Untitled-1.png

Edited by Omen
Link to comment
Share on other sites

in 9.0 beta 7, the platforms that have .lnk as rom, were losing roms, even one of them remained at 0 and then disappeared, while launchbox was running (example 9 .. 5 ... 0 .. then disappeared)
The funny thing is that the .xlm is still in the DATA folder and I do not notice anything strange in its structure.
I'm not sure if something similar happened with other platforms, since those were the ones I was editing at the time that happened.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...