Jump to content
LaunchBox Community Forums
Shabbathehut

Big box controlling issues

Recommended Posts

Hi

when I navigate through the menus with my ipac 2 joystick it doesn’t move to the next game or option it skips and moves two places.

any idea on how to fix this?

Share this post


Link to post
Share on other sites

I am having the same issue.  I have it configured in an arcade cabinet with a joystick and 10 buttons, but before the joystick and buttons worked fine in big box.  I don't know if it was the latest update or some option I changed, but the joystick moves two places when going up or down as well.  Plus trying to change buttons or select games acts very weird, because I believe the buttons are being pressed twice when I press it once as well.  The joystick and buttons work fine when I am in Launchbox, steam, or when I am playing the games.  Only in Big Box is it acting weird.  Very annoying, please help.

Share this post


Link to post
Share on other sites

This might not be the issue but this sounds like steam stomping on your configuration via their "desktop configuration" or whatever they call it. I had same issue with other controllers because steam was sending keyboard commands along with the button presses. I just unmapped everything so there was essentially no desktop configuration...

Share this post


Link to post
Share on other sites

Hey UltimatePistachio, I removed the desktop configuration  like you recommended, but it didn't make a difference for me.  To add some additional details on my issue.   When I first open big box, most of the time the first player will work fine, no skipping lines or double press of buttons.  After running a game though and  returning to big box, the issues start occurring.  I found out that the second player controller works perfectly fine for using Big Box and it doesn't skip lines or double press buttons.  So not sure if anyone else has any ideas.  Thanks.

Share this post


Link to post
Share on other sites

I figured out what the issue is, but I hope that the developers could help fix the issue for me.  It happens whenever I have Steam running on my computer, bigbox recognizes the keys setup in Steam and in bigbox, causing each button press to be clicked twice.  That is why it worked sometimes normally, when steam wasn't running.  I can use my xbox controller and it works fine no problem, even when steam is running.  When I am using my custom joystick arcade stick and buttons, each button and direction is pressed twice.  I can turn off controllers in bigbox and the custom joystick arcade stick work fine in bigbox, because it is using the steam config.  Only problem with this is that the xbox controller is not recognized in bigbox when disabling controllers.

I also tried to keep controllers on in bigbox and remove them in steam, but then both the xbox controller and custom joystick arcade stick don't work in the steam games.  Please find a way to fix the configs so that custom controllers act like xbox controllers, where the buttons don't get duplicated in bigbox when running steam in the background.  Thanks.

Share this post


Link to post
Share on other sites

Good discovery here. However, I'm not 100% on what's going on. What is Steam doing exactly? Is it converting the keyboard presses from your arcade board to game controller presses? Does it work to disable game controllers in Big Box?

Share this post


Link to post
Share on other sites

Thanks for responding all, 

1. I don't know exactly what steam is doing, but if steam is open, it affects my custom controller outside of the game, but not the xbox controller.

2. It seems that when steam and big box are both open, the button or joystick presses on my custom controller are using both the big box buttons and the steam buttons. Where the xbox controller only registers a single press. 

3. So It appears that when I disable controllers on big box, the custom controller still work within big box menus, i believe using the steam button configs. The Xbox controller though doesn't work anymore within the big box menus. 

Let me know if you need me to test anything else to try and get the custom controllers to work with both the steam and big box configs on, so i can still use the Xbox controllers and use the custom controller without the buttons being pressed twice for each single press. Thanks. 

Share this post


Link to post
Share on other sites

When I had this issue I had to go through the annoying steam interface and blank out every keyboard mapping made in the desktop configuration that's in steam, there was no way to just turn that off. You might also needed to add big box to the steam library and configure the controller settings to be "forced on" and launch big box through steam. It's really sounding like you're not blanking out the desktop configuration in steam or steam added another feature that needs to be disabled somehow, or you possibly need to add Big Box to your library and set controller configuration to be "forced on" and launch it through steam.

Edited by UltimatePistachio
Launch through steam with forced on controller configuration

Share this post


Link to post
Share on other sites

It's clear that we have at least a couple different issues here for different people, and they probably have nothing to do with each other. It is really good to know that Steam can cause that kind of trouble though. @Shadow805 Do please see if you can do what @UltimatePistachio said and blank out Steam's controller settings. I'm fairly certain that that particular situation isn't really a fault of Big Box (though I could be wrong).

@omlifecrew It could be a similar situation, even if Steam isn't to blame. It could be that somehow the controller board is sending both keyboard and game controller commands. What happens if you disable game controllers in Big Box?

Share this post


Link to post
Share on other sites

Hello All, 

Sorry for late response, but been away on vacation. Anyways, ultimatepistachio, I understand what you mean by none and I was able to do that to all settings within steam and that fixed the buttons from triggering twice, but not the joystick. For some reason the joystick still seems to be going up/down/left/right twice every time it is moved once. 

I unchecked the controls in steam for my custom control and now no buttons work in big box, including in any stream games.  The joystick still works though, so i wonder if big box is seeing it and automatically giving it a direction, then it uses steams controls, which causes two directional inputs. 

Thanks for all the help, this is a minor issue with my setup and I will work around it, but I appreciate all the assistance. 

Share this post


Link to post
Share on other sites

Hi all,

 

This has not been resolved. When Steam is running (in my case Steam is launched in the background at startup) , my arcade cabinet joystick jumps two places for each single click in the Big Box menu. All buttons are triggering double actions for each single click.

When launching PC games from Big Box, instead of having 2 players (it is a DIY 2 player arcade bartop ) I end up with 4 players on screen because of all the doubled up action the controls trigger.

It is making using Big Box unusable for me. Quitting Steam does solve the double action, but then game controls don't work. It's catch 22.

Share this post


Link to post
Share on other sites
7 minutes ago, bietekwiet said:

Hi all,

 

This has not been resolved. When Steam is running (in my case Steam is launched in the background at startup) , my arcade cabinet joystick jumps two places for each single click in the Big Box menu. All buttons are triggering double actions for each single click.

When launching PC games from Big Box, instead of having 2 players (it is a DIY 2 player arcade bartop ) I end up with 4 players on screen because of all the doubled up action the controls trigger.

It is making using Big Box unusable for me. Quitting Steam does solve the double action, but then game controls don't work. It's catch 22.

You need to turn off steams desktop configuration i believe, this is steam interfering when not running a game, not a Bigbox one i think.

1850508280_Screenshot(248).thumb.png.b83c1699c13b9d2edfc5c71741514843.png

Share this post


Link to post
Share on other sites
5 minutes ago, bietekwiet said:

Hi all,

 

This has not been resolved. When Steam is running (in my case Steam is launched in the background at startup) , my arcade cabinet joystick jumps two places for each single click in the Big Box menu. All buttons are triggering double actions for each single click.

When launching PC games from Big Box, instead of having 2 players (it is a DIY 2 player arcade bartop ) I end up with 4 players on screen because of all the doubled up action the controls trigger.

It is making using Big Box unusable for me. Quitting Steam does solve the double action, but then game controls don't work. It's catch 22.

The first thing to figure out would be why your arcade controller is not working at all without Steam. Steam should never be required for any controller to work. So that's my first suggestion: get it working without Steam, especially since we know Steam to be the cause of this issue. Does your arcade board act as a keyboard or a game controller (or both)?

Share this post


Link to post
Share on other sites
2 minutes ago, neil9000 said:

You need to turn off steams desktop configuration i believe, this is steam interfering when not running a game, not a Bigbox one i think.

1850508280_Screenshot(248).thumb.png.b83c1699c13b9d2edfc5c71741514843.png

Oh, ha. Well this explains a lot lol. Thanks Neil.

Regardless, this is not a bug. It's a configuration issue where Big Box is taking input from two different places, most likely because of Steam's desktop configuration stuff shown in the screenshot above.

  • Like 1

Share this post


Link to post
Share on other sites

When I turn the controls off in Steam, the controls in some games do not work any more when launching a game from Big Box.

So either I can make the Big Box UI to be controlled properly (no double clicks) and not play PC games, OR Big Box UI will be messed up but I can play the games.

Pick your poison situation?

I get it that this is a steam issue more than  it is a Big Box issue, but is there no way that global Steam controller settings do not affect controls in Big Box?

I am not launching Big Box from Steam, so in my humble reasoning, I don't get why Steam should affect Big Box controls....

 

Edited by bietekwiet

Share this post


Link to post
Share on other sites
2 minutes ago, bietekwiet said:

When I turn the controls off in Steam, the controls in some games do not work any more when launching a game from Big Box.

So either I can make the Big Box UI to be controlled properly (no double clicks) and not play PC games, OR Big Box UI will be messed up but I can play the games.

Pick your poison situation?

I get it that it is a steam issue more than that it is a Big Box issue, but is there no way that global Steam controller settings do not affect controls in Big Box.

I am not launching Big Box from Steam, so in my humble reasoning, I don't get why Steam should affect Big Box controls....

 

I didnt say to turn off the controls in steam, i said to turn off the desktop configuration. Steam allows you to control the desktop by using a controller as a mouse, and maps the keyboard arrow keys to the left stick and enter on the A button. This is what is interfering with Bigbox. You can just disable steam having control on the desktop, all normal controls will still work in games, you will just lose the ability to do normal desktop things with the controls on your  cabinet, which im guessing you dont want to do anyway.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...