Jump to content
LaunchBox Community Forums
RetroHumanoid

Unified Refried 2.0

Recommended Posts

5 hours ago, vaderag said:

Thanks for this!

Couple of follow up questions

1) How can I know which view is being used on a particular screen? Appreciate I could trial and error but just wondering in general... (in this instance I'm looking at the very first screen you get when you boot)

2) how will I ensure that remains between updates etc (I think you mentioned of a big one upcoming following 9.4 theme changes?)

Thanks!

1) I'm not sure if there is a way to know really...other than visual queues in the artwork placement and stuff. I wouldn't mind having maybe a popup text that shows for a few seconds,and shows the current view you are on when toggling through views.

2)With my next update,it won't...the whole Refried theme structure is going to change drastically,so it will be a fresh install. I wouldn't stress making too many changes to the current 200+ themes out now,because they are all going away,and becoming just 2 themes after the update. Same features,smaller and easier to use package.

  • The Cake is a Lie 1

Share this post


Link to post
Share on other sites
1 hour ago, RetroHumanoid said:

1) I'm not sure if there is a way to know really...other than visual queues in the artwork placement and stuff. I wouldn't mind having maybe a popup text that shows for a few seconds,and shows the current view you are on when toggling through views.

2)With my next update,it won't...the whole Refried theme structure is going to change drastically,so it will be a fresh install. I wouldn't stress making too many changes to the current 200+ themes out now,because they are all going away,and becoming just 2 themes after the update. Same features,smaller and easier to use package.

Ah. Thanks for the heads up. Was just in the process on manually downloading videos / logos etc to update some of what I have that seems to have downloaded or been missed.
I'm guessing now is the time to stop that then in lieu of what's coming...

Share this post


Link to post
Share on other sites

@RetroHumanoid Awesome theme and a massive amount of detail/work, particularly with the new update working with the revised theme system so soon out of the gate.  I noticed as I was cruising around all the files after install that the Queso Fresco Addon for Microsoft Windows 3.1.X image directory has a typo in folder name (Microsot).  See below screenshot:

image.thumb.png.02411933890fa4b9845d3bed5c8ff1d6.pngI don't have any games (yet) in this category so cannot say it impacted my setup.  The XAML file references appear to be correct titles. 

Share this post


Link to post
Share on other sites
27 minutes ago, sundogak said:

@RetroHumanoid Awesome theme and a massive amount of detail/work, particularly with the new update working with the revised theme system so soon out of the gate.  I noticed as I was cruising around all the files after install that the Queso Fresco Addon for Microsoft Windows 3.1.X image directory has a typo in folder name (Microsot).  See below screenshot:

image.thumb.png.02411933890fa4b9845d3bed5c8ff1d6.pngI don't have any games (yet) in this category so cannot say it impacted my setup.  The XAML file references appear to be correct titles. 

Thanks for the heads up...not sure how that happened. Luckily it's not a platform that most people have,but, next update I will straighten it out

Share this post


Link to post
Share on other sites

@RetroHumanoidAlso seeing some inconsistencies in the Queso Fresco Addon with Sony PlayStation Portable. In addon the image directory is referenced as Sony PSP but in main theme it Sony PlayStation Portable.  So doesn't pull up the addon border (pulls the vanilla version).  When went through and renamed all to Sony PlayStation Portable in the folders and XAML file references worked fine.  

Lastly, the Sony PlayStation (PS1 to PS4) name references have mixture of lower and uppercase in the "S" (PS4 and PS3 are upper, and others lower).  I didn't think it would matter but my PS3 name in LB was lowercase and wouldn't pull the addon border until renamed to match the theme name which was with upper case "S".  The PS3 addon border came up okay then after that. Although oddly, didn't seem to be issue with PS2 and PS1, I went and renamed all PS references with uppercase (i.e., Sony PlayStation) so everything was same.  Could just be me but maybe something to look at on next revision pass. 

Thanks again for the work. 

Edit: I also see that the theme is generating empty directories in the Themes folder.  They are empty except for a "plugin" directory which has no files. I had completely started from scratch with V2 so these folders were not there prior. They seem to generate by platform when launching BB and scrolling /selecting a platform. 

image.png.0b1ba1787f877d35cb2587a56814cff3.png

image.thumb.png.ec483321653a7c5a588930b611c2f1bb.png

Edited by sundogak
Added note about the empty folders

Share this post


Link to post
Share on other sites

I'm sorry but I don't understand how to use the addons. It creates an addon folder but the view doesn't use the new files, should I change an option somwhere to point to the new folders? I don't get it...

Share this post


Link to post
Share on other sites
7 hours ago, sundogak said:

@RetroHumanoidAlso seeing some inconsistencies in the Queso Fresco Addon with Sony PlayStation Portable. In addon the image directory is referenced as Sony PSP but in main theme it Sony PlayStation Portable.  So doesn't pull up the addon border (pulls the vanilla version).  When went through and renamed all to Sony PlayStation Portable in the folders and XAML file references worked fine.  

This is odd,because in the new version of the default theme,there is artwork for "Sony Playstation Portable" and "Sony PSP"

381253150_Example1.thumb.png.a612e87938fdf35d943e02422cd0dedb.pngBut,in the old version of the theme,this is not the case...it only had "Sony Playstation Portable"
 

And in the Queso Addon,it really doesn't matter what the artwork is called,as long as the custom view file for that platform,references it by the correct name,which out-of-the-box, it does...

2084649936_Example2.thumb.png.597db3d4d4352a776c1006634a61a0b2.png

And as long as the view file is named after the users platform name correctly,which is the first place a user should look if artwork doesn't show correctly.

I think you may have possibly lost something in the installation,and you are using the old version of Refried,but,merged the queso addon into it.I know you said it was a fresh install,but,all the evidence points to the possibility of PEBCAK...if not,then I will eat my shoe.Or possibly the drastic change of the Refried themes structure,while still retaining the same name of the theme,may have caused an issue with LaunchBox itself.

What I would do is start with a fresh download of Refried 2.0 and Queso Fresco.

Change Big Box to a different theme in the options menu.

Disable "Remember Separate View for each Platform"

Browse through that different theme,change views on a platform

Shut down big box and remove anything related to refried from your themes folder.

Place the new version of Refried and merge the addon into it. Then start big box and see if that solves anything.

Also,let me know if the ps3-ps4 thing persists after this and I will look into it further. I don't have those on my cabinet,but,I can try to figure out what is going on.Just an fyi on this though,I did change the name of the custom "Nintendo Entertainment System" wheelgamesview xaml to "nintendo entertainment system", and it made no difference. The addon border showed just fine,and capitalization doesn't seem to matter.

" I went and renamed all PS references with uppercase (i.e., Sony PlayStation) so everything was same."

I am curious about what files you had to rename in this process though.

The ghost folders might be part of the first problem,and probably has something to do with the "Remember Separate Views" option.Hopefully it gets sorted out with the above method.

Share this post


Link to post
Share on other sites
53 minutes ago, vital74 said:

I'm sorry but I don't understand how to use the addons. It creates an addon folder but the view doesn't use the new files, should I change an option somwhere to point to the new folders? I don't get it...

538390158_Instructions1.thumb.png.491be466c9d99b61a46739dd80ef20b1.png775569351_Instructions2.thumb.png.90649a80d859e1a41700274401149bd2.png1925516793_Instructions3.thumb.png.a0efd205625116d950018678193af2e0.png

  • Haha 2

Share this post


Link to post
Share on other sites

Oh ok, that's what I did, but I was looking at the "windows" list and that one is named "PC games" now, tilt.

thanks for the step by step explaination, got to fine tune my lists names. ;D

 

and I guess the clear logos replaces the folders in "addons" right?

 

Share this post


Link to post
Share on other sites

@RetroHumanoidThanks for the reply. Let me do some troubleshooting.  I can say with 100% surety that I didn't have any old refried files/folders for V1 when did V2.  But could be an errant plugin as an issue (outside of Refried theme). So will play with that. On the PSP, understand what saying since did see the dual named borders as well.  I will give whirl with clean install now that I know my PlayStation titles in LB are all consistent and see what happens.

On another note, in the Queso addon under "_Computers" image folder I don't see any custom images for "Windows" anymore like in older plugin. There are the MS-DOS, and Windows 3.1x folders.  Is that by design?

Cheers.

Share this post


Link to post
Share on other sites
26 minutes ago, sundogak said:

On another note, in the Queso addon under "_Computers" image folder I don't see any custom images for "Windows" anymore like in older plugin. There are the MS-DOS, and Windows 3.1x folders.  Is that by design?

They are there...but,they are named PC Games. This was actually a mistake,and there are a few other systems I have to fix up like that as well. On my cabinet I call it PC Games,but,when I released it,I figured Windows was a better name since there are alot of different categories of PC Games. Refried 2.0 is the version from my cabinet.To remedy this easily,you can go into each custom view folder in the themes "Views" folder and change the name of all the PC Games xaml's to Windows.

Share this post


Link to post
Share on other sites

Ahh, makes sense. I didn't think to look for PC name.  Easy enough fix. 

I have gone back and forth on how to name modern Windows games grouping so can see how that one is problematic.  Thanks again.

Share this post


Link to post
Share on other sites

Hey RH, I had to rename a couple of files to match what I had in Launchbox and everything displays properly until I go into the actual game screen. Then it looks like this. I've renamed all images and refreshed the cache. Any ideas as to what's happening here? 

Thanks!

refried.png

Share this post


Link to post
Share on other sites

I'm sure RetroHumanoid will see this and respond.  But, to me it looks like maybe there's a file you missed re-naming.  Look through all the files in ..\Unified Refried\Images\Theme\ and check to make sure you have them matched to the platform/playlist name you're having issues with.  For example it looks like you're accessing that screen via a playlist named Shoot 'Em Up, but in Unified Refried\Images\Theme\Addons\_Arcade\VideoBorder there's a file called "Shoot Em Ups.png".  Maybe that one needs to be copied and renamed to match your playlist name eg.  "Shoot 'Em Up.png".

Sorry, I don't use playlists so I can't confirm is this is the issue you're seeing or not, but I did have issues with several of my platforms and I just had to go through all the image files and find the right ones and rename them to match what I have my platform called in LB. Hope this helps... if not maybe someone else knows what's wrong :)

Edited by CDBlue

Share this post


Link to post
Share on other sites
3 hours ago, Ghostlines said:

Hey RH, I had to rename a couple of files to match what I had in Launchbox and everything displays properly until I go into the actual game screen. Then it looks like this. I've renamed all images and refreshed the cache. Any ideas as to what's happening here? 

Thanks!

refried.png

If you are using the Default theme,and are not using the Queso addon,then you should rename the videoborder and background to match your platforms name.

If you are using the Default theme,and you are using the Queso addon,then you only change the name of the background to match your platform...afterwards you should change the custom view xaml filenames to match your platform name...no other artwork should be changed,because the names of the videoborders in the arcade pack are hard referenced in the custom view xaml's.

In a future update,all art will be hard referenced from the addons...but,for now,with the addon,you still have to check the backgrounds platform name

  • Thanks 1

Share this post


Link to post
Share on other sites

Hey RetroHumanoid, love your theme, and it's become my default on both of my cabinets.

Quick request if it's not too much to ask. Would it be possible to add a game view showing the 3D box, just without the carts or the spinning CD's?

The reason I ask is, there are tons of bad images for those that get pulled down. For example, CD's without transparency, so you're left with a spinning white box. It just looks sloppy, and takes away from the otherwise awesome look.

Thanks for any consideration you can give this request.

GG

 

UnifiedRefried2_badCD.jpg

Share this post


Link to post
Share on other sites
47 minutes ago, GreenGriffon said:

Hey RetroHumanoid, love your theme, and it's become my default on both of my cabinets.

Quick request if it's not too much to ask. Would it be possible to add a game view showing the 3D box, just without the carts or the spinning CD's?

The reason I ask is, there are tons of bad images for those that get pulled down. For example, CD's without transparency, so you're left with a spinning white box. It just looks sloppy, and takes away from the otherwise awesome look.

Thanks for any consideration you can give this request.

GG

 

UnifiedRefried2_badCD.jpg

You can just delete the code below from the view you don't want discs/carts

 

<!-- DISC IMAGE -->
            <Image x:Name="DiscImage" Grid.Column="4" Grid.ColumnSpan="2" Grid.Row="3" Grid.RowSpan="3" Source="{Binding Path=ActiveGame.CartFrontImagePath}" Opacity="100" Panel.ZIndex="12" Margin="-250,20,175,70" Stretch="Uniform" VerticalAlignment="Center" HorizontalAlignment="Left" RenderOptions.BitmapScalingMode="HighQuality" RenderTransformOrigin="0.5,0.5">
                <Image.RenderTransform>
                    <TransformGroup>
                        <ScaleTransform/>
                        <RotateTransform />
                        <TranslateTransform X="4000"/>
                    </TransformGroup>
                </Image.RenderTransform>
                </Image>

  • Like 1

Share this post


Link to post
Share on other sites

RH, love your work, this theme is just perfect for me. I'm emulating 80 systems and you've covered them all apart from 2. Any chance, when you get time you could add them in the future please? I'm missing the Dragon 32 and the Oric Atmos. Cheers 😊

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...