Jump to content
LaunchBox Community Forums
dominikabra

Downloading missing art

Recommended Posts

Hello!

First of all, kudos for the wonderful piece of software. I've just recently discovered and seriously rocks. I'm pretty confident I'll eventually end up purchasing a license even though I don't see myself needing the extra features. I think it's well deserved.

Now on to the issue. Sorry if it's already been asked and solved, but I haven't been able to find the exact same issue.

 I'm using Launchbox 9.1 on Windows 10 x64. I'm adding some rom sets (NES, SNES, Genesis, etc.) from no-intro mainly. The problem is that once the parsing and scraping is finished, there's a bunch of games with missing art. The funny thing is that if I edit those games and click on "download images/media", the art is found and downloaded. How can I do this automatically? I don't want to go through 100 games doing the same operation if there's a way to avoid it.

I've tried the "audit" function, selected the games with "0" box art pictures and gone through the wizard to download the art, to no avail. I don't want to add custom art, just the art that's in the DB and which is effectively downloaded via the Edit function ("download images/media"). Do I really have to endure this pain and go through them all manually? I'm sure there's a way and I'm even surer I'll feel as dumb as hell when I'm told the solution.

Thank you very much.

 

EDIT: I'll attach some screenshots to clarify the issue. I'm not asking about the roms or games that are not automatically found in the DB by LB. It's about those games that ARE detected and DO have media but it's not downloaded (for some reason).

Screenshot 1: Romset with missing art

1-Romset.jpg

Screenshot 2: Edit window of the rom with missing art (Metal Warriors). Metadata is already retrieved.

2-Edit.jpg

Screenshot 3: "Download Images/Media" window. Lots of media here. I click "download" and all is downloaded correctly.

3-Media.jpg

Screenshot 4: Romset after downloading the missing media

4-Romset_v2.jpg

Edited by dominikabra
Adding screenshots

Share this post


Link to post
Share on other sites

What is the scraping source your using? I haven't ran into that issue but I am also pulling media down from EMU movies as well with the lifetime license.

Share this post


Link to post
Share on other sites

I'm using LB database as main source. Generally speaking I don't even have to touch a thing, works like a charm. Except for those games missing the art.

Share this post


Link to post
Share on other sites

Gotcha well I know I didn't have much art missing but there are some games that don't have art period and unfortunately/fortunately the people that make art for those either sell it or contribute it to the community. 

Share this post


Link to post
Share on other sites

Funny thing is those games DO have art. It's just LB not downloading it first time for some reason. Manually editing and clicking "download" on the media forced the download, but I'd like to avoid the manual process, if possible.

Share this post


Link to post
Share on other sites

So question then did you add the games via the folder method vs. the rom file method? I am wondering if that has something to do it with. I can look at mine tonight and see. I know you can't scan for newly added roms if you added them in via folder.

Share this post


Link to post
Share on other sites

Nothing changed regarding folders. They were added all at the same time. The scrapping from the "import" process (under "tools") was performed forts,a new minutes after that I realized some where missing. Edited the first one and saw the metadata was already in the game profile but the art had to be downloaded "manually". See the screenshots I added to the first post.

Thanks for your help and feedback.

Share this post


Link to post
Share on other sites

yeah just went through my collection. There was maybe 2 NES games that didn't get scraped that I went back and did it manually. Aside from that I did notice too that some images were labeled for SFC and not SNES even though they were USA SNES games. The media was there but it referred the other image until I changed the image type. 

Aside from that I have a few prototype games from older systems like Atari and some files that are BIOS that I need to either hide or put a default "BIOS" file on. Did you recall getting any errors when the scraping was done? I know I had a few awhile back when I did and it said it had a duplicate name. If there is some media missing maybe I can help if its not downloading anything. 

Share this post


Link to post
Share on other sites
10 hours ago, dominikabra said:

Hello!

First of all, kudos for the wonderful piece of software. I've just recently discovered and seriously rocks. I'm pretty confident I'll eventually end up purchasing a license even though I don't see myself needing the extra features. I think it's well deserved.

Now on to the issue. Sorry if it's already been asked and solved, but I haven't been able to find the exact same issue.

 I'm using Launchbox 9.1 on Windows 10 x64. I'm adding some rom sets (NES, SNES, Genesis, etc.) from no-intro mainly. The problem is that once the parsing and scraping is finished, there's a bunch of games with missing art. The funny thing is that if I edit those games and click on "download images/media", the art is found and downloaded. How can I do this automatically? I don't want to go through 100 games doing the same operation if there's a way to avoid it.

I've tried the "audit" function, selected the games with "0" box art pictures and gone through the wizard to download the art, to no avail. I don't want to add custom art, just the art that's in the DB and which is effectively downloaded via the Edit function ("download images/media"). Do I really have to endure this pain and go through them all manually? I'm sure there's a way and I'm even surer I'll feel as dumb as hell when I'm told the solution.

Thank you very much.

 

EDIT: I'll attach some screenshots to clarify the issue. I'm not asking about the roms or games that are not automatically found in the DB by LB. It's about those games that ARE detected and DO have media but it's not downloaded (for some reason).

Screenshot 1: Romset with missing art

1-Romset.jpg

Screenshot 2: Edit window of the rom with missing art (Metal Warriors). Metadata is already retrieved.

2-Edit.jpg

Screenshot 3: "Download Images/Media" window. Lots of media here. I click "download" and all is downloaded correctly.

3-Media.jpg

Screenshot 4: Romset after downloading the missing media

4-Romset_v2.jpg

Yeah that game pulled down correctly for me just fine. I started a fresh install of 9.0 when I did this and updated to 9.1 since. I did recache not too long after that so I wonder if that is an issue.

 

Share this post


Link to post
Share on other sites

There were no errors during the parsing and scrapping. The metadata seems correct, it's just that LB doesn't download the existing media for some games. I don't even need to touch a thing in the profile, just hit the "download" button inside the "edit" window and all the media is shown, already checked and promptly downloaded.

It's a tedious procedure that I'd love to avoid since I have 100 games like that in the NES set alone, even a few more in the SNES, etc.

The audit procedure didn't do a thing, and it's driving me nuts.

If, in the end, I have to endure the pain and have really missing media, I'll ask for your help. Thank you very much.

BTW, do the Devs/mods check all the threads or do you need to mention them for them to check the issue?

Share this post


Link to post
Share on other sites
On 12/19/2018 at 1:21 AM, dominikabra said:

There were no errors during the parsing and scrapping. The metadata seems correct, it's just that LB doesn't download the existing media for some games. I don't even need to touch a thing in the profile, just hit the "download" button inside the "edit" window and all the media is shown, already checked and promptly downloaded.

It's a tedious procedure that I'd love to avoid since I have 100 games like that in the NES set alone, even a few more in the SNES, etc.

The audit procedure didn't do a thing, and it's driving me nuts.

If, in the end, I have to endure the pain and have really missing media, I'll ask for your help. Thank you very much.

BTW, do the Devs/mods check all the threads or do you need to mention them for them to check the issue?

The devs/mods are generally good on reviewing posts and replying to some. However we are in the holiday season and they probably also have full-time jobs so  not sure how quickly they will acknowledge it but they might of even noted it in a next beta release. I hope they start up the dev/qa live youtube qa discussions because those were pretty helpful.

Share this post


Link to post
Share on other sites

Just tried and exactly the same happens with my NES collection. The audit process doesn't add the missing art even though it detects the games and scrapes correctly, and also downloads the media (the messages above the green progress bar prove it). I'm really at a loss at what's going on here...

Share this post


Link to post
Share on other sites

I found out what's causing some game information/artwork not to be downloaded when importing. It's most certainly because those titles are misspelled. I checked every game with missing artwork against the Launchbox DB and corrected their titles in the romfolder. Then I manually edited each title in Launchbox with the correct titles and hit search and the game was found in the database so I downloaded the missing info & artwork.

Share this post


Link to post
Share on other sites

Thank you SteelDawn, but the issue is LaunchBox actually DOES find the metadata/information for the game. The funny thing is it doesn't download the artwork automatically, as you can see in my first screenshot. When I go through the "edit" process I only have to click on "Download Media" and it retrieves everything. The information fields are filled (see screenshot 2) so the artwork is inmediately found and downloaded. I really would like to avoid enduring the pain of going manually through each one of them so LaunchBox downloads the media...

Share this post


Link to post
Share on other sites

Make sure you check the Search for game information and media from the LaunchBox Games Database (recommended). Even if info was found previously. No media will be downloaded if that option is not checked.

Share this post


Link to post
Share on other sites
On 12/30/2018 at 3:22 AM, Suhrvivor said:

Make sure you check the Search for game information and media from the LaunchBox Games Database (recommended). Even if info was found previously. No media will be downloaded if that option is not checked.

Thanks for the suggestion Suhrvivor, it is (and always has been) checked. I'll keep digging.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×