Jump to content
LaunchBox Community Forums
CaptSpeirs

LaunchBox 9.2 really bad sound, ok in Retroarch.

Recommended Posts

I finally decided to get involved with LaunchBox, ETAPrime is a great salesman :), and all went fine until I starting launching ROMs. The sound is really bad and yes I tested outside of LaunchBox and with Retroarch they works great. I have search and found no issues like mine. It has to be something simple, just don't know what. Thanks for your time.

Share this post


Link to post
Share on other sites

My apologies for the delay; I'm just now seeing this thread. I suspect that no one answered it because no one has any idea why you're having sound issues. Honestly, the above makes almost no sense, which is probably why no one responded. Since this is indeed something that no one else has ever reported, I would be willing to bet that the issue you're having has nothing to do with LaunchBox, though anything is certainly possible.

We'll need more of an explanation as to what's happening with the sound. Are you using Retroarch both inside and outside of LaunchBox?

 

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Jason Carr said:

We'll need more of an explanation as to what's happening with the sound. Are you using Retroarch both inside and outside of LaunchBox?

 

Yes, inside and outside of LaunchBox. Installed LaunchBox then added Retroarch according to ETA Prime's Tutorial. Launching games I nitced the sound is bad. Launched game in Retroarch, no sound issues. I even went as far as excluding LaunchBox from my Antivirus. I uninstalled LaunchBox and will try again with a new installation.

Edited by CaptSpeirs

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Jason Carr said:

What do you mean by the sound is bad? Is it stuttering?

I reinstalled Launchbox, added Retroarch and it still has the same problem. As much as it was painful to do, I ran the game and tried playing it, it runs very slow. If I launch Retroarch from inside Launchbox it does the same thing. If I launch Retroarch from outside of Lauchbox, it still runs slow. If I run it from a different Retroarch, it runs fine.

 

Edited by CaptSpeirs

Share this post


Link to post
Share on other sites
31 minutes ago, CaptSpeirs said:

I reinstalled Launchbox, added Retroarch and it still has the same problem. As much as it was painful to do, I ran the game and tried playing it, it runs very slow. If I launch Retroarch from inside Launchbox it does the same thing. If I launch Retroarch from outside of Lauchbox, it still runs slow. If I run it from a different Retroarch, it runs fine.

Okay, that makes more sense. So it sounds like it's a setting problem with the Retroarch install, if I'm understanding you correctly. Why not just use the Retroarch install that works?

Share this post


Link to post
Share on other sites
1 minute ago, Jason Carr said:

Okay, that makes more sense. So it sounds like it's a setting problem with the Retroarch install, if I'm understanding you correctly. Why not just use the Retroarch install that works?

I compared the two and noticed by default "Threaded Video" is off and on the one that works, it is on. I changed the other one to "on" and it works great now. Thanks for holding my hand through this now all seems well.

  • Like 1

Share this post


Link to post
Share on other sites
On 1/5/2019 at 8:44 PM, CaptSpeirs said:

I compared the two and noticed by default "Threaded Video" is off and on the one that works, it is on. I changed the other one to "on" and it works great now. Thanks for holding my hand through this now all seems well.

CaptSpeirs...I was having an issue with the video and audio in NeoGeo being extremely slow! I've spent all day trying to figure out the issue. I stumbled upon your response. Completely solved my issue for NeoGeo. Sorry you had a similar issue as me, but I'm glad you were able to figure it out because it definitely saved me!

Share this post


Link to post
Share on other sites
13 hours ago, HotMommasCowboy said:

CaptSpeirs...I was having an issue with the video and audio in NeoGeo being extremely slow! I've spent all day trying to figure out the issue. I stumbled upon your response. Completely solved my issue for NeoGeo. Sorry you had a similar issue as me, but I'm glad you were able to figure it out because it definitely saved me!

Glad it worked out for you. I am having a different problem with Neo Geo. I have a No Intro Rom Set of Neo Geo titles and less than half will launch. Just can't figure it out.

Share this post


Link to post
Share on other sites

CaptSpeirs, I wouldn't be able to help you with No Intro Rom Sets...I'm just not savvy enough when it comes to emulators and roms. But, I did want to add some info to NeoGeo running in "slow motion". I found one of my older Retroarch (version 8.5 I believe) and checked it's video settings because I was having slow motion issues with several Nintendo platforms and Sega Naomi. I changed my video settings in the newer version of RA to match the older version (which actually had threaded video turned off) and now all the platforms that were running in slow motion are now up to normal playing speed. The only thing I didn't change was the custom aspect ratio and I turned "Start in Full Screen Mode" back on. If you weren't having slow motion issues in several platforms like I was, maybe this'll help someone else out. See attached screen shot below.IMG_4191.thumb.jpg.403e1f05e163b93ab960238f668e6eab.jpg

Share this post


Link to post
Share on other sites
On 1/15/2019 at 3:40 PM, HotMommasCowboy said:

CaptSpeirs, I wouldn't be able to help you with No Intro Rom Sets...I'm just not savvy enough when it comes to emulators and roms. But, I did want to add some info to NeoGeo running in "slow motion". I found one of my older Retroarch (version 8.5 I believe) and checked it's video settings because I was having slow motion issues with several Nintendo platforms and Sega Naomi. I changed my video settings in the newer version of RA to match the older version (which actually had threaded video turned off) and now all the platforms that were running in slow motion are now up to normal playing speed. The only thing I didn't change was the custom aspect ratio and I turned "Start in Full Screen Mode" back on. If you weren't having slow motion issues in several platforms like I was, maybe this'll help someone else out. See attached screen shot below.

Thanks for the tip. however my version of Retroarch is 1.7.5 and it doesn't have some of the settings you are showing. I'll take a screen shot later so you can see the difference.

Share this post


Link to post
Share on other sites
2 hours ago, CaptSpeirs said:

it doesn't have some of the settings you are showing

It might have to have the advanced features enabled, this is something I just do out of habit.

Share this post


Link to post
Share on other sites
3 hours ago, CaptSpeirs said:

Thanks for the tip. however my version of Retroarch is 1.7.5 and it doesn't have some of the settings you are showing. I'll take a screen shot later so you can see the difference.

That's the same version RA that I have. I've watched so many Launchbox videos, Lordmonkus may be right and I may have turned on an advanced setting or something. Between all my traveling and trying to update/fix when I can, a lot of it eludes me now a days! I guess I'm not as good with emulators and roms as I thought I was. I actually do have a "No Intro Naomi" set and it appears I can only get less than half the games running in Retroarch and Sammy Atomiswave just isn't working at all for me in RA! :( Just not enough videos/ info on these 2 systems. Oh well, here's to continued searches and pulling what hair I have left out! :)

Edited by HotMommasCowboy

Share this post


Link to post
Share on other sites
18 hours ago, Lordmonkus said:

Oh yeah, that refresh rate will cause issues.

I thought it was low also. What kind of computer do you have to have to run this at 60? My specs are; i7 3770K OC 4.4 GHz, 16GB Ram, 1866 MHz DDR 3, GTX 680 4GB memory. Monitor refresh rate is 60hz

Edited by CaptSpeirs

Share this post


Link to post
Share on other sites

Somehow your refresh rate got set really low, you can try editing your retroarch.cfg and look for:

video_refresh_rate =

and set it to 60, though generally speaking it's never exactly 60, it's usually 59.xx or 60.xx.

Share this post


Link to post
Share on other sites

I would also check nvidia control panel to make sure Windows is actually running at 60 and not 30, as Retroarch may be pulling the number that the actual monitor is refreshing at if it is set incorrectly there..

Share this post


Link to post
Share on other sites
On 1/18/2019 at 3:45 PM, neil9000 said:

I would also check nvidia control panel to make sure Windows is actually running at 60 and not 30, as Retroarch may be pulling the number that the actual monitor is refreshing at if it is set incorrectly there..

Sorry it took so long to get back to you, nVidia Control Panel wouldn't open, so I updated my driver and all is well. Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...