Jump to content
LaunchBox Community Forums
sac1000

turbo graphx emulator and CHD

Recommended Posts

I am trying to install a bunch of pc engine cd games on LB but I am not sure despite all the tutos i've been watching which one should I choose, retroarch, mame or pce jin? my files are CHD files.

Share this post


Link to post
Share on other sites

If they are CHD files RA and MAME are your only options. As a side note I'm not sure of the quality of the emulation in MAME so I would suggest using RetroArch.

Share this post


Link to post
Share on other sites

I'm not sure which is best but either the supergrafx or PC Engine one should work.

Share this post


Link to post
Share on other sites
10 minutes ago, sac1000 said:

ok, are your cd files chd files ?

I dont have that system or roms anymore, but i believe they were, i CHD'd all my CD roms except PS2 and GC/Wii

Share this post


Link to post
Share on other sites

I just tried now this this core and a CHD file but the emulator didn t even open.

Share this post


Link to post
Share on other sites
2 minutes ago, sac1000 said:

I just tried now this this core and a CHD file but the emulator didn t even open.

Do you have the bios?

Share this post


Link to post
Share on other sites

I updated the cores, but didn't do anythinh about the bios...what should I look for on google? bios+pc engine CD is enough?

Share this post


Link to post
Share on other sites
9 minutes ago, sac1000 said:

I updated the cores, but didn't do anythinh about the bios...what should I look for on google? bios+pc engine CD is enough?

should be enough, its this one.

image.thumb.png.4a90a83b832c1d43c042eb4cb1f58b96.png

Share this post


Link to post
Share on other sites

1st what you want to do is load the core in RA then go to information and look in system information this will show you the exact name that RA is looking for to work then Google that name.

Share this post


Link to post
Share on other sites

Neil I hope you know I was mentioning you showing the file name in your previous post and not asking you to show him what I was referencing.

Share this post


Link to post
Share on other sites
1 minute ago, DOS76 said:

Neil I hope you know I was mentioning you showing the file name in your previous post and not asking you to show him what I was referencing.

Yeah i know, but i was also in the process of grabbing the RA info screen when you commented.

  • Like 1

Share this post


Link to post
Share on other sites

I don't know why but I went and grabbed those 3 optional bios files

  • Haha 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×