Jump to content
LaunchBox Community Forums
Jason Carr

9.4-beta-1 Released

Recommended Posts

Hey folks, the first 9.4 beta is released with the following:

- Improvement: LaunchBox will no longer download images for inapplicable regions during batch imports and media download processes. This will help to save disk space and speed up the download processes. Please be sure your region priority preferences are correct in LaunchBox under Tools > Options > General > Region Priorities, as this will define what types of images are downloaded for games that have no region specified.

- Improvement: Debug logging has been improved for media downloads and cleaning up media, now reporting the downloaded and deleted files.

- Improvement: Debug logging can now be turned on or off under Tools > Options > Debugging in LaunchBox. Debug logs were previously available, but had to be manually turned on via the Settings.xml file.

I have several other things in progress, but I wanted to release this now for testing. Enjoy. :)

  • Like 7
  • Thanks 3

Share this post


Link to post
Share on other sites

One thing i noticed is, with the Startup screen(not the startup videos) when you exit a game, and it says game over, you can hear Bigbox and the game video is playing from the beginning in the background and then when bigbox comes into focus, the video loads from where it left off. Ill try to make a video of it. But this might just be a windows focus issue.

Thanks Jason for all your hard work!! Keep it up, and looking forward to what comes next 😎

Edited by ea4492
  • Like 1

Share this post


Link to post
Share on other sites
Just now, ea4492 said:

One thing i noticed is, with the Startup screen(not the startup videos) when you exit a game, and it says game over, you can hear Bigbox and the game video is playing from the beginning and then when bigbox comes into focus, the video loads from where it left off. Ill try to make a video of it. But this might just be a windows focus issue.

Thanks Jason for all your hard work!! Keep it up, and looking forward to what comes next 😎

I have seen that before, but I haven't been able to track it down. It seems to happen randomly, rarely in my case. I might be able to just mute the videos to solve it maybe. Probably won't be easy though.

Share this post


Link to post
Share on other sites
3 minutes ago, Jason Carr said:

I have seen that before, but I haven't been able to track it down. It seems to happen randomly, rarely in my case. I might be able to just mute the videos to solve it maybe. Probably won't be easy though.

Cool. Thanks Jason. I was thinking it might of been the HDD since i was running bigbox off a 5400rmp HDD and i noticed bigbox would lag and slow down do to the slow HDD, but i moved my bigbox collection to a 7200rpm drive, and bigbox is noticeably faster but that issue still happens.

Edited by ea4492

Share this post


Link to post
Share on other sites

Here is the video of the issue. Im using the  Retrotastic theme and the game was loading from Retroarch, But it happens with any game/emulator. So you can see when you exit a game, the  video starts up for a second until bigbox windows is in focus, then the video resumes back to where it left off. I know it does it when Bigbox windows is not in focus, because i did a test when exiting a game while another windows was in focus, and the video started from the beginning until i clicked on bigbox and it  went into focus, the video resumes back to where it left off before like you see in the video below. Hopes this helps identify the  issue.

 

Edited by ea4492

Share this post


Link to post
Share on other sites

Good news re region priorities. I was never quite sure what region priorities meant - when downloading media, I would like it to download the relevant media for the region of the ROM. That is my priority. I’m not sure what other priorities there might be. I’m probably missing something 🤨

Share this post


Link to post
Share on other sites

What would it happen to those images with different region that we already downloaded with previous versions? Can the cleaning media tool remove them if you run it in this beta?

Edited by Suhrvivor

Share this post


Link to post
Share on other sites
5 hours ago, Suhrvivor said:

What would it happen to those images with different region that we already downloaded with previous versions? Can the cleaning media tool remove them if you run it in this beta?

The Clean Up Media tool will remove them, yes. It did in previous versions as well. The main issue is that downloading media was downloading region files that your collection wasn't using, which would then be deleted by Clean Up Media, so it was a never-ending cycle.

9 hours ago, Dan said:

Good news re region priorities. I was never quite sure what region priorities meant - when downloading media, I would like it to download the relevant media for the region of the ROM. That is my priority. I’m not sure what other priorities there might be. I’m probably missing something 🤨

The priorities are used when there is no region listed on the game.

Share this post


Link to post
Share on other sites

Ah of course, that makes sense. Might be helpful to have a few words to that effect in that settings window. 

Share this post


Link to post
Share on other sites
16 minutes ago, Dan said:

Ah of course, that makes sense. Might be helpful to have a few words to that effect in that settings window. 

Yes, that might help, though honestly people don't read things anyways. I had already put that in the changelog and in the first post of this topic.

Share this post


Link to post
Share on other sites

So if I understand it right; when I uncheck all region priority boxes now it would just download any region media like before right? < sorry I'm a bit of a slowpoke sometimes in english and the technical terms) 

Share this post


Link to post
Share on other sites
43 minutes ago, Mr. RetroLust said:

So if I understand it right; when I uncheck all region priority boxes now it would just download any region media like before right? < sorry I'm a bit of a slowpoke sometimes in english and the technical terms) 

Generally, you should check the boxes for the regions you live in (or primarily want images for). If you have no boxes checked, LaunchBox will just randomly pick a region to download, which is not ideal. North America and United States should be checked (in that order) for folks who want ESRB rating images.

  • Thanks 1

Share this post


Link to post
Share on other sites

Beta 2 is out with a bunch of random crap™:

- Improvement: New option to "Hide Auto-Generated Playlists from Playlist View" under the Big Box View settings. This new setting is on by default and will hide all the auto-generated nested playlists from the playlists view.

- Improvement: New options to "Hide Mouse Cursor on Startup Screens" are available in the Game Startup settings of both LaunchBox and Big Box. These routines were causing issues on some rare systems, so they can now be disabled.

- Improvement: A shortcut key combination is now available for "Select Random Game" in LaunchBox: Ctrl+Alt+Q

- Improvement: New key and controller button mappings are available in Big Box for Lock/Unlock. This will allow you to lock or unlock Big Box without having to go all the way out to the System menu.

- Improvement: Games can now be marked as completed or incomplete in Big Box via the game details menu. This new game details menu item can also be hidden in the Game Menu options.

- Improvement: Big Box now has options to allow doing a bunch more things while locked: setting star ratings, opening game folders, opening game image folders, opening emulators, favoriting games, hiding games, marking games as broken, and marking games as completed. All options are available in the Security section of the Big Box options.

- Fixed: In the LaunchBox list view, pressing a letter key to jump to a game in the list did not put keyboard focus on the newly selected item, so using the arrow keys afterwards would jump back to the previous location

  • Like 6
  • Thanks 5
  • Game On 3

Share this post


Link to post
Share on other sites

Very Cool knowing there is at least a Random Game Shortcut key now. I hope to see this maybe become some of a Controller Command or even an Optional Dashboard Button too

Share this post


Link to post
Share on other sites
11 hours ago, Jason Carr said:

Beta 2 is out with a bunch of random crap:

- Improvement: New option to "Hide Auto-Generated Playlists from Playlist View" under the Big Box View settings. This new setting is on by default and will hide all the auto-generated nested playlists from the playlists view.

- Improvement: New options to "Hide Mouse Cursor on Startup Screens" are available in the Game Startup settings of both LaunchBox and Big Box. These routines were causing issues on some rare systems, so they can now be disabled.

- Improvement: A shortcut key combination is now available for "Select Random Game" in LaunchBox: Ctrl+Alt+Q

- Improvement: New key and controller button mappings are available in Big Box for Lock/Unlock. This will allow you to lock or unlock Big Box without having to go all the way out to the System menu.

- Improvement: Games can now be marked as completed or incomplete in Big Box via the game details menu. This new game details menu item can also be hidden in the Game Menu options.

- Improvement: Big Box now has options to allow doing a bunch more things while locked: setting star ratings, opening game folders, opening game image folders, opening emulators, favoriting games, hiding games, marking games as broken, and marking games as completed. All options are available in the Security section of the Big Box options.

- Fixed: In the LaunchBox list view, pressing a letter key to jump to a game in the list did not put keyboard focus on the newly selected item, so using the arrow keys afterwards would jump back to the previous location

I love this "bunch of random crap ™" a lot 🤘:D I'll test out how it went with the mouse cursor and startup screens. And marking as completed is an awesome addition bro!

  • Like 1

Share this post


Link to post
Share on other sites

YES! You did it once again you genius human being! 🤘:D When not hiding the mouse for start screens the mouse cursor stays normal after shutdown and during the whole big box process! Now I can also use those startup screens, rock on! 🤘

  • Like 1

Share this post


Link to post
Share on other sites

Has anyone else experienced some games or Emulators starting up and the Startup Screen doesn't pull away until at most maybe 2 seconds later? Like you'll hear the game and then almost 2 seconds later the startup screen goes away to show it. I think most of the time I dealt with this when it came to VisualBoy

Share this post


Link to post
Share on other sites
4 hours ago, RULLUR said:

Has anyone else experienced some games or Emulators starting up and the Startup Screen doesn't pull away until at most maybe 2 seconds later? Like you'll hear the game and then almost 2 seconds later the startup screen goes away to show it. I think most of the time I dealt with this when it came to VisualBoy

This is what the Startup Load Delay setting is for on the emulator. Just decrease the value.

  • Thanks 1

Share this post


Link to post
Share on other sites
3 hours ago, Jason Carr said:

This is what the Startup Load Delay setting is for on the emulator. Just decrease the value.

Yeah, since i noticed this as well, until i found that setting, turning it down to 2 second was perfect for me.

 

8 hours ago, RULLUR said:

Has anyone else experienced some games or Emulators starting up and the Startup Screen doesn't pull away until at most maybe 2 seconds later? Like you'll hear the game and then almost 2 seconds later the startup screen goes away to show it. I think most of the time I dealt with this when it came to VisualBoy

You system might be different so i would lower the time until you find the right spot.

Share this post


Link to post
Share on other sites

Recently started have an issue which very well could be something in the settings I've missed. I have my games on several different drives. When I import games from a drive that is not the drive Launchbox is on everything works great . If i go back and scan for new roms it finds no new roms even if I have some. If I do the same on the drive launchbox is on, both operations work fine.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×