Jump to content
LaunchBox Community Forums
Jason Carr

9.4-beta-1 Released

Recommended Posts

4 hours ago, Belgarath said:

I'm not at home at the moment but I had a strange problem with the new beta at first, the startup movies weren't playing properly, I could hear them but it was just a black screen, this happened twice but after that it seemed to start working again.

Also my favourite theme retrotastic seems to have major issues with this new beta, long error messages were popping up in most of the views and the transition video (video static) when you scroll through the games wasn't displaying at all, it just showed some text which said something about out of player instances.

 

@Jason Carr @faeran

 

edit: ok..no idea what's going on now, all I did was update to the new beta and Retrotastic stopped working..but to be sure I downloaded a new copy of the theme and it's working fine....very puzzled.

My guess is that this was actually not related to the theme at all, but rather was some kind of fluke or a rare/random glitch with VLC 3.x. I have put in a number of VLC-related fixes for the next beta though, so that may help as well.

Share this post


Link to post
Share on other sites
1 minute ago, Jason Carr said:

Honestly I would never have expected people to have that many preferences regarding the order of the screenshots in the sidebar, but I'll add it to the list of features to add to the next community poll.

 

Any project that allows an open dialogue with stakeholders is going to open itself to all sorts of requests, some of which could be considered nit-picky or of questionable value.

I think sticking to the community polls has been an effective way to avoid Launchbox suffering from too much 'scope creep', which can doom any project.

Just my take, anyway.

 

  • Like 2

Share this post


Link to post
Share on other sites

@runsamok I think I know what might be going on. I think we saw it once in beta testing too but I forgot about it. You have the Minimize on Launch and Restore on Exit settings enabled, which I'm guessing causes the issue. Does it work if you turn those settings off? If so, I'll probably force those off if you have the startup screens turned on.

Share this post


Link to post
Share on other sites

Beta 4 is out now with hopeful fixes for some VLC 3.x-related stability issues.

  • Like 4

Share this post


Link to post
Share on other sites

Thanks for your reply @Jason Carr, that sounds great. @GreenGriffon - just because you consider it "nit picky or of questionable value" doesn't mean that everyone else does. I think Jason's doing a fine job of separating the wheat from the chaff.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Jason Carr said:

@runsamok I think I know what might be going on. I think we saw it once in beta testing too but I forgot about it. You have the Minimize on Launch and Restore on Exit settings enabled, which I'm guessing causes the issue. Does it work if you turn those settings off? If so, I'll probably force those off if you have the startup screens turned on.

It does fix the focus problem after exiting emulators like RetroArch or Dolphin though (and the DOS games after I shut off the start screens) , well done.

If I turn those two off I never see the DOS games load, instead of it playing a second or two before dumping to the black screen of "no fullscreen or you!" I just get dropped right back to LaunchBox while the game plays behind, in a window. But I've basically resigned myself to the fact that I'll have to disable start screens for the exodos stuff as they really don't seem to like when LaunchBox creates the black screen that triggers the shutdown screen, Shame. as it's about 1/4 of my library total.

 

 

Share this post


Link to post
Share on other sites
7 minutes ago, runsamok said:

It does fix the focus problem after exiting emulators like RetroArch or Dolphin though (and the DOS games after I shut off the start screens) , well done.

If I turn those two off I never see the DOS games load, instead of it playing a second or two before dumping to the black screen of "no fullscreen or you!" I just get dropped right back to LaunchBox while the game plays behind, in a window. But I've basically resigned myself to the fact that I'll have to disable start screens for the exodos stuff as they really don't seem to like when LaunchBox creates the black screen that triggers the shutdown screen, Shame. as it's about 1/4 of my library total.

Glad to hear at least the issue that was confusing me is fixed. I might be able to fix it for eXoDOS as well, but it will likely require a custom solution and it's always tricky to get that stuff working with batch files. It's on my list though.

Share this post


Link to post
Share on other sites

Would it be possible to have whatever happens with the black window happen earlier in the cycle, before the DOS game is launched or whatnot?

Given that I can control when I get dumped out of fullscreen by changing the length the start screen is displayed & since it has to end sometime, perhaps if that happens before the game goes fullscreen it'll avert the issue? To test this line of thinking, I have run a series of tests, using max display times for the start/stop screens as 2 seconds (in the main Options screen) and then testing the load delay time in an individual game's Edit/Startup tab.

So long as the load delay is less than the minimum start screen display time, the game will launch & stay fullscreened, but there's a flash of desktop between when the start screen ends & the emulator kicks in. If I increase the load delay to minimise the flash I end up with either the default situation where I get kicked out, or if I time it just right I can get the fullscreen game to never actually go fullscreen & launch it in a window. But as long as I put up with a gap between the end of the start screen & the start of the game I never get kicked out, but I also never get the end screen. 

 

 

Share this post


Link to post
Share on other sites
8 hours ago, Retrofrogg said:

Thanks for your reply @Jason Carr, that sounds great. @GreenGriffon - just because you consider it "nit picky or of questionable value" doesn't mean that everyone else does. I think Jason's doing a fine job of separating the wheat from the chaff.

Yes, he is doing a fine job of prioritizing. And, the community polls are an effective tool in helping do so. Isn't that exactly what I just said?

And to add to your point, what one person wants isn't necessarily what everyone else wants. Hence, I repeat, the community polls.

We've come full circle.

Share this post


Link to post
Share on other sites

Well community polls are a great tool, but just writing off something the majority of people may have never even thought of, or care about as nit picky is sort of silly.  There are options for so many things, and orders, and priorities,...it seems fitting to have something for screenshot order for those who find other screens more appealing than the title screen.  I myself don't even use them really, but I think it is reasonable even if it only get's 10 votes in a poll.  Not everyone participates in a community poll either,...so that doesn't necessarily reflect an accurate account of users who might enjoy a feature.  It's like running into a feature on a car that you might never have dreamed of because conventional manufacturing just never did it, or it wasn't popular enough to ever be considered.  But man, if it applies to you and it is useful, it's a glorious moment.  For example, hoods that flip up with the hinges on the front of the car, make it sooooo much easier to get in the engine bay, but it's only done for a limited time period on limited models for some reason.  Or the fact that on 1971 toyota cars the radiator support unbolts completely from the car so that you can slide the engine straight out the front to replace it, without having to take the hood off. 

Edited by damageinc86
  • Like 1

Share this post


Link to post
Share on other sites

Very little ever gets written off completely because it is "nit picky" or "insignificant" but the fact of reality is that there is only so many hours in a day for Jason to work on things and for the most part it is a one man show. Things have to be prioritized and the polls help determine what gets high prioritization and what doesn't, at the same time items on the polls that get very few votes often get pushed to the next poll. Also often things get added in that were either very low on the votes or not even on the poll. The poll items are not the only thing that decides what gets added and what doesn't.

Share this post


Link to post
Share on other sites

So, getting back to beta testing @Jason Carr I did not get a lock up in attract mode last night with the new beta. 👍🏽

  • Like 2

Share this post


Link to post
Share on other sites

Yep all seems fine with the videos here, I tried to provoke the grey/greenish video artifacts by navigating faster than it could load the video, going back and forth titles really fast, trying to confuse the hdd, in the past I got the artifacts by doing this occasionally using my theme (it uses large videos), it doesn't happen anymore. I'm not 100% sure/could be a feeling but it seems to load video's a tiny fraction slower (could be below a second), is there a way to make videos load faster or is it connected to the loading times of a theme/speed of systems hdd?

Edit: I think It's the theme, I was able to speed up the parameters from the custom code by hexxer for wheel hiding, now it's faster :)

Edited by Mr. RetroLust
  • Like 1

Share this post


Link to post
Share on other sites

Reading and writing to the vlc.cfg file seems to be working great with newest beta as well:)

  • Like 1

Share this post


Link to post
Share on other sites

Would it be possible to have platform categories show the number of platforms rather than games in LB and BB?

  • Like 1

Share this post


Link to post
Share on other sites
On 1/25/2019 at 3:20 PM, FoxyMonty said:

Would it be possible to have platform categories show the number of platforms rather than games in LB and BB?

I would prefer this too. There may be some vocal users who don't. Best would be to make it an option :D

Edited by Retrofrogg

Share this post


Link to post
Share on other sites

I found something a little strange last night and not sure how long this has been an issue, but when I set something to be Launched as a video I then go to Big Box and find all Background Art and Music I chose has been kinda overwritten with the video playing now as the Background instead. So I go back to see in LaunchBox as to what might've happened, and it turns out it automatically set it as a Video Path. I deleted the Video Path and tried again only to see it came back until I just removed the video from being something to Launch. For now I just set it to a text document until I can figure what to do about this issue

Share this post


Link to post
Share on other sites
On 1/24/2019 at 4:53 PM, runsamok said:

Would it be possible to have whatever happens with the black window happen earlier in the cycle, before the DOS game is launched or whatnot?

Given that I can control when I get dumped out of fullscreen by changing the length the start screen is displayed & since it has to end sometime, perhaps if that happens before the game goes fullscreen it'll avert the issue? To test this line of thinking, I have run a series of tests, using max display times for the start/stop screens as 2 seconds (in the main Options screen) and then testing the load delay time in an individual game's Edit/Startup tab.

So long as the load delay is less than the minimum start screen display time, the game will launch & stay fullscreened, but there's a flash of desktop between when the start screen ends & the emulator kicks in. If I increase the load delay to minimise the flash I end up with either the default situation where I get kicked out, or if I time it just right I can get the fullscreen game to never actually go fullscreen & launch it in a window. But as long as I put up with a gap between the end of the start screen & the start of the game I never get kicked out, but I also never get the end screen. 

Possibly, but I'll have to experiment with it. I'm sure there's a solution but I'll have to play with it.

On 1/25/2019 at 7:20 AM, FoxyMonty said:

Would it be possible to have platform categories show the number of platforms rather than games in LB and BB?

I think this is a new request (haven't heard it before). It could be done with a custom theme, but might require a plugin. I'll add an item to my list to add a property to at least make it available to theme developers.

21 hours ago, RULLUR said:

I found something a little strange last night and not sure how long this has been an issue, but when I set something to be Launched as a video I then go to Big Box and find all Background Art and Music I chose has been kinda overwritten with the video playing now as the Background instead. So I go back to see in LaunchBox as to what might've happened, and it turns out it automatically set it as a Video Path. I deleted the Video Path and tried again only to see it came back until I just removed the video from being something to Launch. For now I just set it to a text document until I can figure what to do about this issue

If you put a video into LaunchBox's media folder and name it the name of the game, it will indeed be automatically picked up. This is by design. If you're "launching" videos, my recommendation would be to not put them in the LaunchBox media folders, and keep them somewhere else.

  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks for the feedback on VLC guys. I ran Big Box in attract mode for the entire weekend (more than 48 hours) and had no issues. So I think we're good to go with the VLC upgrade, thankfully.

  • Game On 1

Share this post


Link to post
Share on other sites
6 minutes ago, Jason Carr said:

I ran Big Box in attract mode for the entire weekend (more than 48 hours) and had no issues.

Speaking of which, did your attract mode exit and enter platforms? I noticed again last night something that i have mentioned before, my attract mode enters a platform and stays there permanently, and yes i do have the option on for going in and out of platforms. 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...