Jump to content
LaunchBox Community Forums
True_Blue_VAA

Configuring TI99/4A for Launchbox with MAME emulator

Recommended Posts

Hello,

Lordmonkus recommended I post this here from the reddit thread in order to troubleshoot this further: 

I used to have a TI-99/4A system when I was growing up along with several cartridge games. Previously I used classic99 to run these, but found out that MESS and MAME worked with it as well. I've been getting emulators set up with Launchbox, but I'm having a tough time with this particular one. Eventually I'd like to get it working with Retroarch if possible, but for now I'm working with standalone MAME first.

 

Mame64 location: W:\Arcade\mame64\mame64.exe

TI-99/4A rom folder: W:\Arcade\mame64\roms\ti99_4a.zip

TI-99/4A cart folder (example: Parsec): W:\Arcade\mame64\cart\Parsec.zip

 

mame.ini rompath line has been edited with the following:

rompath roms;consoles;cart;W:\Arcade\mame64\roms

 

When I open a command prompt, I first navigate to the W:\Arcade\mame64 directory. I then type in the following line to launch the game:

mame64.exe ti99_4a -cart parsec

 

After confirming the command line worked, my next step was to try and get this imported into Launchbox. I go to Tools->Import->ROM Files...

After selecting the zip file for Parsec and selecting Texas Instruments TI 99/4A for the platform, I'm then asked to select an emulator. I decided to create a new one and just call it MAMETI99. This is what the Emulator Details tab looks like (see attached screenshot):

Emulator Name: MAMETI99

Emulator Application Path: ..\Arcade\mame64\mame64.exe

Default Command-Line Parameters: ti99_4a -cart
None of the checkboxes are checkmarked.
Sample Command: mame64.exe ti99_4a -cart "FULL\PATH\TO\ROM\FILE"

The Associated Platforms tab only shows one associated platform: Texas Instruments TI 99/4A and it is checkmarked as the Default Emulator (see attached screenshot).

On the next screen I choose to "Use the files in their current location" and then click next for the rest of the screens leaving them to their defaults.

When I try launching Parsec, Launchbox shows the game loading screen but the emulator itself never loads before the process closes and I return to the Launchbox menu.

Thinking that it might be the rompath that was the issue, I then checkmarked the following in Emulator Details:

- Don't use quotes (primarily for Project64 1.6 and lower)
- Use file name only without file extension or folder path (Sega Model 2 Emulator, etc. compatibility)
Which changed the Sample Command to: mame64.exe ti99_4a -cart File
However, the issue is persisting. One thing I did notice is in the command line method, I can't use "W:\Arcade\mame64\mame64.exe" on the root of the W:\ drive in the command prompt otherwise it complains "Fatal error: Required files are missing".

Is there a way to get the TI-99/4A configuration with MAME working on Launchbox?

Emulator Details.png

Associated Platforms.png

Share this post


Link to post
Share on other sites

Ok just as I suspected from your /r/launchbox post, try this:

In your associated platforms default command line put:

ti99_4a -cart

You also may want to uncheck the Don't Use Quotes and Use File Name Only boxes, those in my experience have to be off with this type of stuff.

Also remove the ti99_4a -cart from the Default Command-Line Parameters box in the Emulator Details tab.

Here is a couple of screenshots of my Mame setup that I use for non arcade stuff.

screenshot_17.thumb.jpg.8e83c2776ea847295df20985c7c8146b.jpgscreenshot_16.thumb.jpg.046d4ca9a0962d4f0aa5e7d6d1dc5f4c.jpg

Share this post


Link to post
Share on other sites

Running into the same issue. Below are screenshots of the modified settings. When I double click on the game in Launchbox, the Load Screen appears for 2-3 seconds, then it's a black screen for 2-3 seconds, then the Load Screen once more for another 2-3 seconds before it disappears and I'm back to the Launchbox program.

I also tried increasing the Startup Load Delay for the emulator to about 10 seconds to see if that made any difference, but it did not.

EmulatorDetails.png

AssociatedPlatform.png

Load screen.png

Share this post


Link to post
Share on other sites

Interesting, it appears the Mame window is opening, going full to a black screen, and then closing. It does the same thing when I right click on the game and click on "Open MAMETI99..." If I go launch the mame64.exe directly in Windows Explorer, it opens up the mame menu. I'm running MAME v0.205.

I also tried adding Arcade as a platform and testing it with tmnt arcade. I got it working in command line, but it won't load via Launchbox.

So it's looking like I don't have MAME correctly set up in Launchbox?

Share this post


Link to post
Share on other sites

Where is your mame.ini located ? It should be put in the main folder with your mame executable, it doesn't like to launch properly when it's in the \ini folder.

Share this post


Link to post
Share on other sites

Thanks to the forums I figured out the issue and I apologize for not including everything on how I was launching the game. The thread is here:

I use Steam to open Launchbox/BigBox because I use Steam's mapping for my Dualshock 4. Apparently there is an issue when you try to open MAME via Launchbox which was opened by Steam, causing MAME to crash. There is a line in the mame.ini called joystickprovider, which by default is set to auto. It needs to be changed to xinput so it reads like this (these are currently lines 214-217 in my mame.ini: 

keyboardprovider          auto
mouseprovider             auto
lightgunprovider          auto
joystickprovider          xinput

This fixed the issue, MAME is no longer crashing and is actually launching the games.

Once again I apologize for not thinking to include I was using Steam to launch LB/BB. Texas Instruments games are now launching for me. Thank you for the support and patience.

Edited by True_Blue_VAA

Share this post


Link to post
Share on other sites

Not sure if they changed this in current versions of mame but I use an older version of mess

ti99_4a -cart parsec -peb:slot3 speech if you want the speech in parsec.  think you need ti99_speech.zip to  make this work

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×