Jump to content
LaunchBox Community Forums
DerekWorld

Setting up Philips CD-i with MAME

Recommended Posts

Hello, I've been scouring the forums and watched the CD-i Launchbox tutorial but now that MESS is integrated with MAME, the video instructions don't translate well anymore. I'm using the latest version of MAME with Launchbox for my Arcade Games. Can someone please point me in the direction of updated directions to get CD-i working with MAME and Launchbox or does this even work anymore?

Thanks! 

Share this post


Link to post
Share on other sites

Thanks for responding. I have tried that approach but am unable to get the emulator or games to launch for CD-i.

I've verified the cdimono1.zip exists in the MAME rom path

I've added the cdimono1 -cdrm command line in the associated platforms

I double checked the mame.ini to make sure the rom path points to the rom folder (does by default)

I've tried both the .iso / .cue and chd versions of the games but nothing happens.

I've successfully set up 20 other platforms but this one I just can't seem to make happen thus far. 

Share this post


Link to post
Share on other sites
1 hour ago, DerekWorld said:

Hello, I've been scouring the forums and watched the CD-i Launchbox tutorial but now that MESS is integrated with MAME, the video instructions don't translate well anymore. I'm using the latest version of MAME with Launchbox for my Arcade Games. Can someone please point me in the direction of updated directions to get CD-i working with MAME and Launchbox or does this even work anymore?

Thanks! 

to get cd-i to work with mess/mame they need to be in .chd format , if the are in bin/cue they need to be converted ... here is a link to a batch file which will do all the hard work for you if you need it ....

default commandline is :    cdimono1 -cdrm

Edited by harryoke
  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, harryoke said:

to get cd-i to work with mess/mame they need to be in .chd format

Is that something that got changed only for CD-i ?

Back when I did mess around with CD-i and Mame my cue + bin image worked but I have long since gotten rid of anything CD-i related and the few CD based things I do use for Mame now (NeoGeo CD and FM Towns Marty) work with cue + bin.

Share this post


Link to post
Share on other sites
1 minute ago, Lordmonkus said:

Is that something that got changed only for CD-i ?

Back when I did mess around with CD-i and Mame my cue + bin image worked but I have long since gotten rid of anything CD-i related and the few CD based things I do use for Mame now (NeoGeo CD and FM Towns Marty) work with cue + bin.

my bin/cue files never worked with mess , needed to convert to chd to get them to boot

Share this post


Link to post
Share on other sites

Weird, mine have worked though after double checking my NeoGeo CD and FM Towns Marty stuff I have since converted my NeoGeo CD to CHD but I know they worked before converting them and my FM Towns stuff is in cue + img formatscreenshot_106.jpg.646a23398ece6629b58adc6a6ec5cbd6.jpg

Share this post


Link to post
Share on other sites

Thanks for everyone's help. I have already converted my iso/cue files to chd using chdman.exe that was included MAME ver 206.  

Yes I've confirmed both cdimono files are in my MAME roms file.  Any other thoughts?  Thanks again.ex1.thumb.JPG.6d95f78f976b6459709890219dacb85e.JPGex2.thumb.JPG.1bb2f0191aa091e7ae8865d8071db3c9.JPGex3.JPG.eb551676e37af1bdb909eacee3d4bcc6.JPGex4.JPG.840a9f0704594ce1853ce6bba66d80b1.JPG

Edited by DerekWorld

Share this post


Link to post
Share on other sites

In your command line parameter is there a space between the hyphen and cdrm ? It looks like there is in the screen shot, if there is one remove the space.

Also is your platform in LB called Philips CD-i ?

Share this post


Link to post
Share on other sites

Good catch thanks. I removed the space between the hyphen and cdrm but it still doesn't launch. Yes, also confirmed the platform name matches the associated platform.

Share this post


Link to post
Share on other sites

Ok, I notice you have both Arcade and the CD-i in your associated platforms, are you using that Mame emulator entry for your arcade stuff as well ? If so set up a different entry because they have different check box requirements in Launchbox.

This is my Arcade Mame entry in LB:

screenshot_108.thumb.jpg.e33b614d07c988d63e2b1ff455435311.jpgAnd this one below is my Console Mame entry in LB:

screenshot_107.thumb.jpg.0384dd54a8d8f55bd3d3aec0409e9448.jpgNotice I have none of the boxes checked for the Console entry.

Share this post


Link to post
Share on other sites

MAME/MESS is tricky with files you should be able to launch games through the command line that aren't chd but to use the UI and launch anything it has to use the actual software list chd's. I know that for cart based software systems MAME will launch almost any type of file. I just tested with some Saturn cue bins I have and the cue loads fine in MAME

Share this post


Link to post
Share on other sites

Thank you so much! Creating a separate Mame emulator with the check boxes removed was the final solution for me to get it working. I really appreciate your help! Pretty excited to get this last piece in place. Also, here's an update. Now that I have the games working, I tried both a CHD version as well as the original ISO  / CUE files and both worked! In fact, I was able to have it use a zipped up version of the ISO/CUE files with no problem by going back and selecting the extract rom before running option. 🙂

Edited by DerekWorld
  • Like 1

Share this post


Link to post
Share on other sites

Yeah the check boxes for the console stuff is different than the arcade stuff.

And good to hear that the cue + bin files work as well, I was pretty certain they did.

  • Like 1

Share this post


Link to post
Share on other sites

This is good to know. I wasn't aware Cd-i emulation was working. I have been using 3D0 as I consider the two of them fairly cross platform.

  • Like 1

Share this post


Link to post
Share on other sites

I setup the CD-i with MESS version 0.161 the same way Brad did in his video and what I get is:

  • A teal colored screen for 15 seconds before the Philips settings screen appears (clock, date/time, etc)
  • I select "Play CD-1" and the teal screen appears for another 15 seconds

At this point the majority of the games display the error message "Sorry. In order to play this disk your cd-i must come equipped with a digital video cartridge." All of the games are CHD. Very few of them start without this error message.

Before I start tweaking I want to know if everyone else experiences these same issues. Teal screen, long launch times, fatal digital video cartridge error.

 

Share this post


Link to post
Share on other sites
1 minute ago, Drakkorcia said:

I setup the CD-i with MESS version 0.161 the same way Brad did in his video and what I get is:

  • A teal colored screen for 15 seconds before the Philips settings screen appears (clock, date/time, etc)
  • I select "Play CD-1" and the teal screen appears for another 15 seconds

At this point the majority of the games display the error message "Sorry. In order to play this disk your cd-i must come equipped with a digital video cartridge." All of the games are CHD. Very few of them start without this error message.

Before I start tweaking I want to know if everyone else experiences these same issues. Teal screen, long launch times, fatal digital video cartridge error.

 

only cirtain games that required the mpeg cartridge hardware addon get this error , most games dont use it. mine launch fine but there is a slight delay when launching them

 

Share this post


Link to post
Share on other sites

Yep. from what I understand there is no emulator that handles the games that required the extra cartridge yet, which is a shame because there's a few old game on there that would be fun.  But I mostly wanted this to work to check out the infamous Nintendo games on here. I remember being so jealous when I found out there were Zelda games I couldn't own.  As it turns out I dodged a bullet there.  😆

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...