Jump to content
LaunchBox Community Forums
eXo

eXoDOS v4

Recommended Posts

Regarding the merge of the latest eXoDOS and Win3xO - the documentation says to merge the DOS collection into the Windows structure.  Is that just moving the eXoDOS\Games directory (including !dos) into Win3xO\games?  Or do I dump everything under the top eXoDOS directory into Win3xO?

Share this post


Link to post
Share on other sites

Time to update my 2.0 collection 🙂

 

Thanks, great job... love being able to easily relive my childhood.

Share this post


Link to post
Share on other sites

Thanks. 

 

I can tell you that if you have v4, then you really don't need to bring anything over from v2 or v3. I don't remove games unless they are duplicated. And since v4 is already in launchbox, you already have that part taken care of for you.

  • Like 1

Share this post


Link to post
Share on other sites

I was wondering if there's a tutorial video for merging exodos 4 into launchbox.  If not that's cool, I'll get it figured out.  Also thanks for all the hard work.  Lots of good memories here.

Share this post


Link to post
Share on other sites

To merge your eXoDOS launchbox files into an existing launchbox installation, do the following:

First: 
Run setup.bat

Second: 
copy .\data\platforms\MS-DOS.xml from the exodos folder to your launchbox folder
move .\Manuals\MS-DOS\*.* from the exodos folder to your launchbox folder
move .\images\MS-DOS\*.* from the exodos folder to your launchbox folder
move .\eXoDOS\*.* from the exodos folder to your launchbox folder

  • Like 3
  • The Cake is a Lie 1

Share this post


Link to post
Share on other sites

Thank you so much for all of your hard work eXo. This pack is the easiest way to get Dos games up and running!

I would like to know if it is possible to run your collection through retroarch, since I would very much like to use overlays.

If this isn't possible, I would like to know if there is any way to change the resolution the games run in. Some games just run in a rather small window within a large black frame (when I run in full screen). Correcting the aspect ratio in the config menu does nothing.

Edited by SiriusVI

Share this post


Link to post
Share on other sites

image.thumb.png.54e61faa79ef8bc714d2830f5f2901bb.pngThis is wht most of the games I launch look like. How can I correct that? 

This is the only game being displayed correctly so far:

image.thumb.png.fc0007528489d4036e8ff9731fb1260c.png

Edited by SiriusVI

Share this post


Link to post
Share on other sites
On 10/23/2019 at 9:41 AM, eXo said:

To merge your eXoDOS launchbox files into an existing launchbox installation, do the following:

First: 
Run setup.bat

Second: 
copy .\data\platforms\MS-DOS.xml from the exodos folder to your launchbox folder
move .\Manuals\MS-DOS\*.* from the exodos folder to your launchbox folder
move .\images\MS-DOS\*.* from the exodos folder to your launchbox folder
move .\eXoDOS\*.* from the exodos folder to your launchbox folder

So I did everything here and I only get illegal command messages as in the picture.

dosbox.PNG

Share this post


Link to post
Share on other sites
6 hours ago, SiriusVI said:

Thank you so much for all of your hard work eXo. This pack is the easiest way to get Dos games up and running!

I would like to know if it is possible to run your collection through retroarch, since I would very much like to use overlays.

If this isn't possible, I would like to know if there is any way to change the resolution the games run in. Some games just run in a rather small window within a large black frame (when I run in full screen). Correcting the aspect ratio in the config menu does nothing.

No, it doesn't run through retroarch. Retroarch doesn't use the same versions of dosbox that I use.

 

As far as your display goes, do you have any kind of hardware acceleration for your video card turned on? Is it a laptop with integrated graphics?  Is it a desktop with an nvidia card running an agent? The problem is not with the collection, it is with the way your video card is handling it, as all of those games display fine for most folks.

Share this post


Link to post
Share on other sites
3 hours ago, Bushgopher said:

So I did everything here and I only get illegal command messages as in the picture.

dosbox.PNG

Then you did something else as well, because my conf files don't try and mount those folders. Looks like you tried to edit the confs or run different ones. At no point would it be trying to mount the 'extras' folder as the C: in any conf I included in the project.

Share this post


Link to post
Share on other sites

Thanks for the reply, exo. 

I use a desktop PC with an nvidia card. Other than nvidia control center, I don't use any GPU software. I don-t know about hardware acceleration. How do I turn that on/off?

Could custom DPI settings play a role?

EDIT: It's not the DPI settings, I just tested that.

Additional info: I do use multiple displays. One of the displays runs in 1080p, the other one has a higher resolution. I'm not sure that this is the problem, though, since every system I emulate (other than dosbox) works with this setup, and there are some dos games that display correctly, as I mentioned.

I've since found more games that display correctly:

image.thumb.png.13539547d79cd4cf1f2bf97ddfa34a43.png

Edited by SiriusVI

Share this post


Link to post
Share on other sites

I figured it out. The black bars appear if I set the graphics scaler to something other than "normal". Graphics filters work well for some games, but not for all of them.

Share this post


Link to post
Share on other sites

First of all, a HUGE thank you goes to eXo for starting this project, and to all those who have volunteered to help and make 4.0 possible as a team effort. I've been trying to do something like this for AGES and in a way lesser extension (so far configured 500ish games) and it's taken me forever. It's just something I've come to accept I will never be able to finish. All this goes to say I perfectly understand the sheer amount of effort required to do it, and by so, the true gratitude I'm trying to convey.

On a second note, from my experience, "openglnb" has always been the best option both for pixel accuracy and lack of dithering as well as for achieving a full screen with correct aspect ratio presentation. I really can't stand those filters that dither the graphics, they grind my gears.

Keep up the AWESOME work!

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...