Jump to content
LaunchBox Community Forums
Jason Carr

9.8-beta-1 Released

Recommended Posts

27 minutes ago, dov_EL said:

I only use retroarch, I haven't tried other emulators.
I've tested it on my Bartop with Encoder and Arcade Stick and it doesn't work.
I tried it on my primary PC and it doesn't work (Xbox Gamepad and keyboard)
I tried on my secondary PC with another gamepad and keyboard and it doesn't work.
I don't think it's a Windows MayUpdate problem since on Bartop I have the previous version of 1803 of Windows.

Did you set the pause option for controller automation? There are LB and BB settings. Both your videos show an Xbox One controller recognized.

It definitely works. It has been beta tested quite a bit. I have it running on 3 setups just fine.

Share this post


Link to post
Share on other sites
14 minutes ago, dov_EL said:

Not work with controller , 
not work with keyboard
Not work with Arcade Stick (+Encoder) 

You use Retroarch 1.7.7 or old version ?

I am using Retroarch 1.7.7.

Share this post


Link to post
Share on other sites
2 minutes ago, neil9000 said:

At this point I don't know what to answer.
Perhaps you have imported the old retroarch configuration, and therefore some function has remained unchanged. I have reconfigured everything from scratch and so maybe the problem comes out.
Even the bezel in retroarch 1.7.7 has problems starting a game if you don't turn OFF the new Menu WIdget.

Share this post


Link to post
Share on other sites
Just now, dov_EL said:

At this point I don't know what to answer.
Perhaps you have imported the old retroarch configuration, and therefore some function has remained unchanged. I have reconfigured everything from scratch and so maybe the problem comes out.
Even the bezel in retroarch 1.7.7 has problems starting a game if you don't turn OFF the new Menu WIdget.

Then it sounds like you have a configuration issue with Launchbox/Retroarch. My Retroarch 1.7.7 was also a fresh configuration, i started from scratch with 1.7.7 it is a completely new configuration with zero old configurations used.

Share this post


Link to post
Share on other sites
2 minutes ago, neil9000 said:

Then it sounds like you have a configuration issue with Launchbox/Retroarch. My Retroarch 1.7.7 was also a fresh configuration, i started from scratch with 1.7.7 it is a completely new configuration with zero old configurations used.

Absurd. Everything works perfectly between launchbox and retroarch except the pause menu.
On the bartop I have already tested the Pause, the Save State and Load state with the buttons I established. But on the PC I forgot everything by default and the Pause Menu just doesn't want to come out.
Really very strange.
Serve feedback from multiple people who restore retroarch 1.7.7 and the new version of launchbox.

Share this post


Link to post
Share on other sites
5 minutes ago, dov_EL said:

At this point I don't know what to answer.
Perhaps you have imported the old retroarch configuration, and therefore some function has remained unchanged. I have reconfigured everything from scratch and so maybe the problem comes out.
Even the bezel in retroarch 1.7.7 has problems starting a game if you don't turn OFF the new Menu WIdget.

Did you try any other emulator? You mentioned in a prior post you have not tried other emulators. I see in your video you have Mame and Model 2 emulators listed. Pause screens work fine with those two. Have you tested those on your setup?

Share this post


Link to post
Share on other sites

SOLVED 
It works only after configuring the Pause function in the BigBox with the gamepad commands, whereas instead from the desktop with the keyboard it does not work.

Share this post


Link to post
Share on other sites
1 minute ago, dov_EL said:

SOLVED 
It works only after configuring the Pause function in the BigBox with the gamepad commands, whereas instead from the desktop with the keyboard it does not work.

Yes, LaunchBox and Big Box have separate settings for all of that stuff. Some people only want to use it all in Big Box.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, dov_EL said:

SOLVED 
It works only after configuring the Pause function in the BigBox with the gamepad commands, whereas instead from the desktop with the keyboard it does not work.

ahhh, so doing exactly what everyone told you to do worked, what a shock! :o

  • Haha 2

Share this post


Link to post
Share on other sites
2 minutes ago, Omen said:

ahhh, so doing exactly what everyone told you to do worked, what a shock! :o

Let's not throw shade...drama isn't helpful here.

  • Like 1

Share this post


Link to post
Share on other sites
49 minutes ago, Jason Carr said:

Let's not throw shade...drama isn't helpful here.

You're right, I'm sorry.

  • Unusual Gem 1

Share this post


Link to post
Share on other sites
4 minutes ago, Omen said:

You're right, I'm sorry.

Well now I feel like a mean parent. ;)

  • Haha 1

Share this post


Link to post
Share on other sites

The new pause menus are so good, thanks. One more nail in the coffin for RocketLauncher.

I added a feature request to the tracker, but it seems to have been forgotten. Can you please give us a way to run an AHK script before the emulator launches, rather than just alongside it? I have a script that I use to setup controllers (specifically light guns and steering wheels), but it requires variables from Launchbox to run. The only way I can get it working at the moment via LaunchBox is to use RocketLauncher as an intermediary, which is such a waste considering the strides you've taken with all the extra features recently.

Share this post


Link to post
Share on other sites

Sorry, is there a chance that a mini guide for Pause screen could be published along with the official build? Frankly I am a bit lost? :(

 

Thank you

Share this post


Link to post
Share on other sites
5 hours ago, Tomkun said:

The new pause menus are so good, thanks. One more nail in the coffin for RocketLauncher.

I added a feature request to the tracker, but it seems to have been forgotten. Can you please give us a way to run an AHK script before the emulator launches, rather than just alongside it? I have a script that I use to setup controllers (specifically light guns and steering wheels), but it requires variables from Launchbox to run. The only way I can get it working at the moment via LaunchBox is to use RocketLauncher as an intermediary, which is such a waste considering the strides you've taken with all the extra features recently.

You should be able to run an AHK before the game launches using the additional apps feature. Right click and edit a game and choose the additional apps tab. 

4 hours ago, Wally said:

Sorry, is there a chance that a mini guide for Pause screen could be published along with the official build? Frankly I am a bit lost? :(

 

Thank you

I don't think a guide will be released. I recommend posting a thread in the troubleshooting or noobs sub-forum requesting help. We can give you a quick walkthrough there to keep the beta test threads clean for beta testing issues.  You can also watch the latest video on this release. ETA shows you a quick how to on using the Pause feature. 

Share this post


Link to post
Share on other sites
27 minutes ago, Retro808 said:

You should be able to run an AHK before the game launches using the additional apps feature. Right click and edit a game and choose the additional apps tab. 

I don't think a guide will be released. I recommend posting a thread in the troubleshooting or noobs sub-forum requesting help. We can give you a quick walkthrough there to keep the beta test threads clean for beta testing issues. 

I have already looked at that route and it's just not feasible.  The script needs a few variables from LaunchBox, such as romname and system in order to know what control settings it needs. As far as I'm aware, LaunchBox cannot pass these variables on to an external program (If it can, please tell me!). It's just not possible to configure all of the lightgun/driving games individually.

Share this post


Link to post
Share on other sites
4 minutes ago, Tomkun said:

I have already looked at that route and it's just not feasible.  The script needs a few variables from LaunchBox, such as romname and system in order to know what control settings it needs. As far as I'm aware, LaunchBox cannot pass these variables on to an external program (If it can, please tell me!). It's just not possible to configure all of the lightgun/driving games individually.

Until Jason does implement a solution I would post a thread out in troubleshooting. I have seen a couple members post some in depth responses to AHK questions. Maybe they can help find a workaround. I would be interested in any solution as I am about to build a driving cab.  

Share this post


Link to post
Share on other sites
Just now, Retro808 said:

Until Jason does implement a solution I would post a thread out in troubleshooting. I have seen a couple members post some in depth responses to AHK questions. Maybe they can help find a workaround. I would be interested in any solution as I am about to build a driving cab.  

I posted a couple of threads in the support forum, but they've both been pushed down unanswered. I also added a feature request on the BitBucket page. That's also been ignored so far. I'm not sure what else to do, really, hence me posting here. In the meantime I'll continue using RocketLauncher, but it does seem like such a pity as it's such a bloated piece of software for a workaround. I very much appreciate your interest in it though, so thank you.

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, Tomkun said:

The script needs a few variables from LaunchBox, such as romname and system

LB/BB will pass the rom name as %1%.   It won't pass the emu's game specific system though.

EDIT: I (half way) take that back.  It doesn't appear to pass the roms' name (as %1%) to an AHK script that's used under Additional Apps.  It will however pass it along if you create/Add an emulator that points to and AHK script.

Edited by JoeViking245

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...