Jump to content
LaunchBox Community Forums
Jason Carr

9.8-beta-1 Released

Recommended Posts

11 hours ago, Jason Carr said:

Beta 5 is out now with the very beginnings of the pause screens. At this point it's really just a proof of concept, but simply getting the pause screen showing and hiding properly is the hardest part of this endeavor. Some important notes:

Great work! You're getting one step closer to making RocketLauncher become completely redundant, which is certainly a good thing :) For what it's worth, RocketLauncher is a very fine addition to LaunchBox but its lack of updates and some other nuances such as the need for modules make it somewhat frustrating. I tried out the new pause feature with retroarch and mame, and so far everything seems pretty good!

Share this post


Link to post
Share on other sites

i have only tried RA but it seems to go into pause flawless. but i have an issue when i go out the game is still in its own pause mode. 

Share this post


Link to post
Share on other sites
Posted (edited)
  • Processor.png.1b36cd4bedcd4fe543a01fa8ae
  • Wanderer189
  • Members
  • 4
  • 45 posts

Game Startup Screen Broken now with Cemu

Just updated to v9.8 beta 5. Now when I run a game using Cemu in full screen, all I get is a black screen. I turn off the Game Startup Screen and all works fine again. I have 2 PC's and the one that I did not update is still working fine. Still testing other emulators

Edited by Wanderer189

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Wanderer189 said:
  • Processor.png.1b36cd4bedcd4fe543a01fa8ae
  • Wanderer189
  • Members
  • 4
  • 45 posts

Game Startup Screen Broken now with Cemu

Just updated to v9.8 beta 5. Now when I run a game using Cemu in full screen, all I get is a black screen. I turn off the Game Startup Screen and all works fine again. I have 2 PC's and the one that I did not update is still working fine. Still testing other emulators

Actually the latest pause screen feature has caused major issues to Bigbox. Game startup sometimes works and sometimes games don’t launch at all. I spend most of my time trying to work out why things are not working. I understand these are beta updates and more than likely I will be switching them off moving forward but I feel more emphasis is required on emulator integration.

@Wanderer189 I also have the same issue but not just cemu but demul, gameloader all rh... they work fine through launchbox but Bigbox is not responding, losing focus before and after exit, black screen as you said.

I will be rolling back and disabling auto update. I just can’t be bothered at the moment but I believe there is an issue with focus between applications since beta 4.

Edited by Juzzotec

Share this post


Link to post
Share on other sites

Thank you all. I'm slowly working through the issues and I'll get a new beta out soon.

@Juzzotec I warned everyone in this thread that there might be stability issues. Probably best to not use the betas if that's where you're coming from. They're betas for a reason.

  • Like 2

Share this post


Link to post
Share on other sites

Betas aren't just advance previews. They can and do contain bugs, stability issues, and in-progress features that are being field-tested. Jason constantly provides fair notice about this.

If you don't have the time or the patience to handle those possibilities, opt out of the betas and stick with the official releases.

  • Like 2

Share this post


Link to post
Share on other sites
5 hours ago, Wanderer189 said:
  • Just updated to v9.8 beta 5. Now when I run a game using Cemu in full screen, all I get is a black screen. I turn off the Game Startup Screen and all works fine again. I have 2 PC's and the one that I did not update is still working fine. Still testing other emulators

What version Cemu are you on? 

Just installed 1.15.4b and no issues with Startups and Cemu in BigBox. Pause seemed to work ok. The few tests I did on various games going in and out of pause did not show issues. 

Tested more Model 2, Dolphin, and Model 3 and same results as my last post. Model 3 worked well. Model 2 and Dolphin the more times I went in and out of pause I would get black screen or frozen image, but still heard audio. 

Share this post


Link to post
Share on other sites

@Jason Carr Would it be possible to make controller automation compatible with the Xbox Guide button, so that the guide button could be used as the Hold button? The button guide button is vk07sc000 instead of joy1, joy2, ect.

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)
53 minutes ago, Retro808 said:

What version Cemu are you on? 

Just installed 1.15.4b and no issues with Startups and Cemu in BigBox. Pause seemed to work ok. The few tests I did on various games going in and out of pause did not show issues. 

Tested more Model 2, Dolphin, and Model 3 and same results as my last post. Model 3 worked well. Model 2 and Dolphin the more times I went in and out of pause I would get black screen or frozen image, but still heard audio. 

I am running Cemu 1.15.4b as well. It's when I run Cemu in full screen using the "-f -g" paramaters in the Default Command Line Parameters. It is working fine if I go back one beta version in LB. So far this is the only issue I am having

Edited by Wanderer189

Share this post


Link to post
Share on other sites
41 minutes ago, Omen said:

@Jason Carr Would it be possible to make controller automation compatible with the Xbox Guide button, so that the guide button could be used as the Hold button? The button guide button is vk07sc000 instead of joy1, joy2, ect.

This is such a big deal for me. It's partly why I wrote my own pause system that I could trigger using the Guide button. So many people use Xbox controllers and it's the perfect button for it a) because it's what it was designed for on the 360 and b) because it's one button that wasn't actually on retro systems!

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)
8 minutes ago, SpaceMidget75 said:

This is such a big deal for me. It's partly why I wrote my own pause system that I could trigger using the Guide button. So many people use Xbox controllers and it's the perfect button for it a) because it's what it was designed for on the 360 and b) because it's one button that wasn't actually on retro systems!

Yup, those are both the reasons I use it.

Edited by Omen

Share this post


Link to post
Share on other sites
Posted (edited)

Not sure why..but I ran MAME 0.208 and KEGA Fusion to where when I exit I end up with a Black Screen. Anyone else having this issue or know why it's doing that now? I'd hate to disable Startup/Shutdown Screens in hopes that fixes things since I work so hard to get my Startup Screens to looking nice

Update: Turns out I already had MAME 0.208's Shutdown Screen already disabled..yet it still brings me to a Black Screen for some reason

Edited by RULLUR

Share this post


Link to post
Share on other sites
4 minutes ago, RULLUR said:

Not sure why..but I ran MAME 0.208 and KEGA Fusion to where when I exit I end up with a Black Screen. Anyone else having this issue or know why it's doing that now? I'd hate to disable Startup/Shutdown Screens in hopes that fixes things since I work so hard to get my Startup Screens to looking nice

My Mame goes to a black screen when exiting seems to be to do with the startup screens when I Alt Tab brings up the game over screen then back to Bigbox

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

My testing results so far (Cemu, Demul, and Dolphin seem to have the worst issues from what I've tried):

Cemu: Some games no longer boot when launched from LB/BB , but boot fine from Cemu (Edit: Seems to be the same issue @Wanderer189 is having, disabling startup screens fixes the issue). Other games boot fine from LB/BB. For those games Pause activates and deactivates fine but the game continues to run in the background.

CxBx Reloaded: Pause activates and deactivates fine, but the game runs in the background while the pause screen is active.

Demul: Pause activates fine but the screen is black after deactivating Pause, and the game continues to run in the background.

Dolphin: Pause activates fine but the screen is black after deactivating Pause, and the game continues to run in the background.

NullDC: Works perfectly.

PCSX2: Works perfectly.

PPSSPP: Sometimes it takes 2-5 seconds to activate, other times it's instant, but works perfectly besides that.

Raine: Pause activates and deactivates fine but the game continues to run in the background.

RetroArch: Works perfectly.

RPCS3: Sometimes it takes 2-5 seconds to activate, other times it's instant, but works perfectly besides that.

Xenia (D3D 12): Works perfectly.

Yuzu: Works perfectly.

 

Edited by Omen

Share this post


Link to post
Share on other sites

Yeah..that's what I've been having to do. If you Windows Key and click the X on the Black Screen, then you won't be able to Launch anything is what I found too. You'll have to leave BigBox and come back so it can Launch stuff again

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Wanderer189 said:

I am running Cemu 1.15.4b as well. It's when I run Cemu in full screen using the "-f -g" paramaters in the Default Command Line Parameters. It is working fine if I go back one beta version in LB. So far this is the only issue I am having

I am running the same settings and have no issues. So definitely something odd.

That's why the beta tests though. Helps Jason see if issues occur on different setups. So many pc variations out there. 

Share this post


Link to post
Share on other sites
4 hours ago, Jason Carr said:

Thank you all. I'm slowly working through the issues and I'll get a new beta out soon.

@Juzzotec I warned everyone in this thread that there might be stability issues. Probably best to not use the betas if that's where you're coming from. They're betas for a reason.

Yeah I understand, haven’t been on the forum as much. Thanks @Jason Carr

 

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, Wanderer189 said:

I am running Cemu 1.15.4b as well. It's when I run Cemu in full screen using the "-f -g" paramaters in the Default Command Line Parameters. It is working fine if I go back one beta version in LB. So far this is the only issue I am having

Just wanted to add more info, things I have tried: I am having the same black screen issue when using the following emulators with Game Startup Screens enable, if I disable them for the individual emulators, all is fine: (The games are starting and can get to them with ALT/TAB, even when you close emulator from there, it returns to Game Exit screen/LB/BB)

Cemu
Yuzu

I tried putting the LBThemes back to default, then the StarupThemes back to default but didn't help.

Something else I have noticed with these 2 emulators is that the Automation buttons are not even recognized, like to exit a screen, volume or pause, nothing.

I am using all the latest portable versions of Cemu, Yuzu (canary), Dolphin (dev/nightly), PCSX2 v1.5dev, and current Retroarch.

In all other games/emulators I have tried, all functions great, including the new PAUSE feature.

My system specs are:
Z390 Taichi with 8086k (oc @ 5.1), 32gb ram, 8TB WD HDD using 32gb optane modeule, Xbox 360, generic Xbox 360, PS4 controllers. For testing, maybe I will disable that, just to eliminate. (I have had rare caching issues with it in the past)

Hope it helps

UPDATE: Optane module was not issue, worth a shot.

Edited by Wanderer189

Share this post


Link to post
Share on other sites

On BigBox 9.8 beta 5, The shutdown screen fails to appear and put you back to BigBox. When you close an emulator, you are stuck in a black screen. alt+tabbing or clicking on the startup window in the taskbar seems to fix it.

This happened mainly with Retroarch and MAME (Arcade64 flavor) and not all the times, sometimes you go back normally, other times this happens.

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, Omen said:

@Jason Carr Would it be possible to make controller automation compatible with the Xbox Guide button, so that the guide button could be used as the Hold button? The button guide button is vk07sc000 instead of joy1, joy2, ect.

Yes! I was planning on posting this question also. Being able to assign a global function like pause to the guide button for every emulator is the best way to go, if possible. In fact, I wouldn't even assign it as a hold button, I would assign it as the only primary button... with the option to hold for like 3 seconds to activate. It's not really mappable to action buttons within emulators anyway, so it's just sitting there waiting for my favorite new LaunchBox feature to finally take advantage of it.

Edited by PanteraZombie

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...