Jump to content
LaunchBox Community Forums
Dane

Player 2 Controller in RA Not Working

Recommended Posts

Posted (edited)

I have a Hori FC4 that I have used without issue in RA (1.7.6). Its' setting in User 1 Binds are:

  • User 1 Device Type: RetroPad
  • User 1 Analog to Digital Type: Left Analog
  • User 1 Device Index: Fighting Commander (#1)

The settings I have on the controller itself are PS4 and DP.

The second controller I have just purchased is the Hori FC5. In the User 2 Binds, I feel like I have tried a combination of everything above but RA does not want to cooperate. I have used the Update Joypad Profile in the Online Updater. I have not messed with any Driver settings because everything works just fine with the Hori FC as player 1. Regarding Drivers, however, my Input is set on dinput and my Joypad is set on xinput. I have read many forum posts about people having problems with their player 2 controllers, but a lot of them seems to be non-PC related. Is anyone able to help with this? Thank you.

EDIT: I have DS4 on my PC and even though I have my two Hori FIghting Commander controller set on PS4, DS4 says no controllers are present. Despite this, my Hori FC4 has always worked as previously stated so I would not guess that would have anything to do with it but wanted to put as much information as I can in order to aid in anyone able to point me in the correct direction. Someone help me so I can finally kick my girlfriend's arse at Tetris! Please.

Edited by Dane

Share this post


Link to post
Share on other sites

Just wondering if this issue is because Retroarch sees the controllers as the same?

Image1.thumb.png.f8a30f2b0afb14dabcadd60a654e4f22.pngImage3.thumb.png.186bd647fb485b0decf51fd9ee04dcfd.pngIs that a possibility? If so, is there any way around that?

Share this post


Link to post
Share on other sites
Posted (edited)

I have still made it no further with this. My PC and MAME recognises both controllers just fine but Retroarch does not. MAME sees my FC4 as Joy 1 and the FC5 (the one Retroarch will not map) as Joy 3 so would it be a matter of entering this manually into Retroarch? I imagine it would need to be able to recognise the controller though, right?

image.thumb.png.583de4b4ba05e5c19e4e90de8fca0b33.pngIf so where would I put it as pretty much everything says "null" for player 1 even though player 1 is mapped just fine. I just am not making it anywhere with this one and I cannot help but think like most things it is something that is simple and glaringly obvious to another person, possibly.

Edited by Dane

Share this post


Link to post
Share on other sites

I have posted about this on the Libretro forum here but am still no closer to fixing this. Just thought I would post that here in case it prompts any help. Sorry, but I am at a complete loss with this one. DOes no one else out there have 2 Fighting Commanders on their setup? If so, have you had issues or has it all worked out well?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...