Jump to content
LaunchBox Community Forums
Jason Carr

The Great Emulator Coverage Thread

Recommended Posts

Posted (edited)

Just tested Virtual Jaguar 2.1.2 and pause screens seem to work without issue as far as I can tell (with default settings in LB/BB).  Sorry, forgot to also mention that startup and shutdown screens are also working as intended with this emulator.

-CDBlue

Edited by CDBlue
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Have a couple updates from my setup.

Citra, which previously worked well in the early betas, is now not functioning properly with the Pause Screens, or with Shutdown Screen. Im on beta 14. The startup screen does work properly and the emu does load. Emu version is Citra Canary 1354. I hadn't updated the emu until today, so I believe the issue was more so with a change in the beta's versus the emu itself. 

Along with that, Cxbx Reloaded works with the Startup screen and pause screen, however with closing it just minimizes the emu and doesn't work well with the shutdown screen. Both citra and cxbx reloaded have separate GUI screens that load prior to the game loading, so maybe that could be part of the issue

Edited by TheNewClassics

Share this post


Link to post
Share on other sites

I have managed to "solve" my problem with a workaround.

I was experimenting with AHK commands to solve my problem. I had an syntax error in my code, but this was the solution for my problem. The syntax error message is appearing only for 1 millisecond between the transition from the emulator to the pause screen. But somehow this causes the pause screen to work with retroarch now. 😅

It is not an elegant solution but at least now I can use the pause screen with retroarch.

Share this post


Link to post
Share on other sites

FS-UAE

Startup Screens: Work on my setup for both LB and BB (WHLoad games).  Screen is relatively fast ~5 seconds before going to UAE control. Slider doesn't alter timing so suspect exclusive screen at that point.

Pause: Broken. Mutes the game but doesn't pause and doesn't bring up menu for both force and non-forced. 

  • Like 1

Share this post


Link to post
Share on other sites
On 5/12/2019 at 9:26 AM, TheNewClassics said:

Have a couple updates from my setup.

Citra, which previously worked well in the early betas, is now not functioning properly with the Pause Screens, or with Shutdown Screen. Im on beta 14. The startup screen does work properly and the emu does load. Emu version is Citra Canary 1354. I hadn't updated the emu until today, so I believe the issue was more so with a change in the beta's versus the emu itself. 

Along with that, Cxbx Reloaded works with the Startup screen and pause screen, however with closing it just minimizes the emu and doesn't work well with the shutdown screen. Both citra and cxbx reloaded have separate GUI screens that load prior to the game loading, so maybe that could be part of the issue

Have you tested with Forceful Activation both enabled and disabled? Cxbx Reloaded in particular I've had at least three reports of it working properly for everything, so that's odd.

Share this post


Link to post
Share on other sites

Thanks all; I have the table updated. Hoping to improve compatibility with some of the broken ones this week.

Share this post


Link to post
Share on other sites
Posted (edited)

SSF

Startup: Works

Pause: Emulator closes after opening the pause screen. Tried it with every option.

 

1 hour ago, Jason Carr said:

Have you tested with Forceful Activation both enabled and disabled? Cxbx Reloaded in particular I've had at least three reports of it working properly for everything, so that's odd. 

I have the same issue. Have tested both options.

Edited by deliyuerek85

Share this post


Link to post
Share on other sites
Posted (edited)

FYI, just tested latest beta (9.8 beta 15) and have a couple more emulators to report what I've seen:

BSNES (v107r3) - SNES - Startup/shutdown and pause screens all work as intended without issues for me

Blastem (v0.6.3-pre 64-bit) - Sega Genesis - Startup/shutdown screens work without issues.  Hitting the key to go to the pause screen caused a black screen to appear.  After about 30 seconds launchbox crashed and Blastem became unresponsive and had to be ended via task manager/process.

Edited by CDBlue

Share this post


Link to post
Share on other sites

Startup works however shutdown does not in the emulators below and when exiting the games it freezes the screen however the game audio continues to play. Also in Action Max you'll see the game starts before the startup finishes.

Daphne
Daphne Singe
 

 

Share this post


Link to post
Share on other sites

Thanks guys; I've updated the list. When testing, it would be useful to know what all settings you tried. I am going to go ahead with the official release here in the next day or two, but we'll keep working on emulator compatibility as time goes on.

For some problematic emulators (specifically regarding pause screens), it may work best to disable "Suspend Emulator Process While Paused" and then put in AutoHotkey scripts to trigger the pause keyboard shortcut. Just another option to try for emulators that are not currently working.

We'll keep updating this list going forward.

Share this post


Link to post
Share on other sites

I have been messing with some of the scripts and what some of the emulators can and cannot do/use as far as reset and swapping disc scripts. So here is list as of Beta 17:

Daphne:

Pause Works but not through normal method if:

  1. Suspend Emulator Process While Paused = Off
  2. Forceful Pause = Off
  3. On Pause Tab
;Daphne pause is keyboard "p"
#IfWinActive ahk_exe DAPHNE.exe ; note ahk_class SDL_APP used by Hatari and KAT5200
Send p

3. On Resume Tab

;Daphne toggle back to active
#IfWinActive ahk_exe DAPHNE.exe ; note ahk_class SDL_APP used by Hatari and KAT5200
Send p

4. Reset Tab (it takes about 10 seconds to reset so initially seems like not working)

;Daphne emulator reset is F3
#IfWinActive ahk_exe DAPHNE.exe
Send {f3}

5 . Save State, Load State, Swap Disc ; not used by Daphne

If Suspend Emulator Process While Paused = On (normal)  then loses focus during Pause (Menu comes up) and also doesn't pause game. 

=====================

Pinball

Visual Pinball (with B2S running): Pause Works Normally:  Forceful Off  Reset, Save State, Load State, Swap Disc; Not Used by Emulator

Pinball FX3: Pause doesn't work normally with or without forceful.   Doesn't bring up menu at all.  The Suspend Emulator Process While Paused = Off trick like for Daphne doesn't work (no menu). Doesn't seem to capture AHK entries.  Reset, Save State, Load State, Swap Disc; Not Used by Emulator

The Pinball Arcade (using TPAFreeCamMod.exe) and Future Pinball (with BAM) Pause doesn't work normally with or without forceful - loses focus, no pause. The Suspend Emulator Process While Paused = Off trick like for Daphne doesn't work, exits out of full screen and doesn't always pause with default ESC.   Reset, Save State, Load State, Swap Disc; Not Used by Emulator.  Still messing with them with combos but  "pre-launcher" type programs don't play well.. 

=====================

AppleWin

Pause Works Normally:  Forceful Off

1.  Reset Tab ; works

; AppleWin emulator reset is F2
#IfWinActive ahk_class APPLE2FRAME
Send {f2}

2. Save State; works, but not too useful without getting fancy with AHK since need keyboard

; AppleWin save state is F11 but not too useful since brings up explorer window for selection and have to use keyboard
#IfWinActive ahk_class APPLE2FRAME
Send {f11}

3. Load State; works but need keyboard

; AppleWin load state is F12 but not too useful since brings up explorer window for selection and have to use keyboard
#IfWinActive ahk_class APPLE2FRAME
Send {f12}

4. Swap Disc; works

; AppleWin swap disc is F5
#IfWinActive ahk_class APPLE2FRAME
Send {f5}

==============

miniVMac

Pause Works Normally:  Forceful Off

1. Save State, Load State, Swap Disc Tabs ; not used by miniVMac

2. Reset Tab;  works (CTRL R) but not useful since it is ejects disc with reset and reboots with no disc in drive (i.e., have to exit and restart)

;Reset causes disc to eject so comment out
#IfWinActive ahk_class minivmac 
{
Send {LCtrl Down}RY
Send {LCtrl Up}
} 

===================

Altirra

Pause Works Normally:  Forceful Off

1.  Reset Tab ; works

;Altirra Hard Reset is SHIFT F5 - Keeps disc in system 
#IfWinActive ahk_class AltirraMainWindow
Send +{f5}

Save State, Load State, and Disc Rotate  - No default keys assigned. Must use Shortcut feature to assign in Emulator to one of the functions:

Assign these functions: Quick Save State, Quick Load Save State, Save State (brings up Menu-keyboard needed), Load Save (brings up Menu-keyboard needed)  - None really useful since keyboard. Quicksave will over write last used of any game.

Swap Disc Example

;Altirra assigned in Shortcuts menu CTRL SHIFT F10 for Rotate Down
#IfWinActive ahk_class AltirraMainWindow
Send ^+{f10}

======

Steem

Pause Works Normally:  Forceful Off (must be off)

Similar to Altirra, no default keys for Swap Disc, Load State, or Save State.  Must assign via the Configure Keyboard Shortcuts feature.

Assign key for "Cold Reset and Run"  = Reset Tab

Assign "Swap Discs in Drives" = Swap Discs Tab

Load and Save Memory Snapshot feature requires keyboard.  Similar issues with quick save states as Altirra but haven't fully tested.

=================

KAT5200

Pause Works Normally:  Forceful Off

1. Swap Disc Tabs ; not used by kat5200

2. Reset - if controller assigned rather than keyboard the reset key command doesn't appear available. 

3. Load State from 9 slots - ALT 1 to ALT 9  - Results seemed unreliable (emulator issue), games would work oddly after load. 

4. Save State from 9 slots - SHIFT 1 to SHIFT 9 - Not using due to above.

==============

WinVice

Pause Works Normally - Forceful off

1. Reset (Hard) - CTRL ALT R - Not using since seems to fry emulator and not reboot disc. Similar with soft reset

2.  ALT S and ALT L for Quick save and load state; haven't tested

============

ePSX

Pause Works Normally:  Forceful Off (must be off, doesn't work with on)

1. Save state; works

;ePSX save state F1;  F2 is to increment up a slot
#IfWinActive ahk_exe ePSXe.exe
Send {f1} 

2. Load State; works

;ePSX load state F3;  F2 is to increment up a slot
#IfWinActive ahk_exe ePSXe.exe
Send {f3} 
  

3. No reset or swap disc command that can be assigned to hotkey that I can find.

 

  • Like 4

Share this post


Link to post
Share on other sites

Testet Mednafen version 1.22.2 standalone emulator with pause screen on ps1, the pause screen works when you enable forceful pause screen activation. I also tested this script to reset the game as well and is working.

; Medmafem resets game with F10 key by default
Send {F10 down}
Sleep 50
Send {F10 up}

 

I also tested Kega Fusion version 3.64 with a Mega Drive / Genesis game and is working also with forceful pause screen activation enabled. I also tested this script to reset game and is also working.

; Kega Fusion resets game with Tab key by default
Send {Tab down}
Sleep 50
Send {Tab up}

 

 

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, MazeGuardian said:

Testet Mednafen version 1.22.2 standalone emulator with pause screen on ps1, the pause screen works when you enable forceful pause screen activation. I also tested this script to reset the game as well and is working.

; Medmafem resets game with F10 key by default
Send {F10 down}
Sleep 50
Send {F10 up}

 

I also tested Kega Fusion version 3.64 with a Mega Drive / Genesis game and is working also with forceful pause screen activation enabled. I also tested this script to reset game and is also working.

; Kega Fusion resets game with Tab key by default
Send {Tab down}
Sleep 50
Send {Tab up}

Thanks; updated the grid. I'm thinking we might create a new thread here soon to keep track of scripts as well.

Share this post


Link to post
Share on other sites

Alright, I updated the first post of this thread. There's a new Google Sheets document with the previous grid and now scripts as well:

https://docs.google.com/spreadsheets/d/1wuGiwg8I5QqulDncQvGBZP83BVDSXpbSOzdYqDrsCxI/edit?usp=sharing

We'll work through getting the script contributions from this thread in there, and as we get more scripts and testing details, the moderators and myself have access to updating the document, so we'll get it updated as we go. :)

  • Like 1

Share this post


Link to post
Share on other sites

'ePSX

Pause Works Normally:  Forceful Off (must be off, doesn't work with on) '

Noob question - What is Forceful? I don't see it in the options. I really want pause working on ePSXe :)

Share this post


Link to post
Share on other sites
On 5/23/2019 at 5:58 PM, Lukeyboy67 said:

'ePSX

Pause Works Normally:  Forceful Off (must be off, doesn't work with on) '

Noob question - What is Forceful? I don't see it in the options. I really want pause working on ePSXe :)

In the emulator settings in LaunchBox for ePSXe, there's a forceful activation option under the pause screens tab.

  • Like 1

Share this post


Link to post
Share on other sites

Future Pinball:

Pause and startup screens work. I had to use @sundogak's instructions with the following command in emulator settings:

/open %romfile% /play /exit

 

  • Like 1

Share this post


Link to post
Share on other sites

Here is my complete set up review of the startup screen and pause screen. It seems to be working on most, but there are a few issues currently. Love the idea though and would love to see this perfected =D

Startup Screens:

ePSXe: shows, but becasue of the rescaling of the screen in the emulator, it also rescales the startup screen? Also a brief flash of appears on exite before end screen.

Mesen: seems to work perfectly, but game has already loaded slightly into startup video of the game, before startupscreen disappears.

PPSSPP: seems to work perfectly, but game has already loaded slightly into startup video of the game, before startupscreen disappears.

No$GBA: works perfectly

Dolphin: shows but becasue of the rescaling of the screen in the emulator, it also rescales the startup screen?

Project64: seems to work almost perfectly, but game has already loaded slightly into startup video of the game, before startupscreen disappears. Only issue is the screen breifly flashes (presumably when the emulator loads in the background), the game noise starts and then the startup screen disapeears.

Snes9x: seems to work perfectly, but game has already loaded slightly into startup video of the game, before startupscreen disappears.

PCSX2: works perfectly

Retroarch: Seems to work perfectly on genesis-plus-core, but loads into the game startup video on the mednafen-saturn core, before the startup screen disapears

Demul: works perfectly

 

Pause Screens:

ePSXe: works perfectly

Mesen: works perfectly

PPSSPP: works perfectly

No$GBA: doesn't show at all

Dolphin: again, it shows, but the rescaling of the emulator messes up the scaling of the pause screen.

Project64: works perfectly

Snes9x: works perfectly

PCSX2: works perfectly

Retroarch: works perfectly

Demul: works perfectly

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...