Jump to content
LaunchBox Community Forums

Exiting Cemu stopped working


Recommended Posts

Hi, as of Launchbox 9.9 (or maybe a not so old earlier version), I can no longer exit a Cemu game with my usual xbox one controller automation pressing hold button Back and then Start.

This no longer seems to work in the emulator exit ahk script with Cemu for some reason:  Process, Close, {{{StartupEXE}}}. I also tried uisng Send !{f4}

This worked fine for a very long time, but broke with one of the recent LB upgrades.

Does it work for anyone? If so, how did you get it to work.

 

Edited by ckp
Link to post
Share on other sites

Running LB 9.9 and CEMU 1.15.8. The new Pause feature as well as the existing AHK exit scripts I had work.  I use ESC and XBOX One Guide Button for exit prior.  

$Esc::
Process, Close, {{{StartupEXE}}}

;for exit with one press of XBOX Guide Button
$vk07:: 
Process, Close, {{{StartupEXE}}}

Also the controller automation works as well. I have settings both in LB as well as BB using Back button as HOLD and the "X" button as exit with "Y" as Pause.

So not sure on what the issue would be other than to check CEMU version and double checking buttons mapped in controller automation.

Link to post
Share on other sites

No issues with latest version of Cemu and Launchbox. I would however recommend using the below AHK. It was discovered that original closing AHK was a hard close of emulators and with certain emulators that needed to be closed properly like Higan it would not allow for saves states to be saved. 

You can use this with any emulator just change the exe name to the emulators specific .exe

$Esc::
{
    WinClose, ahk_exe Cemu.exe
}

 

Link to post
Share on other sites
23 minutes ago, ckp said:

yeah, this stuff used to work for me with Cemu and those scripts, but not anymore...thanks for replying

If you shut off Startup themes and Pause themes for just Cemu can you exit a game properly?

Link to post
Share on other sites

i am able to exit the games again using my controller and same ahk script. for some reason i had to disable cemu from running as admin. now i'm battling why some cemu games are crashing cemu only when launched from LB and not when launched only be cemu...

Link to post
Share on other sites
  • 5 months later...
  • 1 month later...

Same issue here, I can hit Esc and close CEMU but my Back + Start combo that works with every other emulator is not working. Using LB 10.10 and CEMU 1.17.1 with the following script. 

$Esc::

{

WinClose, ahk_exe Cemu.exe

}

Link to post
Share on other sites
On 2/8/2020 at 7:41 PM, xz38 said:

Same issue here, I can hit Esc and close CEMU but my Back + Start combo that works with every other emulator is not working. Using LB 10.10 and CEMU 1.17.1 with the following script. 

$Esc::

{

WinClose, ahk_exe Cemu.exe

}

Maybe give this a try.

ESC::
{	
    SetTitleMatchMode, 2
    WinWaitActive, Cemu
    Send !{f4}    			
}

 

Link to post
Share on other sites
  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...