Jump to content
LaunchBox Community Forums
Beatlemaniac19

Having Trouble with Pause Screen...

Recommended Posts

Hey guys,

I'm hyped about the additions of pause screens. LB's constant updates are the reason I think it's the best front end available.

However, I'm a bit confused on how to get the pause screens to function the way I like. After watching ETA Prime's tutorial video on getting the pause screen functioning I've gotten it to work, but only in this state:

IMG_0158.thumb.JPG.c6853a666fd687d3fcb6bd246e3c511e.JPGAs you can see the pause function works, but it doesn't pull up the menu like in the LB tutorial video. That's what I'm trying to get done. For reference, the only emulator I'm using is RetroArch and I followed the video's instructions to a tee, but with no results. The script Google Docs document also states that RetroArch doesn't need the use of any scripts.

Lastly, note that I've disabled all keyboard functions within RetroArch besides opening the RA menu and exiting the program so I can play computer games without accidentally saving/loading states and doing various hotkeys with a keyboard input. Just wanted to note that in case that's the reason something is broken.

Share this post


Link to post
Share on other sites
3 minutes ago, Beatlemaniac19 said:

Hey guys,

I'm hyped about the additions of pause screens. LB's constant updates are the reason I think it's the best front end available.

However, I'm a bit confused on how to get the pause screens to function the way I like. After watching ETA Prime's tutorial video on getting the pause screen functioning I've gotten it to work, but only in this state:

IMG_0158.thumb.JPG.c6853a666fd687d3fcb6bd246e3c511e.JPGAs you can see the pause function works, but it doesn't pull up the menu like in the LB tutorial video. That's what I'm trying to get done. For reference, the only emulator I'm using is RetroArch and I followed the video's instructions to a tee, but with no results. The script Google Docs document also states that RetroArch doesn't need the use of any scripts.

Lastly, note that I've disabled all keyboard functions within RetroArch besides opening the RA menu and exiting the program so I can play computer games without accidentally saving/loading states and doing various hotkeys with a keyboard input. Just wanted to note that in case that's the reason something is broken.

Do your retroarch options match these?

image.thumb.png.e188b9b66f0ce5593675301108ab04bd.png

  • Thanks 1

Share this post


Link to post
Share on other sites
35 minutes ago, neil9000 said:

Do your retroarch options match these?

image.thumb.png.e188b9b66f0ce5593675301108ab04bd.png

Yes sir Neil. I have all of those boxes ticked.

Btw I noticed within the default folder of pause themes there is an Arcade.xaml file and a Default.xaml file. Is it the case that I need to direct towards the Arcade.xaml file? If so, how?

Share this post


Link to post
Share on other sites
2 minutes ago, Beatlemaniac19 said:

Is it the case that I need to direct towards the Arcade.xaml file? If so, how?

No, that is just because the Arcade Pause shows slightly different images, so is a different file.

What button have you set in launchbox to activate the pause, and is it keyboard or controller you are using to activate the pause screen?

  • Like 1

Share this post


Link to post
Share on other sites
22 minutes ago, neil9000 said:

No, that is just because the Arcade Pause shows slightly different images, so is a different file.

What button have you set in launchbox to activate the pause, and is it keyboard or controller you are using to activate the pause screen?

I've enabled it on the controller as the Select (hold button) + Start to enable the game pause. I had it configured to the keyboard for testing purposes and set it to the spacebar. Both work, but with the results on the image shown above,

Edited by Beatlemaniac19

Share this post


Link to post
Share on other sites
3 minutes ago, Beatlemaniac19 said:

I've enabled it on the controller as the Select (hold button) + Start to enable the game pause. I had it configured to the keyboard for testing purposes and set it to the spacebar. Both work, but with the results on the image shown above,

If you alt tab after activating the pause do you see the screen but its not got focus, or is there nothing at all?

Share this post


Link to post
Share on other sites
53 minutes ago, neil9000 said:

If you alt tab after activating the pause do you see the screen but its not got focus, or is there nothing at all?

Using Tab + Alt does work, but it brings up the same pause menu in my first post. Do you think using a script would solve this issue as a failsafe?

Share this post


Link to post
Share on other sites
2 minutes ago, Beatlemaniac19 said:

Using Tab + Alt does work, but it brings up the same pause menu in my first post.

All i see in your first post is super mario all stars paused in the emulater, so you dont see a screen like this when you alt tab?

687222804_Screenshot(229).thumb.png.1e6079a5945fe037f18204ce4a8243fe.png

Share this post


Link to post
Share on other sites
2 minutes ago, Beatlemaniac19 said:

No sir. That's the issue Neil.

Well in that case, the pause isnt working at all, normally if its not showing for people its a focus issue, and the screen will be there if you alt tab, its just not up front, if you dont see that then all you are doing is pausing the emulator, which is what you show in your image, just the emulator paused. So im a little confused at this point.

Do the startup/shutdown screens work for you with retroarch?

Share this post


Link to post
Share on other sites
2 minutes ago, neil9000 said:

Well in that case, the pause isnt working at all, normally if its not showing for people its a focus issue, and the screen will be there if you alt tab, its just not up front, if you dont see that then all you are doing is pausing the emulator, which is what you show in your image, just the emulator paused. So im a little confused at this point.

Do the startup/shutdown screens work for you with retroarch?

If you mean the loading game screen with the cartridge and the game over screen then yes, they do work.

Share this post


Link to post
Share on other sites
9 minutes ago, Beatlemaniac19 said:

If you mean the loading game screen with the cartridge and the game over screen then yes, they do work.

These are the only options i have set for Pause in Launchbox and it works just fine with Retroarch.

1463373272_Screenshot(230).thumb.png.dfcfae480052aae35a086cada11917ad.png1207172578_Screenshot(231).thumb.png.2b910ae511a0499a065229878f908e68.pngAnd of course i have then set it up again in BIgbox as it needs activating in both UI's separately.

Share this post


Link to post
Share on other sites
1 hour ago, neil9000 said:

These are the only options i have set for Pause in Launchbox and it works just fine with Retroarch.

1463373272_Screenshot(230).thumb.png.dfcfae480052aae35a086cada11917ad.png1207172578_Screenshot(231).thumb.png.2b910ae511a0499a065229878f908e68.pngAnd of course i have then set it up again in BIgbox as it needs activating in both UI's separately.

Yeah man I went through with those settings and couldn't get it to work. Maybe it's because I'm on an old Windows 7 PC lol. I can't figure it out. Oh well

Share this post


Link to post
Share on other sites

@neil9000 I figured out the problem. There seems to be an error when entering full-screen mode where RetroArch overrides the LB pause screen. Here's some pictures to show you...

1) Launching a game out of full-screen mode to windowed mode:

2) Toggling the pause screen successfully in windowed mode:

3) Changing windowed mode to full-screen mode

4) Attempting the pause screen but it's not working and RA is overriding the controls.

As mentioned before, I've disabled all keyboard inputs in RA so it seems to just be a bug I'm encountering when entering full-screen mode and not that RA's keyboard controls are overriding my LB configuration. I've tried adjusting all of the other settings in RA and LB, but it seems that the problem is simply full-screen mode in RA.

Do you know a workaround Neil or do you think this is a bug that should be reported to Jason to hopefully patch out by next release?

Btw don't know if you're an American or not, but happy Independence Day! :)

IMG_0160.JPG

IMG_0161.JPG

IMG_0162.JPG

IMG_0163.JPG

Share this post


Link to post
Share on other sites
7 minutes ago, Beatlemaniac19 said:

@neil9000 I figured out the problem. There seems to be an error when entering full-screen mode where RetroArch overrides the LB pause screen. Here's some pictures to show you...

1) Launching a game out of full-screen mode to windowed mode:

2) Toggling the pause screen successfully in windowed mode:

3) Changing windowed mode to full-screen mode

4) Attempting the pause screen but it's not working and RA is overriding the controls.

As mentioned before, I've disabled all keyboard inputs in RA so it seems to just be a bug I'm encountering when entering full-screen mode and not that RA's keyboard controls are overriding my LB configuration. I've tried adjusting all of the other settings in RA and LB, but it seems that the problem is simply full-screen mode in RA.

Do you know a workaround Neil or do you think this is a bug that should be reported to Jason to hopefully patch out by next release?

Btw don't know if you're an American or not, but happy Independence Day! :)

IMG_0160.JPG

IMG_0161.JPG

IMG_0162.JPG

IMG_0163.JPG

Do you have "Windowed Fullscreen mode" enabled in Retroarch?

1059319729_Screenshot(237).thumb.png.5fa8775342272780c8c96e68c5490de3.png

Share this post


Link to post
Share on other sites
10 minutes ago, neil9000 said:

Do you have "Windowed Fullscreen mode" enabled in Retroarch?

1059319729_Screenshot(237).thumb.png.5fa8775342272780c8c96e68c5490de3.png

Yes sir. I have it enabled. Do you know of any other settings in the video folder that could be affecting my config?

Share this post


Link to post
Share on other sites

Try changing the video driver (gl, vulkan, d3d12, etc) in RetroArch and see if it makes any difference with full screen vs fullscreen windowed. What video card do you have out of curiosity? I was having some weird issues with an integrated Intel video. I threw an old nVidia 750ti in and my problems have gone away in regards to the fullscreen vs full screen windowed stuff. If you only have an intel, don't select Vulkan or RA will crash and you'll have to open the RA config file to fix it. The gl driver looked the best on my intel card but it had a few issues with certain cores like bezel support and the like. Its something to try I guess.

Share this post


Link to post
Share on other sites
On 7/2/2019 at 5:43 PM, neil9000 said:

Well in that case, the pause isnt working at all, normally if its not showing for people its a focus issue, and the screen will be there if you alt tab, its just not up front, if you dont see that then all you are doing is pausing the emulator, which is what you show in your image, just the emulator paused. So im a little confused at this point.

Do the startup/shutdown screens work for you with retroarch?

i have this focus issue with RetroArch. Alt+tab won't bring the pause screen to the foreground though. The pause screen shows on top in focus the first time its triggered but then after that, it shows up in the background and can't be pulled into focus. but its still able to be interacted with. This only occurs with BigBox... LaunchBox doesn't seem to have the issue and the pause screen always shows on top in focus. RetroArch is the only emulator that seems to have this issue as well.

Is there a solution to this? @Jason Carr

I really don't want to have to disable pause screens for retroarch as thats the emulator i use for the majority of my platforms and i really like the save/load state and pause functionality when it works... Mame handles it like a dream and its awesome to pause arcade games that can't normally be paused, save state and load back up again later.

Share this post


Link to post
Share on other sites
19 hours ago, MrSco said:

i have this focus issue with RetroArch. Alt+tab won't bring the pause screen to the foreground though. The pause screen shows on top in focus the first time its triggered but then after that, it shows up in the background and can't be pulled into focus. but its still able to be interacted with. This only occurs with BigBox... LaunchBox doesn't seem to have the issue and the pause screen always shows on top in focus. RetroArch is the only emulator that seems to have this issue as well.

Is there a solution to this? @Jason Carr

I really don't want to have to disable pause screens for retroarch as thats the emulator i use for the majority of my platforms and i really like the save/load state and pause functionality when it works... Mame handles it like a dream and its awesome to pause arcade games that can't normally be paused, save state and load back up again later.

Most often issues like this are caused by faulty video drivers, but it's hard to pinpoint. The pause screens use Windows APIs and methods that are not commonly used, because they have to, just by nature. That's one of the reasons why we held off on implementing them for so long, because they require semi-hacks by nature and can't be implemented any other way. So generally, unfortunately there's not a whole lot we can do to fix one-off issues on certain machines like that. Most likely it is a video driver issue, but it's going to be impossible for us to look into it without having your specific hardware, unfortunately.

Share this post


Link to post
Share on other sites

My experience with the pause screens and RetroArch is they work 100% of the time in Launchbox. In Bigbox however, I can pause 7, 8, or 9 times (Maybe more or less than that, but definitely more than just once) and then Pause will no longer work. Opening and closing a retroarch game has no effect and trying a platform that uses a different core but same retroarch exe has no effect. The only way I've gotten Pause to work again is to close and re-open BigBox where Pause will only work a few times again. Alt Tabbing has no effect.

If there is a game I am spamming save and load states through Pause, I can only do it within Launchbox. But now, I'm kind of over it and just use a key combo through RetroArch to save or load states and skip Pause altogether. Probably should have been doing that to begin with, but yeah. Something not entirely right with Pause in BigBox for me. But I have no issues with this in Launchbox.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...