Jump to content
LaunchBox Community Forums

CXBX Reloaded script needed


Recommended Posts

5 minutes ago, DeadVoivod said:

I mean the games starts, I can play, but all of a sudden LB is showing the closing screen, and closes. But the game stays, only that it goes from fullscreen to windowed mode. 

He means messing with the Startup theme setting in LB. Go to >Tools>Manage emulators and edit CXBX. In the Startup tab turn of startup themes and see if the issue goes away. If it does you now know it is LB Startups causing the issue. You can then turn it back on and tweak the settings in it to see if you can find a setting that will not cause the issue.  

Link to post
Share on other sites
38 minutes ago, DeadVoivod said:

Don't know what you mean?

I meant the LaunchBox / BigBox startup screens. One thing you could try that I can think of. Do the games run if you try them in CXBX directly? Sometimes an emulator in heavy development has a regression that prevents games that once worked from working.

What workes for me:

- Setting cxbx-ldr.exe as my emulator in LaunchBox using the /load argument in the command line.

- No ahk script except to close cxbx-ldr.exe

- Ticking "Use Exclusive Fullscreen Mode" in CXBX videosettings. (I myself use a Display Resolution 3840 x 2160 32 bit.)

- In LaunchBox "Manage Emulator" settings for CXBX Reloaded in the "Startup Screen" tab: "Hide all windows that are not in Exclusive Fullscreen Mode" ticked with a "Startup Load Delay" of 3 seconds.

 

One thing to note though, I do not have the games you mentioned as not working. (Blood Wake and Crimson Skies).

Edited by Koroth
Link to post
Share on other sites
1 hour ago, Koroth said:

What workes for me:

- Setting cxbx-ldr.exe as my emulator in LaunchBox using the /load argument in the command line.

- No ahk script except to close cxbx-ldr.exe

- Ticking "Use Exclusive Fullscreen Mode" in CXBX videosettings. (I myself use a Display Resolution 3840 x 2160 32 bit.)

- In LaunchBox "Manage Emulator" settings for CXBX Reloaded in the "Startup Screen" tab: "Hide all windows that are not in Exclusive Fullscreen Mode" ticked with a "Startup Load Delay" of 3 seconds.

Ok, it works partially for me. 

Tried with Blood Wake. Shortly after starting the mission, the Shutdown Screen shows again, like before, although after 2 seconds it returns to the game, like before, but this time it stays in fullscreen. Almost good.

I tried to untick "Enable Game Shutdown Screen", but then it switches to LB screen for 2 seconds, and back into game.

Link to post
Share on other sites
  • 2 months later...
On 10/25/2020 at 5:53 AM, Koroth said:

I meant the LaunchBox / BigBox startup screens. One thing you could try that I can think of. Do the games run if you try them in CXBX directly? Sometimes an emulator in heavy development has a regression that prevents games that once worked from working.

What workes for me:

- Setting cxbx-ldr.exe as my emulator in LaunchBox using the /load argument in the command line.

- No ahk script except to close cxbx-ldr.exe

- Ticking "Use Exclusive Fullscreen Mode" in CXBX videosettings. (I myself use a Display Resolution 3840 x 2160 32 bit.)

- In LaunchBox "Manage Emulator" settings for CXBX Reloaded in the "Startup Screen" tab: "Hide all windows that are not in Exclusive Fullscreen Mode" ticked with a "Startup Load Delay" of 3 seconds.

 

One thing to note though, I do not have the games you mentioned as not working. (Blood Wake and Crimson Skies).

This worked for me Thanks!

 

Quote

Does anyone know if I can rename default.xbe?  I tried it on crazy taxi 3, but apparently crazy taxi 3 doesn't work anyway.  I'm looking for an easy way to add to launchox.  Thinking of making shortcuts.  Any other suggestions

NVM all of this quote I found that awesome feature of using the names of the folders not rom files.

Edited by Aevans0001
Link to post
Share on other sites
  • 1 month later...
On 9/30/2020 at 6:25 PM, Dark Fact said:

Hello, in case anyone sees this and needs help with CXBX Reloaded, this is what worked for me with the most recent version of the emulator as of right now:

The emulator auto loads the game now as long as you point Launchbox to the default.xbe file

There is also an alternative you can use if you want to compress the game's files. All you do is either rename the default.xbe to default.cue OR you can copy the default.xbe file and paste it in the same directory and rename it ANYTHING.cue  All that matters is that the file extension is CUE and launchbox will send it to the emulator and it will automatically load.

As far as making it go fullscreen and being able to exit, this script works for my system:

Sleep, 3000
Send !{enter}

$Esc::
{
  Send {f6}
  Send !{f4}
  Return
}

Put it in the Running AutoHotKey Script tab and you're good to go!

***Unless things work for you, be sure that the emulator's Video config settings has Use Exclusive Fullscreen Mode UNCHECKED ***
On my system that causes issues and the game screen goes black and the emulator won't close without using Task Manager to End Task.

 

Hope that all makes sense and helps someone!

 

Thx, I was able to get this to work with newest version as of today and get passed the F5 screen.

Edited by Wanderer189
  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...