Jump to content
LaunchBox Community Forums
Johnny T

Got my dynamic marquee LCD - now just wondered if anyone has the marquee images?

Recommended Posts

On 8/12/2019 at 4:22 PM, Johnny T said:

That's great Napalm. Glad you managed to snap it up mate. I've not started building my cab yet so it will primarily be designed around the width of the LCD. It was a bit bigger than I was looking for but, as you say, they aren't that easy to find so didn't want to pass it up.

Happy days! :)

Hi Johnny T got my marquee screen now unfortunately its not displaying correctly and the image is cut off just wondered if you had the same issue and possibly a fix? 20190821_174643.thumb.jpg.54dcfadfe2a9a80b147e2bc6298ae875.jpg

Share this post


Link to post
Share on other sites
16 hours ago, Napalm2016 said:

Hi Johnny T got my marquee screen now unfortunately its not displaying correctly and the image is cut off just wondered if you had the same issue and possibly a fix? 20190821_174643.thumb.jpg.54dcfadfe2a9a80b147e2bc6298ae875.jpg

Hi Napalm

Yep! I had exactly the same issue! I did a bit of searching on here and found a thread about it (

You need to have a mess around with your GameMarqueeView and PlatformMarqueeView xaml files in the views folder.

I copied the code from the thread and managed to get some of the marquees displaying perfectly.

I've not built my cabinet yet so I shelved it at that point with a view to coming back to it and sorting it out properly when the cabinet is built.

However, if you get futher than me and get it sorted then please let me know what mods you made as I've obviously got the same display as you and it'll save me a big headache!

Cheers :)

Share this post


Link to post
Share on other sites
40 minutes ago, Johnny T said:

Hi Napalm

Yep! I had exactly the same issue! I did a bit of searching on here and found a thread about it (

You need to have a mess around with your GameMarqueeView and PlatformMarqueeView xaml files in the views folder.

I copied the code from the thread and managed to get some of the marquees displaying perfectly.

I've not built my cabinet yet so I shelved it at that point with a view to coming back to it and sorting it out properly when the cabinet is built.

However, if you get futher than me and get it sorted then please let me know what mods you made as I've obviously got the same display as you and it'll save me a big headache!

Cheers :)

If I get chance and further than you I will certainly share what Ive found 😉 I have found that thread also and have played around with settings as they have said but for some reason it errors out on me and doesn't work so don't know Im doing wrong would you mind sharing your xaml so I cant start where you left off?

Share this post


Link to post
Share on other sites

Certainly! I'm at work at the moment but I'll do it when I get home (around 6pm UK time - in about 4 hours from making this post).

🙂

Share this post


Link to post
Share on other sites

Arrrrghhhh...!!! I haven't got them!!!

I had problems with Retrostatic crashing my new cabinet PC when I was testing it and I've deleted the theme folder and re-downloaded it forgetting that I'd messed around with the xaml files!

I'll have to re-do it all when I start setting up the cabinet properly.

Apologies mate. From memory though, all I did was adjust the Grid Height and Width settings I think. I managed to get Donkey Kong / Donkey Kong 2 etc working fine although I still had problems with a lot of other marquees. But I just shelved it then thinking I would sort it when I got around to it.

:-(

Share this post


Link to post
Share on other sites
4 hours ago, Johnny T said:

Arrrrghhhh...!!! I haven't got them!!!

I had problems with Retrostatic crashing my new cabinet PC when I was testing it and I've deleted the theme folder and re-downloaded it forgetting that I'd messed around with the xaml files!

I'll have to re-do it all when I start setting up the cabinet properly.

Apologies mate. From memory though, all I did was adjust the Grid Height and Width settings I think. I managed to get Donkey Kong / Donkey Kong 2 etc working fine although I still had problems with a lot of other marquees. But I just shelved it then thinking I would sort it when I got around to it.

:-(

Ok no probs I have progress on it and doesn't pull up an error now but have given up for now as its getting very frustrating but will get there eventually 

Share this post


Link to post
Share on other sites

Okay that's good. Why not start a new thread asking for help on it and link it in here. You'll probably get a load of people chiming in with more info. 🙂

Share this post


Link to post
Share on other sites
1 hour ago, Napalm2016 said:

Ok no probs I have progress on it and doesn't pull up an error now but have given up for now as its getting very frustrating but will get there eventually 

What is the resolution of the monitor? It should likely just need a repositioning of the image in the xaml.

Share this post


Link to post
Share on other sites
9 hours ago, Retro808 said:

What is the resolution of the monitor? It should likely just need a repositioning of the image in the xaml.

Retro you are a genius feel really stupid changed the  grid height to match the resolution of the monitor and works thank you so much 👍

15 hours ago, Johnny T said:

Arrrrghhhh...!!! I haven't got them!!!

I had problems with Retrostatic crashing my new cabinet PC when I was testing it and I've deleted the theme folder and re-downloaded it forgetting that I'd messed around with the xaml files!

I'll have to re-do it all when I start setting up the cabinet properly.

Apologies mate. From memory though, all I did was adjust the Grid Height and Width settings I think. I managed to get Donkey Kong / Donkey Kong 2 etc working fine although I still had problems with a lot of other marquees. But I just shelved it then thinking I would sort it when I got around to it.

😞

Heres the code that worked for me if you wanted it mate:

<UserControl xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
             xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
             xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
             xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
             xmlns:transitions="clr-namespace:Unbroken.LaunchBox.Wpf.Transitions;assembly=Unbroken.LaunchBox.Wpf"
             xmlns:i="http://schemas.microsoft.com/expression/2010/interactivity"
             xmlns:cal="http://www.caliburnproject.org"
             mc:Ignorable="d"
             d:DesignHeight="562" d:DesignWidth="1000" HorizontalAlignment="Stretch" VerticalAlignment="Stretch" Style="{DynamicResource UserControlStyle}">
<!-- GRID DEFINITIONS -->
            
            
    <Grid Height="768" Width="1366">
        <Grid.ColumnDefinitions>                       
            <ColumnDefinition Width="1*" />
    </Grid.ColumnDefinitions>
        <Grid.RowDefinitions>
            <RowDefinition Height="*" />
            <RowDefinition Height="*" />
            <RowDefinition Height="*" />
        </Grid.RowDefinitions>
                              
        <!-- GAME MARQUEE -->
               
               
        <Image Source="{Binding Path=SelectedGame.MarqueeImagePath}" Stretch="fill" HorizontalAlignment="Center" VerticalAlignment="Top" RenderOptions.BitmapScalingMode="HighQuality" />
            <TextBlock x:Name="GameMarquee" Visibility="Visible">
                <TextBlock.Text>
                    <MultiBinding StringFormat="{}pack://siteoforigin:,,,/Arcade - Marquee/_Default.png">
                    <Binding Path="SelectedGame.Platform"/>
                    </MultiBinding>
                </TextBlock.Text>
            </TextBlock>
        <Image x:Name="MainMarquee" Grid.RowSpan="3" Grid.Row="0" Grid.ColumnSpan="8" Grid.Column="0" Source="{Binding Text, ElementName=GameMarquee, FallbackValue='pack://siteoforigin:,,,/Arcade - Marquee/_Default.png'}" Opacity="100" Stretch="fill" Panel.ZIndex="1" RenderOptions.BitmapScalingMode="HighQuality" />
    </Grid>
</UserControl>

Share this post


Link to post
Share on other sites

That's great! I *thought* it was something to do with Grid Height and Width! Thanks Retro!

Thanks for the code Napalm. Glad you got it all sorted.

Cheers 🙂

  • Like 1

Share this post


Link to post
Share on other sites
15 hours ago, Darkseid001 said:

I got one woohoo so stoked!!!

That's excellent news!! Well done :)

Share this post


Link to post
Share on other sites

In each theme’s Launchbox folder the xaml files are located in the Views folder. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...