Jump to content
LaunchBox Community Forums
Jason Carr

LaunchBox for Android 0.6 Beta Released!

Recommended Posts

oh man, I just bought an shield and was looking for something like this. Awesome!

  • Like 1

Share this post


Link to post
Share on other sites

getting an error on the lunchbox side where it cannot delete the old android temp folder because access was denied ( to the game at the top of the list in games folder) this has happened every time iv done a transfer with a different games being access denied.

I have worked around the issue by deleting the folder manually but wondering if there is a permanent fix

PS. awesome job Jason replying to every post in this 25 page thread!

  • Like 1

Share this post


Link to post
Share on other sites
4 minutes ago, Nickkt said:

getting an error on the lunchbox side where it cannot delete the old android temp folder because access was denied ( to the game at the top of the list in games folder) this has happened every time iv done a transfer with a different games being access denied.

I have worked around the issue by deleting the folder manually but wondering if there is a permanent fix

PS. awesome job Jason replying to every post in this 25 page thread!

Ha, well thanks. :)

That's interesting though. Are you using any file sync utilities like Dropbox or Google Drive?

Share this post


Link to post
Share on other sites
5 minutes ago, Jason Carr said:

Ha, well thanks. :)

That's interesting though. Are you using any file sync utilities like Dropbox or Google Drive?

no i have no utilities like that at all, even my windows one drive crap is off

Share this post


Link to post
Share on other sites
18 minutes ago, Nickkt said:

no i have no utilities like that at all, even my windows one drive crap is off

Okay, I'm lost then currently. I'll take a look though to see if I can replicate it.

  • Thanks 1

Share this post


Link to post
Share on other sites
4 hours ago, Nickkt said:

getting an error on the lunchbox side where it cannot delete the old android temp folder because access was denied ( to the game at the top of the list in games folder) this has happened every time iv done a transfer with a different games being access denied.

I have worked around the issue by deleting the folder manually but wondering if there is a permanent fix

PS. awesome job Jason replying to every post in this 25 page thread!

I've been getting the same error with the same workaround.  Other than that the app has been great and extremely easy to setup

  • Like 1

Share this post


Link to post
Share on other sites

After playing around in beta state I have kinda bloated my phone with too many systems/games. 

Was wondering what is the best way to start over, if I delete everything and reinstall the app will I run into issues, I understand I'll have to fiddle a bit to line up the emulators. 

But I'm wondering about screwing the app up etc. 

I'm assuming if I delete everything it will be clean to start over... 

Share this post


Link to post
Share on other sites
4 hours ago, Mu144 said:

After playing around in beta state I have kinda bloated my phone with too many systems/games. 

Was wondering what is the best way to start over, if I delete everything and reinstall the app will I run into issues, I understand I'll have to fiddle a bit to line up the emulators. 

But I'm wondering about screwing the app up etc. 

I'm assuming if I delete everything it will be clean to start over... 

Correct. The easiest way to do it is to just delete the /Android/data/com.unbrokensoftware.launchbox folder. Then it'll be a completely fresh install. :)

Share this post


Link to post
Share on other sites

Hey all, first off thank you so much for helping with the beta testing. The official release has been very smooth and I definitely owe that to you guys, so thank you very much. :)

I wanted to mention that if you have previously left a review on the Play Store, it has all been private feedback, unfortunately, because Google does not allow beta testers to give public feedback. If you'd like to review the app publicly (and I would be very grateful), you first need to click this link:

https://play.google.com/apps/testing/com.unbrokensoftware.launchbox

From there, click the button to opt out, and then you will finally be able to leave a public review here:

https://play.google.com/store/apps/details?id=com.unbrokensoftware.launchbox

I'm sorry for being so forward about this; I typically wouldn't come out and ask for reviews lol, but Google has complicated this whole process so much that I felt that it was probably a good thing to clear up.

Thanks again, everybody. Just put out a desktop beta, and I'm back to Android development for the rest of the afternoon. :)

Edit: Don't worry about uninstalling the beta version of the app and reinstalling the public version, as the site says. There's no need as they are one and the same for the moment.

  • Like 3

Share this post


Link to post
Share on other sites

I'm not sure about this, but the shield tv doesn't work correctly. Many times when the app is launched, it doesn't navigate to the platforms section.

It only allows me to enter the menu, select anything, but not the platforms/games.

This isn't a problem of the controller, as mentioned before, since it happens even if the controller is offline.

Sometimes the app functions properlly, but most of the time it doesn't.

I have the shield tv newest version, not pro. It is in the most current version, as is the LBA version (.21)

Share this post


Link to post
Share on other sites
29 minutes ago, deesko said:

I'm not sure about this, but the shield tv doesn't work correctly. Many times when the app is launched, it doesn't navigate to the platforms section.

It only allows me to enter the menu, select anything, but not the platforms/games.

This isn't a problem of the controller, as mentioned before, since it happens even if the controller is offline.

Sometimes the app functions properlly, but most of the time it doesn't.

I have the shield tv newest version, not pro. It is in the most current version, as is the LBA version (.21)

Well that's odd. I have the "NVIDIA SHIELD TV Gaming Edition" which should also be the latest version of the Shield. The listing on Amazon doesn't say Pro:

https://smile.amazon.com/gp/product/B01N1NT9Y6/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

So not sure if we have the same one or not, but something is going awry, as my testing and development is done with that device. I know we have quite a few other users who are using various Shield TV devices without issues as well.

What are you using for storage? Do you have the exported folder on internal storage or a USB device? What version of Android are you running?

Share this post


Link to post
Share on other sites
3 minutes ago, Jason Carr said:

Well that's odd. I have the "NVIDIA SHIELD TV Gaming Edition" which should also be the latest version of the Shield. The listing on Amazon doesn't say Pro:

https://smile.amazon.com/gp/product/B01N1NT9Y6/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

So not sure if we have the same one or not, but something is going awry, as my testing and development is done with that device. I know we have quite a few other users who are using various Shield TV devices without issues as well.

What are you using for storage? Do you have the exported folder on internal storage or a USB device? What version of Android are you running?

The "Pro" is the original one with a 500GB HDD built in.

Share this post


Link to post
Share on other sites

Hello Jason.

I have the latest version provided by nVidia. And it is the same hardware as the one you have.

I use an external USB pen.

The thing is... it works sometimes. But sometimes I have to close the application (in the menu) and restart the app about 10 times before it works as normal.

I also had the problem with white and black screens as others pointed out before, but that is all sorted out by now, only this problem remains (since the first beta available).

Share this post


Link to post
Share on other sites
6 minutes ago, deesko said:

Hello Jason.

I have the latest version provided by nVidia. And it is the same hardware as the one you have.

I use an external USB pen.

The thing is... it works sometimes. But sometimes I have to close the application (in the menu) and restart the app about 10 times before it works as normal.

I also had the problem with white and black screens as others pointed out before, but that is all sorted out by now, only this problem remains (since the first beta available).

My guess then at this point is that it's somehow related to the USB drive. Can you try exporting a small collection to the internal storage on the device? I use an external USB hard drive (Western Digital Passport) on mine without issues, but if there's some kind of issue with the USB drive, then that would rule it out. Something is clearly different between our setups though, because that is definitely not normal.

Share this post


Link to post
Share on other sites

Hello Jason.

I'm sorry, but I guess you misunderstood my problem (or probably I didn't explain it the best I could).

The problem I have now is that I can't navigate the platforms list, not that they're not there.

What I mean is that nVidia Shield TV isn't a phone with touch screen support, the controllers have to work on their own.

When the app starts, there's no platform pre-selected, and the controller buttons/stick doesn't select neither go down/up on the platforms list, only the left button allows to access the menu.

Even if I select "Platforms" on the menu, it still doesn't select any platform, and the buttons/stick still can't go up/down to select any.

Share this post


Link to post
Share on other sites
6 minutes ago, deesko said:

Hello Jason.

I'm sorry, but I guess you misunderstood my problem (or probably I didn't explain it the best I could).

The problem I have now is that I can't navigate the platforms list, not that they're not there.

What I mean is that nVidia Shield TV isn't a phone with touch screen support, the controllers have to work on their own.

When the app starts, there's no platform pre-selected, and the controller buttons/stick doesn't select neither go down/up on the platforms list, only the left button allows to access the menu.

Even if I select "Platforms" on the menu, it still doesn't select any platform, and the buttons/stick still can't go up/down to select any.

I think I know what you mean now. I remember seeing that once a while back. I'm not sure why you're seeing it more than I am in my testing, but I do have some ideas and I'll look into it. Thanks for helping me understand. :)

Share this post


Link to post
Share on other sites
13 minutes ago, Jason Carr said:

I think I know what you mean now. I remember seeing that once a while back. I'm not sure why you're seeing it more than I am in my testing, but I do have some ideas and I'll look into it. Thanks for helping me understand. :)

No, thank you! I know you have this covered. I just don't understand how is it that this happens sometimes almost a dozen times in a row, and then out of a sudden, it works ok for 2, 3 times.

Share this post


Link to post
Share on other sites
28 minutes ago, deesko said:

No, thank you! I know you have this covered. I just don't understand how is it that this happens sometimes almost a dozen times in a row, and then out of a sudden, it works ok for 2, 3 times.

Yeah, no kidding. I think I have it fixed, but the problem is, I've only seen it once in my 45 minutes of playing with it. So now I don't know if it's fixed or not lol.

Share this post


Link to post
Share on other sites
29 minutes ago, deesko said:

No, thank you! I know you have this covered. I just don't understand how is it that this happens sometimes almost a dozen times in a row, and then out of a sudden, it works ok for 2, 3 times.

When it wasn't working a bunch of times in a row, were you closing out of the app every time via the app switcher? Do you know if it was showing the loading splash screen on the times that it wasn't working? Or was it just when coming back to the app instantly?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...