Jump to content
LaunchBox Community Forums

COLORFUL bigbox theme


viking

Recommended Posts

On 7/9/2020 at 6:20 PM, Chro said:

Do anybody know how to get the lower right "Max Player" quarter to work.

On Launchbox Database each game i own has the number of player that can participate in a game but they wont be shown in my Launchbox and Bigbox aswell.

If i look my Infos up and only says Single or Multiplayer title. 

I even tried to write 1-2 or 1-4 into the meta data but it didnt helped.

I am using the latest version of the theme and launchbox/bigbox, the number of players and age is not displayed.

Link to comment
Share on other sites

20 hours ago, Aniv Cuderoes said:

I am using the latest version of the theme and launchbox/bigbox, the number of players and age is not displayed.

Are you using the beta version by @faeran? If so, he no longer uses the same data as me for these fields. Try to update your games metadata.

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...

New to BigBox so just figuring things out . I'm having an issue where the theme only seems to be partially applied - a lot of the visuals seem correct at start but things are off, such as most of the platforms are missing videos, changing the horizontal view to any number looks like a wall view with no info instead of what the screenshots  show. Hitting the repair button doesn't seem to change things, is there some other type of resource I'm missing? I'm wondering if I'm missing some sort of assets but can't figure out which. Any ideas?

Current Settings

settings.thumb.png.2461d1ebfca18d81f8139cdd8b22a692.png

 

Platform not working correctly:

Playstation.thumb.png.40cfef2ae5d7eb3facf5e8b8e67ea687.png

 

Game list - not working correctly

  845975705_Gamelist.thumb.png.3a7cb0a7828cfeb88e5f83ed54b0d1fc.png

 

Working platform:

NES.thumb.png.f495c4433fcf12614f89727ed13e10e2.png

 

 

Link to comment
Share on other sites

Hi @Carpetshark,

There are several things here:

  1. The theme does not come in all in one. It would be too heavy. You have to download the platform videos separately. Look at the videos download page, everything is explained in main text.
    in LaunchBox > Tools > Download theme videos tools > Select "Colorful 4K" or "Colorful HD"
  2. At the top of each Colorful download page, I put a list of each piece of the puzzle with the direct links. It's up to you to make your choice!
  3. We haven't released the "games wallview" for Colorful yet. It's currently work in progress with Faeran for theme v2! Please be patient.

 

Link to comment
Share on other sites

12 hours ago, viking said:

Hi @Carpetshark,

There are several things here:

  1. The theme does not come in all in one. It would be too heavy. You have to download the platform videos separately. Look at the videos download page, everything is explained in main text.
    in LaunchBox > Tools > Download theme videos tools > Select "Colorful 4K" or "Colorful HD"
  2. At the top of each Colorful download page, I put a list of each piece of the puzzle with the direct links. It's up to you to make your choice!
  3. We haven't released the "games wallview" for Colorful yet. It's currently work in progress with Faeran for theme v2! Please be patient.

 

Exactly the help I needed, thank you!

Link to comment
Share on other sites

  • 4 weeks later...

This is really a fantastic theme and I would love to use it as my default, but I'm not managing to get the plugin that drives my LED marquee to work with it, which is stopping me at the moment.

My plugin (LedMarqueeNoSerial) derives from UserControl and implements IBigBoxThemeElementPlugin. Normally, I just add a reference to the namespace in the XAML, and add an instance inside the Canvas, e.g.

<UserControl xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
             xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
             xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
             xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
             xmlns:transitions="clr-namespace:Unbroken.LaunchBox.Windows.Transitions;assembly=Unbroken.LaunchBox.Windows"
             xmlns:coverFlow="clr-namespace:Unbroken.LaunchBox.Windows.Controls.CoverFlow;assembly=Unbroken.LaunchBox.Windows"
             xmlns:cal="http://www.caliburnproject.org"
             xmlns:i="http://schemas.microsoft.com/expression/2010/interactivity"
             xmlns:ledMarqueeNoSerial="clr-namespace:LedMarqueeNoSerial;assembly=LedMarqueeNoSerial"
             ...

and then at the end of the XAML file:

<UserControl>
  <Canvas>
    [...]
  	<Grid>
      [...]
    </Grid>
    
    <ledMarqueeNoSerial:BigBoxPlugin />
  </Canvas>
</UserControl>

but when using the Colorful theme that doesn't seem to work and the plugin does not seem to be loaded.

 

Any idea why this may be happening?

Link to comment
Share on other sites

I think this theme has amazing aesthetics and I really like a lot of things about it, but I wanted to provide a little feedback on the usability. I've observed one problem when using this theme with my kids and wife, and that is the way to "flip through" different things is not immediately obvious.

Like from platform to platform. The initial impression when looking at an item in one of these high level "carousels" (like a platform) is that your only option is to drill into that platform. Yes, there are tiny little arrows in the bottom right, but that doesn't seem to be enough. A lot of big-screen UIs address this by "peeking" the other items -- you can see half of an image to the right or left of the next and previous items, for example. Or maybe the next/previous are faded out a bit and only the one you're on is 100% alpha.

It not only provides a strong visual indicator as to whether you should go up/down or left/right, but it also helps orient users. People build mental maps in their mind, and being able to see more than one thing at a time helps with orientation in a UI. Look at the various streaming boxes/apps -- Apple TV, Roku, Fire TV, Android TV...they all do this.

I think a stronger visual indicator of what's next/previous for these high-level carousels would be a really positive user experience enhancement. As of right now, it's a big reason I haven't made this my main theme.

Other than that...this theme is really fantastic and professional looking!

  • Thanks 1
Link to comment
Share on other sites

On 12/12/2021 at 9:48 PM, SiriusVI said:

Hey, quick question: The "Windows" Platform Video has a blue background, but the Colorful Theme background for "Windows" is green. How can I fix this? I like the blue color from the video.

Open your Launchbox Folder. From there go to \Themes\Colorful - Dark\Views\Styles. Open the File "COLORFUL_Styles.xaml" with Editor, e.g. Notepad. Look up under Platforms if there is this entry:

<SolidColorBrush x:Key="Windows" Color="#38b1de"/>

If it isnt, then add it at the bottom of the list. Keep in mind that you have to change 

x:Key="Windows"

according to your Windows Platform Name. E.g. if your Windows Platform in Launchbox is called "Windows Games" you have to name it

x:Key="Windows Games"

Save the file and restart BigBox.

Same goes for all Platforms with missing entrys/color codes.

 

Now about Color Codes in the COLORFUL_Styles.xaml :

I just recently got back to Launchbox and updated Launchbox to its recent Version and the Colorful theme to v1.1 where the former Plugin "Ao.Bigbox.Themer.v3_9_7a.dll" no longer works. Instead the above mentioned "COLORFUL_Styles.xaml" is used. 

So far so good. I'm pretty sure that all of my Color Codes worked like a charm when i used the older Version with "Ao.Bigbox.Themer.v3_9_7a.dll" and there were no differences between Skin Color and Video Color (that odd line of slight color difference everyone is talking about and hates ;)).

I had to manually edit nearly every color code for every platform to get back to a nice seamless look. Yet some of them were not fixable as i couldnt figure out the right hex code (e.g. Atari 5200).

Is there a difference in implementing Color Codes into the skin between the former used .dll and the now "baked-into-launchbox-and-just-read-values-of-the-xaml"-solution? That could be the reason for all those wrong color codes and differences. Maybe @faeran knows more about this.

 

For those of you who want to manually correct Color Codes can use the following route:

1. Open Platform Video with VLC Media Player (e.g. Nintendo Entertainment System.mp4)

2. In VLC Player choose Video / Make Snapshot

3. VLC Player creates a Snapshot .png in C:\Users\yourusername\Pictures

4. Open this Snapshot with the Photo Tool of your preference. e.g. Photoshop. But Paint 3D works too.

5.  Choose pipette tool and get the color Code from the left border of the snapshot

6. Copy this Color Code to the respective Platform in "COLORFUL_Styles.xaml"

7. Save and enjoy

Notes:

The way @viking described earlier in this thread with printing a screenshot when BigBox is open and doing the routine from Point 4 of my route gives me always the wrong Color Codes..

With the VLC Method above i got 98% Percent right. Only Atari 5200 and one other Platform look quite different. I Don't know why. Maybe its because of the change of implementation as mentioned earlier.

 

Hope this is helpful to some of you. 

 

 

Edited by modjoo
  • Thanks 1
Link to comment
Share on other sites

Hi guys I'm sorry if this is a stupid question, I really love this theme I actually bought big box just for it. Everything is working great except when I click on a game , I see the box art, description and a screenshot still picture of the game instead of a video of the game. Am I missing something? please help. Thank you.

Link to comment
Share on other sites

6 hours ago, adiru said:

Hi guys I'm sorry if this is a stupid question, I really love this theme I actually bought big box just for it. Everything is working great except when I click on a game , I see the box art, description and a screenshot still picture of the game instead of a video of the game. Am I missing something? please help. Thank you.

A pic of what you see would help better confirm what you need to do.

A couple things to note: 1. Themes do not come with game play videos so if no videos are showing you need to make sure you downloaded them. 2. Themes typically have different views so you would also need to make sure you are on a view that supports game play videos. You can hot swap views by binding a key/button in the mapping section for "Change View".

  • Thanks 1
Link to comment
Share on other sites

Thanks for replying!

The view is like this and instead of the video it's just a screenshot.. I downloaded the meta data but I'm not sure the videos were there too.. would you mind explaining how to download the videos if that's what I'm missing ? Thank you

 

20211220_182630.jpg

Link to comment
Share on other sites

9 minutes ago, adiru said:

Thanks for replying!

The view is like this and instead of the video it's just a screenshot.. I downloaded the meta data but I'm not sure the videos were there too.. would you mind explaining how to download the videos if that's what I'm missing ? Thank you

 

20211220_182630.jpg

You need a paid premium subscription at emumovies in order to download gameplay videos in Launchbox.

Donation Options - EmuMovies

 

Link to comment
Share on other sites

  • 5 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...