Jump to content
LaunchBox Community Forums
tvguy

NeoGeo and SNES

Recommended Posts

I have Turbografx, Nes, and Genesis working on my LG V40 with Launchbox using Retroarch. But I can't seem to get NeoGeo or SNES working. They extract games and load to a black screen. The neogeo.zip bios file is in the game directory for NeoGeo. Also, NeoGeo doesn't give me the option of using Neo.emu as an emulator which is kind of strange. SNES does the same as NeoGeo, files extract to a black screen and the game never loads. Which cores are you guys using for these two game systems? I've tried many different cores with the same result. Thanks for any help you can give me. **Edit, having the same problem with GBA games - they extract to a black screen**

Edited by tvguy

Share this post


Link to post
Share on other sites

I don't have NeoGeo setup but for SNES I use SNES9x_libertro_android.so core from Retro Arch and everything seems to be working fine. Probably obvious (But wasn't to me at first.) make sure each system has it's own folder or it'll try to use the wrong core. Other then that I'm not to sure.

Share this post


Link to post
Share on other sites
2 hours ago, tvguy said:

I have Turbografx, Nes, and Genesis working on my LG V40 with Launchbox using Retroarch. But I can't seem to get NeoGeo or SNES working. They extract games and load to a black screen. The neogeo.zip bios file is in the game directory for NeoGeo. Also, NeoGeo doesn't give me the option of using Neo.emu as an emulator which is kind of strange. SNES does the same as NeoGeo, files extract to a black screen and the game never loads. Which cores are you guys using for these two game systems? I've tried many different cores with the same result. Thanks for any help you can give me. **Edit, having the same problem with GBA games - they extract to a black screen**

Snes definitely works, i use the bsnes balanced core personally, NeoGeo could be several issues, just cause you have the neogeo.zip bios doesnt mean that you are not still missing files, thats how neogeo and Arcade games in general tend to work, if its not from a Non-Merged set you may be missing required files. Also what is your naming scheme for those systems? You use NeoGeo and SNES in your post, is that how your platforms are named? If so thats also likely the problem, you would need the default system names that Launchbox offers you when importing systems, Launchbox needs the correct name in order to know which emulator/cores to offer you to run the games.

Share this post


Link to post
Share on other sites
6 hours ago, Drakkorcia said:

Snes9x core in Retroarch runs SNES flawlessly for me.

Then why the heck am I getting a black screen on SNES, NeoGeo, and GBA when other games are working perfectly. I have the proper cores, everything exports to Android properly. SMH.

Share this post


Link to post
Share on other sites

Maybe a shader is being loaded that is incompatibe with the video driver being used with those cores. That is a common cause of black screens.

Share this post


Link to post
Share on other sites
3 hours ago, tvguy said:

Then why the heck am I getting a black screen on SNES, NeoGeo, and GBA when other games are working perfectly. I have the proper cores, everything exports to Android properly. SMH.

I have only been using Retroarch on Android for a couple weeks. Maybe a newer build will give you better results. Sometimes things that should work properly just don't and that's one of the joys of computing.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...