Jump to content
LaunchBox Community Forums
danpow

10.0 / 10.1. memory leak causing hang

Recommended Posts

upgraded to 10.0 yesterday (shortly followed by 10.1) and I get a massive memory leak after about half an hour running BigBox, filling up my physical ram, causing system unresponsiveness. i have to kill BigBox to get back to normal. All was well even with beta versions up to this release...

1. Is this a known bug?

2. is there a clear/simple method to downgrade to an earlier version, maintaining all settings etc?

 

 

Share this post


Link to post
Share on other sites

@danpow I did a ton of testing recently and discovered that unfortunately Windows Media Player is causing some very unfortunate issues, including memory leaks and crashes as you describe. Unfortunately though, this was happening with all previous releases as well. Microsoft apparently updated something in Windows 10 recently that started causing this nonsense.

I've tried getting the Big Box WMP code down to the bare minimum, and the issue still happens, so I don't think there's a way for me to fix it. My recommendation at this point is to use VLC and stay far away from WMP.

Share this post


Link to post
Share on other sites

thanks @Jason Carr for the response - I will check which video system i'm running - hopefully it'll be the issue you're already aware of.  i'm running W7 as my OS though; the problem may not be limited to W10 as you suspect!

Edit - i'm already running VLC as the video backend 😞 is there anywhere else in Launchbox that VLC/WMP can be switched out which i may have missed?

Edited by danpow
update

Share this post


Link to post
Share on other sites

Hmm, then apparently WMP is not the issue. There's only one place to switch it out, in the Big Box settings. What Big Box theme are you running?

Share this post


Link to post
Share on other sites

Hehe I'm using a combination of skins - Refaktor as the main menu, mostly retrotastic for platforms, with unified on a couple of platforms. I've been with this skin combo throughout the 10.x beta program without issues, but am happy to test with default if you think the the themeing may be responsible.

As i was already on VLC, i've switched back to WMP to see if there's any difference - i'll keep an eye on the memory usage...

Share this post


Link to post
Share on other sites

Switching to WMP probably isn't a good idea; it's likely to only introduce more issues at this point. That said, Refaktor especially is known for the possibility of memory leaks, so I do think that it is likely theme related. It's also possible that you may need to upgrade those themes. I know eatkinola is at least working on updates to his themes, and the 10.0 update did also break some things in some of his themes, so that is probably at least part of the issue.

It probably would be worth testing with the default theme to confirm if that fixes the issue, though. :)

Share this post


Link to post
Share on other sites

nice one @Jason Carr , top quality info!

BigBox has just gone down as I write - a lot quicker than usual, no doubt thanks to WMP! I'll switch to VLC and default theme, and see how we go.

Can you advise on any 10.0 fully compatible themes? I don't see anywhere in the theme manager relating to compatibility (other than the updates section, but that isn't quite the same...). I've become spoiled, and used to using BigBox daily with the fantastic community themes!

ps thanks so much for the continuing work you put into LB - i'm a <5.x user, and love how the app has stayed relevant and grown whilst keeping the community engaged and heard. with the feature polls etc. Closed source at its best :-) 

  • Like 1

Share this post


Link to post
Share on other sites

Thank you @danpow. :)

In theory, all the themes available in the themes manager have been tested and should not cause memory leaks. If you discover one, though, please do let me know. Refaktor has been in the process of getting approved for the themes manager, but it has not been approved yet because testing has resulted in issues like this, and eatkinola is working on it.

Share this post


Link to post
Share on other sites

understood.

Is the reason Refaktor is available to me in themes manager because i'm accepting beta updates of the software then?

Share this post


Link to post
Share on other sites

...if Refaktor is available to you, then it sounds like I have a bug. I'll look into that...

Share this post


Link to post
Share on other sites

oh dear. it's just gone down on me again, with VLC and Default Theme. I'll do some checking of the system and pull some logs together.

Cheers Jason

Share this post


Link to post
Share on other sites

Can you confirm if you really have Refaktor available for you in the themes manager? Could you maybe have downloaded it from the forums instead? I just confirmed that it isn't there in my testing for the 10.1 release.

Share this post


Link to post
Share on other sites

i've studied the theme manager are of bigbox, I have Refaktor in the 'installed' list, and not in the 'available' list, so yes it is highly likely i installed it from the forum and forgot! sorry Jason my bad :-s

  • Like 1

Share this post


Link to post
Share on other sites

just to put this thread to bed, I've had bigbox running now for around 24hrs with VLC backend and default theme. No memory leaks, no problems.

as of this date, 10.x and  the 'Refaktor' theme are not stable together!

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...