Jump to content
LaunchBox Community Forums
Jason Carr

10.2-beta-1 Released

Recommended Posts

1 hour ago, Jason Carr said:

I'm finding DS4Windows to be a bit finicky and couldn't get it to work (might be conflicting with my Xbox One controllers).

I have the same issue getting DS4Windows to work with AHK, I think it’s a DS4Windows issue.

Share this post


Link to post
Share on other sites

I'm trying to figure out how to use the Guide Button for the Pause Screens. I pretty much haven't used Pause Screens or even tried them out until the Guide Button feature was set. Any idea how I can easily set things that way @Jason Carr?

Edited by RULLUR

Share this post


Link to post
Share on other sites
1 hour ago, RULLUR said:

I'm trying to figure out how to use the Guide Button for the Pause Screens. I pretty much haven't used Pause Screens or even tried them out until the Guide Button feature was set. Any idea how I can easily set things that way @Jason Carr?

Just go to options/Game controllers/mapping and press add next to the item you want, then a button on your controller, couldnt be easier.

image.thumb.png.0d51e5107b52fdf71e37862d86215059.png

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, neil9000 said:

Just go to options/Game controllers/mapping and press add next to the item you want, then a button on your controller, couldnt be easier.

image.thumb.png.0d51e5107b52fdf71e37862d86215059.png

I can't seem to get the new controller mapping feature to work with the 8bitdo SF30 Pro controller. In both LaunchBox and BigBox there's no response in these mapping menus, although the controller can navigate and select games just fine as it did before this feature was implemented. Anyone else having issues with this feature?

Share this post


Link to post
Share on other sites
22 minutes ago, bundangdon said:

I can't seem to get the new controller mapping feature to work with the 8bitdo SF30 Pro controller. In both LaunchBox and BigBox there's no response in these mapping menus, although the controller can navigate and select games just fine as it did before this feature was implemented. Anyone else having issues with this feature?

I have the same controller, let me connect it and have a look.

 

  • Thanks 1

Share this post


Link to post
Share on other sites
2 minutes ago, neil9000 said:

I have the same controller, let me connect it and have a look.

 

Appreciate the help. I also tried it with the USB connected and still no dice

Share this post


Link to post
Share on other sites
26 minutes ago, bundangdon said:

I can't seem to get the new controller mapping feature to work with the 8bitdo SF30 Pro controller. In both LaunchBox and BigBox there's no response in these mapping menus, although the controller can navigate and select games just fine as it did before this feature was implemented. Anyone else having issues with this feature?

Working fine here, i just set the pause screen to the guide button and it works great in Retroarch. If you had to actually enable the controller first back out of the options and then go back in and try. I had controllers off, and after turning it on and selecting it i couldnt change any buttons at all. Backing out then going back into options worked fine.

Share this post


Link to post
Share on other sites
18 minutes ago, neil9000 said:

Working fine here, i just set the pause screen to the guide button and it works great in Retroarch. If you had to actually enable the controller first back out of the options and then go back in and try. I had controllers off, and after turning it on and selecting it i couldnt change any buttons at all. Backing out then going back into options worked fine.

Nope, still not working. I even tried to configure the controller in PC mode as well as Switch mode. Both work fine with navigation and selecting commands but nothing seems to register when I try to configure any mappings. Here is what I have displayed in the controller configuration option
Untitled-1.thumb.jpg.95725a51188b92ff6d42abfac4ce637c.jpg

Share this post


Link to post
Share on other sites
4 minutes ago, bundangdon said:

Nope, still not working. I even tried to configure the controller in PC mode as well as Switch mode. Both work fine with navigation and selecting commands but nothing seems to register when I try to configure any mappings. Here is what I have displayed in the controller configuration option
Untitled-1.thumb.jpg.95725a51188b92ff6d42abfac4ce637c.jpg

Mine shows as a xinput/bluetooth device. Of course i paired it in xinput mode.

image.thumb.png.64db7af03486143687e90bab7f05a378.png

Share this post


Link to post
Share on other sites

Okay, that worked, but only sort of. When I set up the controller in xinput mode like you did, the menu registered my configurations properly. However, when I pressed the corresponding buttons for "Show the Pause Screen" nothing happened even with different button configuration-combinations. And basically, the SF30 Pro in Switch mode doesn't work at all, besides the basic navigation controls. I'm guessing that Jason may need to test this with an actual 8bitdo controller to get the issue resolved

Share this post


Link to post
Share on other sites
12 hours ago, OhBoy said:

I have the same issue getting DS4Windows to work with AHK, I think it’s a DS4Windows issue.

I managed to get it working, and it does seem to be working fine with the guide button. I had to reboot to get it working again though. I'm not sure what made it stop working, but I'm guessing it was connecting my Xbox One receiver/controller.

2 hours ago, bundangdon said:

Okay, that worked, but only sort of. When I set up the controller in xinput mode like you did, the menu registered my configurations properly. However, when I pressed the corresponding buttons for "Show the Pause Screen" nothing happened even with different button configuration-combinations. And basically, the SF30 Pro in Switch mode doesn't work at all, besides the basic navigation controls. I'm guessing that Jason may need to test this with an actual 8bitdo controller to get the issue resolved

Why would you use the controller in Switch mode on PC? For setting the button combination, go slowly like this:

  1. Press and hold the first button.
  2. Press and release the second button.
  3. Release the first button.

If you do that out of order, it doesn't always register. Does that fix it when the controller is in XInput mode? What are the reasons to use the other modes?

  • Like 2

Share this post


Link to post
Share on other sites

Not sure what is up exactly, but seems Mapping isn't doing anything for me. I use those Wireless AfterGlow PS3/PC Controllers that act as an XBO Controller as far as button commands go that even the Shoulder & Triggers look so much like the mixed a PS3 & XBO Controller together. I have things set as "XInput Xbox 360/Xbox One" instead of "Controller (Afterglow Wireless Controller for PS3)" too. I can move around LaunchBox and BigBox just fine, but can't get it to map out anything new though

Edited by RULLUR

Share this post


Link to post
Share on other sites

I have an idea as to what is going on with the mapping stuff. It should work perfectly fine with XInput controllers (360, Xbone, PS4), but some DirectInput controllers treat the trigger axis differently, and I think that is causing it to not map properly. I have a controller coming in the mail tomorrow that I can test with. :)

  • Like 2

Share this post


Link to post
Share on other sites

Hey Jason, thanks for the big controller overhaul. Just gonna toss a thought out there that I've mentioned before since you've been working on the controllers. I was hoping for some way to avoid when you have multiple people playing, and between the multiple players the button combo is pressed to exit or pause. Either like a hold time or something along those lines would be extremely helpful. But regardless, thanks for the big time additions!

Also to add, my DS4 isn't working properly with the new input mapper. I use DS4Windows as well. I can navigate to the controller screen in big box and select a button to change, but it just doesn't register any input from my DS4 when it says "Awaiting Input".

 

Edited by TheNewClassics

Share this post


Link to post
Share on other sites
9 hours ago, Jason Carr said:

I managed to get it working, and it does seem to be working fine with the guide button. I had to reboot to get it working again though. I'm not sure what made it stop working, but I'm guessing it was connecting my Xbox One receiver/controller.

Why would you use the controller in Switch mode on PC? For setting the button combination, go slowly like this:

  1. Press and hold the first button.
  2. Press and release the second button.
  3. Release the first button.

If you do that out of order, it doesn't always register. Does that fix it when the controller is in XInput mode? What are the reasons to use the other modes?

While using this controller in Switch mode, it does all of the same things that it would do in PC/Xinput mode, and also allows you to use the star and home buttons within Retroarch for other very useful functions. Also, the analog nubs can be used as a mouse which is also quite useful. In Xinput mode, unfortunately I can't use these 2 buttons and they're rendered useless. 

I gave it another go today and while I can register the key combinations and assign buttons to the corresponding actions with Xinput mode just fine, it doesn't seem to be working for me within the games. I've tried Retroarch, MAME, and a couple of other emulators. On a side note, I don't have any game controller software running in the background 

  • Like 1

Share this post


Link to post
Share on other sites

Just asking but would this be a good time to give the trackball option for arcade cabs

Share this post


Link to post
Share on other sites
9 hours ago, Jason Carr said:

I have an idea as to what is going on with the mapping stuff. It should work perfectly fine with XInput controllers (360, Xbone, PS4), but some DirectInput controllers treat the trigger axis differently, and I think that is causing it to not map properly. I have a controller coming in the mail tomorrow that I can test with. :)

One like mine? What kind is it? Almost sounds like this feature may have to be tested with various third-party controllers just to get it right for all.

Share this post


Link to post
Share on other sites

Beta 3 is out now to fix issues with some DirectInput controllers. Ended up picking up a few of them to test with; let me know if anyone sees any further issues with any particular controllers.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
On 9/20/2019 at 3:43 PM, TheNewClassics said:

Hey Jason, thanks for the big controller overhaul. Just gonna toss a thought out there that I've mentioned before since you've been working on the controllers. I was hoping for some way to avoid when you have multiple people playing, and between the multiple players the button combo is pressed to exit or pause. Either like a hold time or something along those lines would be extremely helpful. But regardless, thanks for the big time additions!

Also to add, my DS4 isn't working properly with the new input mapper. I use DS4Windows as well. I can navigate to the controller screen in big box and select a button to change, but it just doesn't register any input from my DS4 when it says "Awaiting Input".

Eventually I'm planning on adding controller-specific configurations (different bindings for each controller). When we tackle that, I'll make sure to cover this. As for right now, though, doing that properly would require tracking controllers separately, and currently they're all combined, so I can't really make that happen until we do that restructuring.

On 9/20/2019 at 10:11 PM, drphobus said:

Just asking but would this be a good time to give the trackball option for arcade cabs

Trackball support is completely separate code than game controllers, so unfortunately no, it's not something I can slip in right now. I actually have a version of the code in progress for trackball support for Big Box, but it proved to be more extensive than I had originally thought, and sadly it hasn't seemed to garner a whole lot of interest so I haven't been back to it as of yet.

Share this post


Link to post
Share on other sites

So I caught something weird now since Installing Beta 3. I open Big Box and it tells me all sorts of programs have errors popping up and then Big Box launches just fine. After I left I found a pop-up saying I needed to report a bug. Now when I have LaunchBox open it seems when I move the arrow keys that the mouse cursor moves in that direction too. Very strange, and wonder what it could be to fix it

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...