Jump to content
LaunchBox Community Forums

Recommended Posts

Community Theme Creator for BigBox

View File

The Community Theme Creator for BigBox is still in development and should be treated as an Alpha build, however it has enough features in place that would allow you to start building your own Themes.

(Please see Pyramids by @Rincewind)

 

As I have no documentation at this point, please visit my YouTube Channel as I demonstrate some of the various features.

http://www.youtube.com/channel/UCALHDoR8oQifl6sbIrdrW6w

 

Installation

1. Download .zip file

2. Unblock (right click on the .zip file, select properties and click on Unblock)

3. Unzip where ever you like

4. Go to the unzipped folder and go to folder ".Install these fonts first to allow the demo theme to load correctly in the editor"

5. Install the 2 fonts (these are only needed for the included Theme)

6. Click on the "COMMUNITY Theme Creator for BigBox.exe"

7. Fill out the setup properties (userid / name and location of the BigBox.exe )

 

8. Enjoy!

 

FYI.  If you wish to design a Theme in either 4:3 or 16:9 or any other aspect ratio then simply change your windows desktop settings to the desired resolution and open the editor.

 


 

  • Like 3
  • Thanks 1
Link to post
Share on other sites
  • 4 months later...
  • Replies 331
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Community Theme Creator for BigBox View File The Community Theme Creator for BigBox is still in development and should be treated as an Alpha build, however it ha

You can also click @y2guru s name and use the follow function

yes they will.  parenting will include new UI Elements:- Grid, Border, DockPanel and StackPanel, which have special properties

Posted Images

9 minutes ago, HannesRoets said:

No worries, you did a find job already, no hurries ;)
Thanks for all your effort into this great tool!

Thanks very much, formatting text is on the list and I will be discussing that particular enhancement tomorrow during the livestream.

Link to post
Share on other sites
  • 3 weeks later...

Hi!

How can I create a specific view for a playlist (for example, Atari Classics) with the Theme Creator? I have created a playlist and added it to the list of platforms, but it won't show up in the Theme Creator.

Best!

Edited by CMOSS
  • Like 1
Link to post
Share on other sites
  • 2 weeks later...

Hi,

Is there a way to undo a change? If I move an element, I'm not able to CTRL-Z to move it back.

Also I've ran into a few issues; The text scroller isn't scrolling, and I have a few installed fonts that aren't showing up.

Thanks.

Edited by Zaazu
Link to post
Share on other sites

I have not tackled Playlists yet.

No undo... at least not yet... kinda tricky and easier said than done.

Text Scroller, set the speed to 1 and go from there

Fonts... i'm aware of that issue especially if that font has many variations

Link to post
Share on other sites
  • 4 weeks later...

Hi @y2guru

I have an issue when specifying the resources in the text area of the "Manage External Plugins". I am doing the following:

image.thumb.png.13c722bdeab0160ae011d267db85ae25.pngAfter clicking the OK button, if I open again the window, what I get is the following: 

image.thumb.png.7173a8cfd557238eee127ac6717a3ae2.pngEverything is removed after the first occurrence of "/>". The generated view makes then BigBox crash (I can make it work as I want it to by adding the original 2 lines on the generated view directly, within the <UserControl.Resources> tag).

Is this a bug or am I doing something wrong?

Thanks in advance.

PS. I am using version 1.0.6.1

 

Link to post
Share on other sites
10 minutes ago, CMOSS said:

Hi @y2guru

I have an issue when specifying the resources in the text area of the "Manage External Plugins". I am doing the following:

image.thumb.png.13c722bdeab0160ae011d267db85ae25.pngAfter clicking the OK button, if I open again the window, what I get is the following: 

image.thumb.png.7173a8cfd557238eee127ac6717a3ae2.pngEverything is removed after the first occurrence of "/>". The generated view makes then BigBox crash (I can make it work as I want it to by adding the original 2 lines on the generated view directly, within the <UserControl.Resources> tag).

Is this a bug or am I doing something wrong?

Thanks in advance.

PS. I am using version 1.0.6.1

 

I’ll try exactly as you’ve indicated later (once I get home) and determine the fault, it looks like a bug to me

Link to post
Share on other sites
6 hours ago, y2guru said:

I’ll try exactly as you’ve indicated later (once I get home) and determine the fault, it looks like a bug to me

can you share the text you were trying to key in, the declaration is missing characters as the text length is too long.  thanks

Link to post
Share on other sites
7 hours ago, y2guru said:

can you share the text you were trying to key in, the declaration is missing characters as the text length is too long.  thanks

<aox:GameSelectionColorConverter x:Key="GameSelectionColorConverter"/>
<SolidColorBrush x:Key="DefaultGameColor" Color="#5abc3c"/>

This one. Just one of the above lines will also cause the issue.

Link to post
Share on other sites
3 hours ago, CMOSS said:

<aox:GameSelectionColorConverter x:Key="GameSelectionColorConverter"/>
<SolidColorBrush x:Key="DefaultGameColor" Color="#5abc3c"/>

This one. Just one of the above lines will also cause the issue.

can you provide the text in the declaration text box also, that's the one that's too long for me to see the complete line

xmlns:aov etc....

Link to post
Share on other sites
24 minutes ago, y2guru said:

can you provide the text in the declaration text box also, that's the one that's too long for me to see the complete line

xmlns:aov etc....

xmlns:aov="clr-namespace:Ao.Bigbox.ViewModels;assembly=Ao.Bigbox.Themer.v3_9_7a" xmlns:aox="clr-namespace:Ao.Bigbox.Converters;assembly=Ao.Bigbox.Themer.v3_9_7a" xmlns:aoc="clr-namespace:Ao.Bigbox.Controls;assembly=Ao.Bigbox.Themer.v3_9_7a"

It's actually 3 declarations in just one line, separated by a blank. This works ok in the generated code.

Edited by CMOSS
Link to post
Share on other sites
3 hours ago, CMOSS said:

xmlns:aov="clr-namespace:Ao.Bigbox.ViewModels;assembly=Ao.Bigbox.Themer.v3_9_7a" xmlns:aox="clr-namespace:Ao.Bigbox.Converters;assembly=Ao.Bigbox.Themer.v3_9_7a" xmlns:aoc="clr-namespace:Ao.Bigbox.Controls;assembly=Ao.Bigbox.Themer.v3_9_7a"

It's actually 3 declarations in just one line, separated by a blank. This works ok in the generated code.

fixed in 1.0.7.2 which will be released on monday

image.thumb.png.f9dc18695d9046aa96accfd202650f38.png

image.thumb.png.d89574220067cf08f81d8c4d68f9d685.png

  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...