Jump to content
LaunchBox Community Forums

Community Theme Creator for BigBox


Recommended Posts

Community Theme Creator for BigBox

View File

Instructions

1. Download the .ZIP and UNBLOCK!

2. Unzip to a new location, DO NOT overwrite the existing forum build

3. Copy the content from the "My Theme Projects" folder from your existing Theme Creator folder and Paste into the new "My Theme Projects"

 

Things to Note

When opening the new Theme Creator it will upgrade ALL your copied Themes, this process only happens once so if you notice a delay now you know why.

 

Manuals / How to

Refer to my YouTube channel or visit Faeran's Theme Creator Workshop videos to better understand the new features.

Dave Paterson - YouTube

Development Live Streams - YouTube

 

Obsolete UI Elements

Some UI Elements have been made obsolete as you can now recreate your own custom versions of them with this build, here is a video explaining how you can replace them.

 

 

Screenshots

Untitled.png

Untitled2.png

Untitled3.png

Untitled4.png


 

  • Like 3
  • Thanks 1
  • Unusual Gem 1
Link to comment
Share on other sites

  • 4 months later...
9 minutes ago, HannesRoets said:

No worries, you did a find job already, no hurries ;)
Thanks for all your effort into this great tool!

Thanks very much, formatting text is on the list and I will be discussing that particular enhancement tomorrow during the livestream.

Link to comment
Share on other sites

  • 3 weeks later...

Hi!

How can I create a specific view for a playlist (for example, Atari Classics) with the Theme Creator? I have created a playlist and added it to the list of platforms, but it won't show up in the Theme Creator.

Best!

Edited by CMOSS
  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Hi,

Is there a way to undo a change? If I move an element, I'm not able to CTRL-Z to move it back.

Also I've ran into a few issues; The text scroller isn't scrolling, and I have a few installed fonts that aren't showing up.

Thanks.

Edited by Zaazu
Link to comment
Share on other sites

I have not tackled Playlists yet.

No undo... at least not yet... kinda tricky and easier said than done.

Text Scroller, set the speed to 1 and go from there

Fonts... i'm aware of that issue especially if that font has many variations

Link to comment
Share on other sites

  • 4 weeks later...

Hi @y2guru

I have an issue when specifying the resources in the text area of the "Manage External Plugins". I am doing the following:

image.thumb.png.13c722bdeab0160ae011d267db85ae25.pngAfter clicking the OK button, if I open again the window, what I get is the following: 

image.thumb.png.7173a8cfd557238eee127ac6717a3ae2.pngEverything is removed after the first occurrence of "/>". The generated view makes then BigBox crash (I can make it work as I want it to by adding the original 2 lines on the generated view directly, within the <UserControl.Resources> tag).

Is this a bug or am I doing something wrong?

Thanks in advance.

PS. I am using version 1.0.6.1

 

Link to comment
Share on other sites

10 minutes ago, CMOSS said:

Hi @y2guru

I have an issue when specifying the resources in the text area of the "Manage External Plugins". I am doing the following:

image.thumb.png.13c722bdeab0160ae011d267db85ae25.pngAfter clicking the OK button, if I open again the window, what I get is the following: 

image.thumb.png.7173a8cfd557238eee127ac6717a3ae2.pngEverything is removed after the first occurrence of "/>". The generated view makes then BigBox crash (I can make it work as I want it to by adding the original 2 lines on the generated view directly, within the <UserControl.Resources> tag).

Is this a bug or am I doing something wrong?

Thanks in advance.

PS. I am using version 1.0.6.1

 

I’ll try exactly as you’ve indicated later (once I get home) and determine the fault, it looks like a bug to me

Link to comment
Share on other sites

6 hours ago, y2guru said:

I’ll try exactly as you’ve indicated later (once I get home) and determine the fault, it looks like a bug to me

can you share the text you were trying to key in, the declaration is missing characters as the text length is too long.  thanks

Link to comment
Share on other sites

7 hours ago, y2guru said:

can you share the text you were trying to key in, the declaration is missing characters as the text length is too long.  thanks

<aox:GameSelectionColorConverter x:Key="GameSelectionColorConverter"/>
<SolidColorBrush x:Key="DefaultGameColor" Color="#5abc3c"/>

This one. Just one of the above lines will also cause the issue.

Link to comment
Share on other sites

3 hours ago, CMOSS said:

<aox:GameSelectionColorConverter x:Key="GameSelectionColorConverter"/>
<SolidColorBrush x:Key="DefaultGameColor" Color="#5abc3c"/>

This one. Just one of the above lines will also cause the issue.

can you provide the text in the declaration text box also, that's the one that's too long for me to see the complete line

xmlns:aov etc....

Link to comment
Share on other sites

24 minutes ago, y2guru said:

can you provide the text in the declaration text box also, that's the one that's too long for me to see the complete line

xmlns:aov etc....

xmlns:aov="clr-namespace:Ao.Bigbox.ViewModels;assembly=Ao.Bigbox.Themer.v3_9_7a" xmlns:aox="clr-namespace:Ao.Bigbox.Converters;assembly=Ao.Bigbox.Themer.v3_9_7a" xmlns:aoc="clr-namespace:Ao.Bigbox.Controls;assembly=Ao.Bigbox.Themer.v3_9_7a"

It's actually 3 declarations in just one line, separated by a blank. This works ok in the generated code.

Edited by CMOSS
Link to comment
Share on other sites

3 hours ago, CMOSS said:

xmlns:aov="clr-namespace:Ao.Bigbox.ViewModels;assembly=Ao.Bigbox.Themer.v3_9_7a" xmlns:aox="clr-namespace:Ao.Bigbox.Converters;assembly=Ao.Bigbox.Themer.v3_9_7a" xmlns:aoc="clr-namespace:Ao.Bigbox.Controls;assembly=Ao.Bigbox.Themer.v3_9_7a"

It's actually 3 declarations in just one line, separated by a blank. This works ok in the generated code.

fixed in 1.0.7.2 which will be released on monday

image.thumb.png.f9dc18695d9046aa96accfd202650f38.png

image.thumb.png.d89574220067cf08f81d8c4d68f9d685.png

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...