Jump to content
LaunchBox Community Forums

Recommended Posts

3 hours ago, y2guru said:

The theme creator relies heavily on its own plugin as the plugin is responsible for scaling UI elements based on the users resolution.

so yes it would be a dealbreaker if startup themes do not support plugins.

 

@Jason Carr can this be helped ?

  • Like 1

Share this post


Link to post
Share on other sites

I'm trying to get the "Total Games Count" to load "During Selection" (instantly), it seems like there's a bug that prevents this from happening. It only loads "Once Selected" no matter how it's set. Anyone experiencing a similar issue?

Share this post


Link to post
Share on other sites
8 hours ago, Klopjero said:

@Jason Carr can this be helped ?

 

5 hours ago, ALIE said:

Could be cool if Pause screen was possible as well ⏸️. If possible @Jason Carr @y2guru

Dreaming 😊

I think this should be possible without too much trouble. On my list. :)

1 hour ago, Corgana said:

I'm trying to get the "Total Games Count" to load "During Selection" (instantly), it seems like there's a bug that prevents this from happening. It only loads "Once Selected" no matter how it's set. Anyone experiencing a similar issue?

That's probably Big Box itself doing that. Loading the Total Games Count is a slower process, so it's too intensive to do instantly during quick moves.

  • Like 1

Share this post


Link to post
Share on other sites

It's definitely doing the "once selected" behavior, if I hold down the scroll wheel it will wait to change once the wheel has settled. I tested this on a machine with only 2-4 games per system just to be sure.

13 hours ago, Jason Carr said:

That's probably Big Box itself doing that. Loading the Total Games Count is a slower process, so it's too intensive to do instantly during quick moves.

 

Edited by Corgana
Formatting

Share this post


Link to post
Share on other sites
40 minutes ago, Corgana said:

It's definitely doing the "once selected" behavior, if I hold down the scroll wheel it will wait to change once the wheel has settled. I tested this on a machine with only 2-4 games per system just to be sure.

 

Yes, that is by design. Unfortunately doing it instantly is not supported.

Share this post


Link to post
Share on other sites
3 hours ago, Jason Carr said:

 

I think this should be possible without too much trouble. On my list. :)

That's probably Big Box itself doing that. Loading the Total Games Count is a slower process, so it's too intensive to do instantly during quick moves.

Then Pause screen would just need multiple save stats 😉.. 

Share this post


Link to post
Share on other sites
4 hours ago, Jason Carr said:

 

I think this should be possible without too much trouble. On my list. :)

That's probably Big Box itself doing that. Loading the Total Games Count is a slower process, so it's too intensive to do instantly during quick moves.

That's great to hear! I think that the more developed and user-friendly 'Community Theme Creator' becomes including startup and pause themes, then eventually the more (new) creative-type users will jump on board to use BigBox.

  • Like 1

Share this post


Link to post
Share on other sites
17 hours ago, Jason Carr said:

Yes, that is by design. Unfortunately doing it instantly is not supported.

I'm assuming that means it's not possible to write a theme that overrides it and have the GamesCount load as soon as possible? It's kind of crucial for a theme I'm doing.

Share this post


Link to post
Share on other sites
On 9/25/2020 at 8:45 AM, bundangdon said:

That's great to hear! I think that the more developed and user-friendly 'Community Theme Creator' becomes including startup and pause themes, then eventually the more (new) creative-type users will jump on board to use BigBox.

Yah plus those 2 sections has unfortunately never gotten the same attention. Not as many awesome themes to pick from as regular themes. I could imagine the selection would sky rocket with this. 

  • Thanks 1

Share this post


Link to post
Share on other sites
On 9/25/2020 at 2:27 PM, Corgana said:

I'm assuming that means it's not possible to write a theme that overrides it and have the GamesCount load as soon as possible? It's kind of crucial for a theme I'm doing.

Yes, unfortunately not. You could write a plugin to do it, but it's definitely not recommended because of the performance issues that it would likely introduce.

Share this post


Link to post
Share on other sites
On 9/25/2020 at 5:27 PM, Corgana said:

I'm assuming that means it's not possible to write a theme that overrides it and have the GamesCount load as soon as possible? It's kind of crucial for a theme I'm doing.

Could do is use your plugin to poll the users entire game library and then get the counts on start up, and then use that cached information in the view. Would cause a delay in start up but would be far less detrimental to the user than you trying to brute force it every time the user changes selection.

Share this post


Link to post
Share on other sites
4 hours ago, C-Beats said:

Could do is use your plugin to poll the users entire game library and then get the counts on start up, and then use that cached information in the view. Would cause a delay in start up but would be far less detrimental to the user than you trying to brute force it every time the user changes selection.

Good idea, I don't suppose you have a tutorial or starting point anywhere for that- eh? I'm honestly surprised that's not something Launchbox does by default. Plus it's not like "counting the number of files in a folder" is a time-consuming task, especially since a pretty beefy computer is needed to run Launchbox smoothly already.

Share this post


Link to post
Share on other sites

Hello,

I'm trying to add a User Defined Video for just a background. However, when I try to select Media Image then Media Folder in the editor, there is nothing to select in the dropdown box. It's just black. I've unblocked the zip, tried to run as administrator, try to change DPI setting in Windows and still can't get it to populate anything in the folder or file name dropdowns for a user defined video. Any suggestions?

Using the latest .09 version.

Thanks.

Edited by Surfdeign

Share this post


Link to post
Share on other sites
1 hour ago, Surfdeign said:

Hello,

I'm trying to add a User Defined Video for just a background. However, when I try to select Media Image then Media Folder in the editor, there is nothing to select in the dropdown box. It's just black. I've unblocked the zip, tried to run as administrator, try to change DPI setting in Windows and still can't get it to populate anything in the folder or file name dropdowns for a user defined video. Any suggestions?

Using the latest .09 version.

Thanks.

ah, so no entries in the dropdown box. when you click media folder, do you see entries? meaning did you successfully select a media folder then no entries are available for the filename ? if thats the case, the selection is looking for mp4, what file type are your videos ?

Share this post


Link to post
Share on other sites

Update - I got it to select the file by moving it into the theme creator folder, but it's not playing on the preview or editor...

image.thumb.png.97bd321dcaabdad178fa7158f7370a33.png

The video is MP4. I select browse media folder, it opens an explorer window and I browse to the folder where the video is and open it. I've attached a pic of what it looks like. It also took away the media file drop down that was under media folder... 

 

image.thumb.png.5817a753d2f0a503998697e1ba6de869.png

Edited by Surfdeign

Share this post


Link to post
Share on other sites
5 hours ago, Surfdeign said:

Update - I got it to select the file by moving it into the theme creator folder, but it's not playing on the preview or editor...

image.thumb.png.97bd321dcaabdad178fa7158f7370a33.png

The video is MP4. I select browse media folder, it opens an explorer window and I browse to the folder where the video is and open it. I've attached a pic of what it looks like. It also took away the media file drop down that was under media folder... 

 

image.thumb.png.5817a753d2f0a503998697e1ba6de869.png

Click Browse Media Folder, then create new folder (User Defined Videos) and place the .MP4 in that new folder.  exit the explorer window and return to the properties panel,  you can now click the Media folder drop down and select your new folder, then you can see the .mp4 when you click the filename dropdown

Share this post


Link to post
Share on other sites
3 hours ago, Surfdeign said:

Thanks, that worked great!!

Glad to hear it, the next release I will add a text file to the media folder indicating that sub folders should be created to contain your own personalized media 

sorry for the confusion

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...