Jump to content
LaunchBox Community Forums
Jason Carr

10.7-beta-1 Released

Recommended Posts

FYI ... Issue with Beta 2 when trying to d/l media after right clicking on a game and edit. Trying to download media will error out.

  • Like 1

Share this post


Link to post
Share on other sites
43 minutes ago, Krakerman said:

FYI ... Issue with Beta 2 when trying to d/l media after right clicking on a game and edit. Trying to download media will error out.

What media types from where? Just tried on several games across several platforms and couldn't get it to fail. If "error out" means the bug report screen could you send me a copy of the text inside it?

Share this post


Link to post
Share on other sites
Value cannot be null.
Parameter name: source

App:     LaunchBox
Version: 10.7-beta-2
Type:    System.ArgumentNullException
Site:    Boolean Contains[TSource](System.Collections.Generic.IEnumerable`1[TSource], TSource, System.Collections.Generic.IEqualityComparer`1[TSource])
Source:  System.Core

   at System.Linq.Enumerable.Contains[TSource](IEnumerable`1 source, TSource value, IEqualityComparer`1 comparer)
   at (DownloadImagesForm )
   at Unbroken.LaunchBox.Windows.Desktop.Forms.DownloadImagesForm.InitDownloads()
   at (DownloadImagesForm , Object , RunWorkerCompletedEventArgs )
   at Unbroken.LaunchBox.Windows.Desktop.Forms.DownloadImagesForm.backgroundWorker_RunWorkerCompleted(Object sender, RunWorkerCompletedEventArgs e)
   at System.ComponentModel.BackgroundWorker.OnRunWorkerCompleted(RunWorkerCompletedEventArgs e)
   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

Recent Log:

   8:00:30 PM Music.Prepare Start
   8:00:30 PM Music.Kill Start
   8:00:30 PM Music.Kill Finished
   8:00:30 PM Music.NotifyTrackList Start
   8:00:30 PM Music.NotifyTrackList Invoke WPF
   8:00:48 PM Music.Play Start
   8:00:48 PM Music.Kill Start
   8:00:48 PM Music.Kill Finished
   8:00:48 PM Music.Play Empty Music Path
   8:00:48 PM Music.NotifyTrackList Start
   8:00:48 PM Music.NotifyTrackList Invoke WPF
   8:00:50 PM Music.Stop Start
   8:00:50 PM Music.Kill Start
   8:00:50 PM Music.Kill Finished
   8:00:50 PM Music.Play Start
   8:00:50 PM Music.Kill Start
   8:00:50 PM Music.Kill Finished
   8:00:50 PM Music.Play Empty Music Path
   8:00:50 PM Music.NotifyTrackList Start
   8:00:50 PM Music.NotifyTrackList Invoke WPF
   8:01:02 PM Exception

 

Edited by Krakerman
  • Like 1

Share this post


Link to post
Share on other sites

Only happens in Beta 2 ... Beta 1 no error. Trying to d/l media for Steam games when you right click on a game then go to edit then press download media you get the error

Edited by Krakerman
  • Like 1

Share this post


Link to post
Share on other sites

I have tracked the bug down and squashed it @Krakerman it will be in the next push. This only affects Steam games without trailers available.

  • Like 3

Share this post


Link to post
Share on other sites
16 hours ago, RULLUR said:

I guess I rushed on what I was saying, but basically I was looking through my Platforms in BigBox and kinda noticed something missing which was my SEGA STV one which is actually a Playlist I made visible as a Platform. Apparently it went away and back to only being a Playlist and not a Playlist made visible as a Platform. So I had to go into the Edit for SEGA STV and clicked the option to make it that way while also having to rename the Unique Name as "SEGA STV" instead of "Arcade SEGA STV" again and also having to go back and set the Video Directory for it since that somehow went to being set to the Arcade Video I guess because it's actually part of Arcade as a Playlist. I hope this is enough detail in explaining what happened. I don't know if anyone else has experienced that with any Playlists they made as a Platform or not, but it happened to me though.

Hmm, I'm not sure why a playlist would lose those settings; I haven't seen that situation before. I'll keep an eye out though. Thanks @RULLUR.

16 hours ago, wallmachine said:

upon this update I couldn't run BigBox from pinned item on task-bar had to re-pin it.

 

15 hours ago, Retro808 said:

Worked fine on all my cabinets/builds. None of them needed re-pinning. I have had this happen in the past with other software after an update. So I don't think it is something unique to Launchbox. 

Yeah, this is just Windows. There's unfortunately not anything we can do about it.

  • Like 1

Share this post


Link to post
Share on other sites
20 hours ago, Jason Carr said:

There should be a new "Games Missing Media" option available in the side bar filter type drop down.

1536105692_Bildschirmfoto2019-11-12um20_24_22.thumb.png.7bbe742f29cd980fe23eddcca631f9dc.pngin the German Translation I cannot find nothing under "Ansicht".

Share this post


Link to post
Share on other sites
2 minutes ago, Chris Kant said:

1536105692_Bildschirmfoto2019-11-12um20_24_22.thumb.png.7bbe742f29cd980fe23eddcca631f9dc.pngin the German Translation I cannot find nothing under "Ansicht".

That is the "Tools" menu, not the sidebar. 

It's here.

1596173395_Screenshot(160).thumb.png.1f377fc9140964b00117a25e3625dc14.png

  • Like 2

Share this post


Link to post
Share on other sites
25 minutes ago, Chris Kant said:

ach clear. thank you. unlucky place for that and that's why I never expected that on that place

Beta 2 is out now guys with the following:

  • New Feature: You can now filter your library in LaunchBox based on missing media. In the sidebar drop down select "Games Missing Media" and then pick the appropriate media type.

:) No worries, glad you found it and that it helps.

Share this post


Link to post
Share on other sites

After updating to the latest beta it takes about 5-10 seconds each time for the ListView to display, no xaml code, settings or plugins changed. I then restarted my PC and after opening BigBox it would freeze my PC after a few seconds in the PlatformWheel2FiltersView each time. I then rolled back to 10.7-beta-1 and still the same issue not sure if rolling back still doesn't work (https://forums.launchbox-app.com/topic/49564-98-beta-1-released/?do=findComment&comment=31803). Just to note after rolling back and when LaunchBox re-opens itself it said I had no platforms/games so I just closed it and re-opened and the platforms/games appeared.

Please see example at 4:00 it takes a while to display ListView even though Fade Quick is on. Also occasionally scrolling freezes please see at 5:06. Honestly not sure if its the update as the issues only started after it haven't had any windows updates recently either.

Edited by wallmachine

Share this post


Link to post
Share on other sites

@wallmachine I've done some testing and haven't been able to replicate any of that. I'm inclined to believe that whatever is causing it is not related to the update, as you suggested. Rolling back to beta 1 should work just fine, so most likely it's not related to the beta release. Does it happen with all themes on your system?

Share this post


Link to post
Share on other sites

Beta 3 is out now guys with the following:

  • New Feature: You can now force update metadata from the LaunchBox Games Database via Help > Force Update Games Database Metadata in LaunchBox
  • Fixed: Removing existing auto-generated playlists was sometimes incorrectly deleting unrelated playlists because of "Nintendo Game Boy" being part of multiple platforms
  • Fixed: Steam metadata imports were causing errors for games without videos (introduced in previous beta)
  • Fixed: Counts were not properly showing in the side bar for the new Games Missing Media section

Also, I finally have a new Android beta out with a new import process that runs directly on Android devices (and no longer requires the desktop app):

 

  • Like 5

Share this post


Link to post
Share on other sites
1 hour ago, Jason Carr said:

@wallmachine I've done some testing and haven't been able to replicate any of that. I'm inclined to believe that whatever is causing it is not related to the update, as you suggested. Rolling back to beta 1 should work just fine, so most likely it's not related to the beta release. Does it happen with all themes on your system?

yes

Share this post


Link to post
Share on other sites

Beta 4 is out now with the following:

  • Improvement: LaunchBox and Big Box now use improved processes for media downloads (threaded downloads). This should signficantly speed up downloads from the LaunchBox Games Database, especially.
  • Improvement: In Big Box you can now individually hide view types while locked instead of all or none
  • New "Games Missing Media" filters now have items for videos and manuals as well
  • Fixed: "Scan for Removed ROMs" now removes additional apps that are missing as well

Planning for this to be the last beta release with new stuff before the official release, which hopefully will go out early next week. Any testing you can do would be appreciated. :)

  • Like 13
  • Thanks 1
  • Game On 1

Share this post


Link to post
Share on other sites

Hey guys, should import of Steam trailers be working now? I tried updating all my steam games and I'm still not able to get Steam trailers

Share this post


Link to post
Share on other sites
6 minutes ago, TheNewClassics said:

Hey guys, should import of Steam trailers be working now? I tried updating all my steam games and I'm still not able to get Steam trailers

Yes, they should be working. How are you testing?

Share this post


Link to post
Share on other sites

Beta 5 is out now guys with only translation updates. Planning to put the official 10.7 release out tomorrow morning. :)

  • Like 2

Share this post


Link to post
Share on other sites

I used the update metadata and media on all my windows games, and made sure the Steam Trailer was checked. Videos don't seem to be downloading though

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...