Jump to content
LaunchBox Community Forums
Jason Carr

10.7-beta-1 Released

Recommended Posts

1 minute ago, TheNewClassics said:

I used the update metadata and media on all my windows games, and made sure the Steam Trailer was checked. Videos don't seem to be downloading though

Videos will only download if a video doesn't already exist, and the game is actually launching a Steam game via a Steam URL. I just tested the latest beta with updating metadata and media and it seems to be pulling down videos just fine.

Share this post


Link to post
Share on other sites
7 minutes ago, TheNewClassics said:

I used the update metadata and media on all my windows games, and made sure the Steam Trailer was checked. Videos don't seem to be downloading though

 

1 minute ago, Jason Carr said:

Videos will only download if a video doesn't already exist, and the game is actually launching a Steam game via a Steam URL. I just tested the latest beta with updating metadata and media and it seems to be pulling down videos just fine.

Yeah i was about to say, i believe it only works for actual steam games, normal windows games from other stores or discs are not supported.

Share this post


Link to post
Share on other sites

My bad, should have clarified. I'm using it primarily for Steam games; the example I can use is Yakuza Kiwami. It has a trailer on the Steam store and it's launching through Steam when I use it. For whatever reason it's not pulling the trailer. I'll try a few others but haven't had much luck. 

Share this post


Link to post
Share on other sites
9 minutes ago, TheNewClassics said:

My bad, should have clarified. I'm using it primarily for Steam games; the example I can use is Yakuza Kiwami. It has a trailer on the Steam store and it's launching through Steam when I use it. For whatever reason it's not pulling the trailer. I'll try a few others but haven't had much luck. 

Strange. I just tested Yakuza Kiwami and downloaded that trailer just fine. This whole Steam trailer download process has been confusing for ages; at this point I'm guessing Steam is limiting it somehow for some people or something like that. What do you have in the game's application path field for that game?

Share this post


Link to post
Share on other sites
7 minutes ago, TheNewClassics said:

steam://rungameid/834530

Same as what's in mine. What language are you using in LaunchBox? I wonder if it's a translation issue or something.

Share this post


Link to post
Share on other sites

English. Yea definitely seems like a weird bug, there's several games with trailers that aren't downloading. Some of the initial entries I imported have the trailers; I wonder if the api blocked downloading trailers at some point for me 

Share this post


Link to post
Share on other sites
10 minutes ago, TheNewClassics said:

English. Yea definitely seems like a weird bug, there's several games with trailers that aren't downloading. Some of the initial entries I imported have the trailers; I wonder if the api blocked downloading trailers at some point for me 

That's my guess, but I still don't have a definitive answer, unfortunately.

Share this post


Link to post
Share on other sites

Unfortunately no. It basically just says game updated/imported successfully. I'm not sure if there's a log I could send you that might help? 

Share this post


Link to post
Share on other sites
18 hours ago, Jason Carr said:

@TheNewClassics I assume you don't get any errors reported?

I have the same issue without any message for not working downloading the videos for my steam games.

Share this post


Link to post
Share on other sites

Sorry coming late into the party. How are we determining the video didn't download? Is it now showing up in Launchbox or Big Box? Is it not in the Launchbox\Videos\Windows\ directory? Mine is working so I want to get as much information as possible so we can try to get this working for everyone.

Share this post


Link to post
Share on other sites
8 minutes ago, C-Beats said:

Sorry coming late into the party. How are we determining the video didn't download? Is it now showing up in Launchbox or Big Box? Is it not in the Launchbox\Videos\Windows\ directory? Mine is working so I want to get as much information as possible so we can try to get this working for everyone.

at least I have no video in the games detail screen in Launchbox AND under missing video filter the game is showing up

Share this post


Link to post
Share on other sites
33 minutes ago, TheNewClassics said:

It's not showing up, and it's not in the video directory either

Could you go to a title you know has a trailer video. Right click and hit edit to get the games Edit screen open. Then in the bottom right push the "Download Images/Media" and tell me if you see the "Steam Trailer Video (1)" show in the grid?

Share this post


Link to post
Share on other sites
37 minutes ago, C-Beats said:

Could you go to a title you know has a trailer video. Right click and hit edit to get the games Edit screen open. Then in the bottom right push the "Download Images/Media" and tell me if you see the "Steam Trailer Video (1)" show in the grid?

Just checked here with Half Life 2, has a video on steam, but it doesnt list one in the edit window.

515407556_Screenshot(164).thumb.png.3c30aba3a95b09067777b7dc564b6e6f.png115407693_Screenshot(165).thumb.png.4327e4532612d1293296990a31ba80f4.png

 

Share this post


Link to post
Share on other sites
7 minutes ago, C-Beats said:

For poo and giggles @neil9000 could you go to https://store.steampowered.com/api/appdetails/?appids=220 in your browser, then try again in LaunchBox and let me know the results.

Same.

97682285_Screenshot(167).thumb.png.7f3ced52d380c90701fa7adb6031bff9.pngI have my platform named Steam, not Windows. Could the platform name cause any issues? I have another platform called Windows that houses all my non-steam games.

Share this post


Link to post
Share on other sites

No the code checks that the Application path is a steam path. Doesn't pay attention to platform. When you went to that URL can I assume you saw the JSON response?

Share this post


Link to post
Share on other sites
10 minutes ago, C-Beats said:

When you went to that URL can I assume you saw the JSON response?

You can assume what you like, doesnt make it true though. :) I have no idea, how would i check that?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...