Jump to content
LaunchBox Community Forums

volume control problem


Recommended Posts

Hey guys,

I build my arcade cabinet with 2 volume buttons.

I selected them in BB as my volume up and volume down buttons.

But they only work in BB, not in any emulator.

Is that normal? Is there a way to let them work in all my emulators?

Link to post
Share on other sites
4 minutes ago, SpuRge said:

Hey guys,

I build my arcade cabinet with 2 volume buttons.

I selected them in BB as my volume up and volume down buttons.

But they only work in BB, not in any emulator.

Is that normal? Is there a way to let them work in all my emulators?

BigBox controls do not affect emulators they are only for BigBox. Those controls though should adjust the Windows volume. So you still should hear a volume change. 

Link to post
Share on other sites

It should work without needing to set in any emulator. I do not have it set in Mame and it works fine. I believe Jason said it is adjusting the Windows volume not the volume directly in Mame. At first I thought it did not work as well, but it turned out I had the volume directly in Mame and Retroarch set to low.

In the video watch in the upper left. It is adjusting the Windows volume as it should and this is in Mame. 

Are you on Win7 or Win10? Also are you using a game controller or a joystick setup that replicates keystrokes?

 

Link to post
Share on other sites
16 hours ago, Retro808 said:

It should work without needing to set in any emulator. I do not have it set in Mame and it works fine. I believe Jason said it is adjusting the Windows volume not the volume directly in Mame. At first I thought it did not work as well, but it turned out I had the volume directly in Mame and Retroarch set to low.

In the video watch in the upper left. It is adjusting the Windows volume as it should and this is in Mame. 

Are you on Win7 or Win10? Also are you using a game controller or a joystick setup that replicates keystrokes?

 

 

yes this is how it should work, but it just works in BB.

I use win10 on my arcade cabinet and I use the Ultimarc Ipac Ultimate for my controls.

 

I hope I can get it to work because I made some custom volume buttons.

 

20191118_185808.jpg

Link to post
Share on other sites
  • 2 weeks later...

@Retro808

So I tested a little bit more and found that when I set my volume keys in "Keyboard Mapping" they only work in the BigBox menu not in a game.

If I set them in "Keyboard Automation" they also work in a game, but I have to use a extra key to let them work.

Does it normaly work in a game with the volume keys set in "Keyboard Mapping"?  Because if it doesn't I don't  have to look for the problem why it does not work for me.

I don't want to use a extra button to change my volume.

Edited by SpuRge
Link to post
Share on other sites
16 hours ago, SpuRge said:

@Retro808

So I tested a little bit more and found that when I set my volume keys in "Keyboard Mapping" they only work in the BigBox menu not in a game.

If I set them in "Keyboard Automation" they also work in a game, but I have to use a extra key to let them work.

Does it normaly work in a game with the volume keys set in "Keyboard Mapping"?  Because if it doesn't I don't  have to look for the problem why it does not work for me.

I don't want to use a extra button to change my volume.

The keyboard mapping is for controlling BigBox only. 

The automation allows for controls while in an emulator. So you would want to make sure that is mapped. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...