Jump to content
LaunchBox Community Forums
Visivopro

Steam Import Not working

Recommended Posts

Trying to import steam games, I registered an API Key and my account is set to public but I continue to get an error saying to import my games I must be connected to the internet. I have had zero issue importing any other type of game. I searched for other topics with the same issue but the only ones I could find where almost two years old. has no progress been made in two years to fix the broken steam import issue? If that's true how do I play my steam games on a cabinet without having to connect a keyboard and mouse? How do I force them to launch from big box and launchbox?

 

Thank you

Share this post


Link to post
Share on other sites
4 minutes ago, Visivopro said:

Trying to import steam games, I registered an API Key and my account is set to public but I continue to get an error saying to import my games I must be connected to the internet. I have had zero issue importing any other type of game. I searched for other topics with the same issue but the only ones I could find where almost two years old. has no progress been made in two years to fix the broken steam import issue? If that's true how do I play my steam games on a cabinet without having to connect a keyboard and mouse? How do I force them to launch from big box and launchbox?

 

Thank you

The steam importer works just fine. Sounds like a firewall issue to me.

1175805892_Screenshot(181).thumb.png.2e6ebcefcaf32abea9c23771a0a67967.png

Share this post


Link to post
Share on other sites
2 hours ago, neil9000 said:

The steam importer works just fine. Sounds like a firewall issue to me.

1175805892_Screenshot(181).thumb.png.2e6ebcefcaf32abea9c23771a0a67967.png

Anything you can tell me that I should look for? Is it a firewall setting in my modem or is it a firewall setting with steam? Any direction I should go in to solve this issue?

Share this post


Link to post
Share on other sites
10 hours ago, Visivopro said:

Anything you can tell me that I should look for? Is it a firewall setting in my modem or is it a firewall setting with steam? Any direction I should go in to solve this issue?

I would guess its being blocked on your end as you get a message saying you need to connect to the internet.

Share this post


Link to post
Share on other sites

Thanks for everyone’s help, I have sorted the issue, turns out you need to make sure your community profile is fully set up, I didn’t have a custom domain setup so my profile name wasn’t fully connected to my profile. Once I set that up, it worked flawlessly. 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...