Jump to content
LaunchBox Community Forums
cjwillms

RushDownloader failed to download file while downloading Big Box Cinematix Video Theme

Recommended Posts

Over the past few days, I've been setting up LaunchBox and Big Box. I've been able to get everything working, with the exception of the "Big Box Cinematix Video Theme" download setup triggered via importing ROMs and using the 'Download Metadata and Media...' menu option.

Whenever LaunchBox tries to download a game's preview video, I get an error message similar to:

Could not download image <URL> for <Game Name>: RushDownloader failed to download file

See attached screenshot for some examples.

Whenever LaunchBox gets into this state, it looks like LaunchBox isn't really doing anything; although, I'm still seeing network traffic from it in the background. After a variable amount of time, ranging from a few seconds to over half an hour, LaunchBox will move on to searching for the next video to download.

Oddly, if I type the logged URL logged into a web browser (FIrefox in my case), then I'm able to manually download the video and add it to the Videos/<Platform>/Theme/ folder, which LaunchBox is then able to read.

 

From my end, it looks like the video is being downloaded at a slow rate (~1.5 Mbps), but either the connection is interrupted or it fails to write the file to the disk for some reason.

 

Are there any known issues with the video download process?

RushDownloadError.png

Share this post


Link to post
Share on other sites

Hi guys, this may be an oversight with the 10.7 release. We'll review and look into it. Thanks for the report. :)

Share this post


Link to post
Share on other sites

Ok cool. It seems to be scraping a lot slower in general, especially from Emumovies. I have 1gb download speed and media files are getting downloaded at 0.5Mbps.

Share this post


Link to post
Share on other sites
1 minute ago, Dynamite Jewduh said:

Ok cool. It seems to be scraping a lot slower in general, especially from Emumovies. I have 1gb download speed and media files are getting downloaded at 0.5Mbps.

No changes were made to the EmuMovies downloads at all, so I expect that's either just your perception or just the fact that it's busier because of the Black Friday traffic.

Share this post


Link to post
Share on other sites
16 minutes ago, Jason Carr said:

No changes were made to the EmuMovies downloads at all, so I expect that's either just your perception or just the fact that it's busier because of the Black Friday traffic.

Ok thanks. I was thinking it had something to do with the new threaded downloads added in the last update.

Edited by Dynamite Jewduh

Share this post


Link to post
Share on other sites
13 hours ago, Dynamite Jewduh said:

Ok thanks. I was thinking it had something to do with the new threaded downloads added in the last update.

The EmuMovies downloads are not currently threaded. The LaunchBox Games Database downloads are, but we've had many people test it and it significantly boosted speeds, not slowed them down. My guess is that any actual speed issues are likely the result of high traffic.

Share this post


Link to post
Share on other sites

I just updated to the 10.8 beta 1 and the video downloads are working again. As far as I can tell, the issue has been fixed.

 

Thanks for the help!

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...