Jump to content
LaunchBox Community Forums
Jason Carr

10.8-beta-1 Released

Recommended Posts

Beta 3 is out now with a fix for the aforementioned issue with getting stuck while scrolling up, and 720p support for the Retro Achievements profile in Big Box.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the updates LB team. I was trying to get the hang of the m3u feature, but having a hard time doing so. Trying with mednafen saturn, and Panzer Dragoon Saga. As far as I can tell, my setup meets all the conditions Christian described. However when I go to disc management, I'm only getting options for Disc 1/1. Where is the m3u file located once it's made?

Share this post


Link to post
Share on other sites
2 minutes ago, TheNewClassics said:

Thanks for the updates LB team. I was trying to get the hang of the m3u feature, but having a hard time doing so. Trying with mednafen saturn, and Panzer Dragoon Saga. As far as I can tell, my setup meets all the conditions Christian described. However when I go to disc management, I'm only getting options for Disc 1/1. Where is the m3u file located once it's made?

If you are using Retroarch you have to eject the disc before you can switch disks. Moving left and right before then won't change the disk index at all. mednafen saturn also requires that you toss the .CUE files in the M3U NOT the bin files, so if you are pointing to the bins you will need to repoint.

Share this post


Link to post
Share on other sites

Sorry I should have clarified, I ejected first. I imported all my roms as cue files. But maybe I misunderstood; is the idea that LB will create the m3u and point to the cue files, or will I need to edit something after the file is created?

Share this post


Link to post
Share on other sites

Clean up Media = no option to go to a file in a folder and no option to compare a file with other files to choose the version of the file we want etc.

Not sure how it works to decide if a file is a duplicate. What are the criteria? It's intended to be automatic. Good but it once deleted a lot of files that I needed.

 

Edited by Pixel

Share this post


Link to post
Share on other sites
7 hours ago, Pixel said:

Clean up Media = no option to go to a file in a folder and no option to compare a file with other files to choose the version of the file we want etc.

Not sure how it works to decide if a file is a duplicate. What are the criteria? It's intended to be automatic. Good but it once deleted a lot of files that I needed.

 

A duplicate is two files that are exactly the same content. Meaning the hash of the two files are the same. If you have two images that are of the same picture but the file hash is different this tool wouldn't know and would leave your image alone. The tool DOES also now tell you the full path of the files in question so that you CAN navigate to that file and compare before selecting it to delete.

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, C-Beats said:

The tool DOES also now tell you the full path of the files in question so that you CAN navigate to that file and compare before selecting it to delete.

It found 56291 duplicated items, so it can take a bit of time...

Share this post


Link to post
Share on other sites

Yeah depending what method you use when mass downloading media that can be very possible. I ran the download media tool against my entire library last night and woke up to 26k duplicates (give or take)

Share this post


Link to post
Share on other sites
On 1/16/2020 at 10:33 PM, C-Beats said:

@Wally

This feature will automatically create and send to your emulator a M3U file under ALL of the following conditions:

1. The application path launched is associated to an additional application of the game you are playing
2. The additional application associated has a disc number associated to it (found in the "Edit Addtional Application" form found in the "Edit Game" form of LaunchBox)
3. The application path launched is not already a M3U
4. The emulator is marked that is supports M3U

If all the above is TRUE then the M3U is made with the application you selected to launch as first track, followed by all other additional applications under that game that also have a disc number, in disc order (numerical).

 

What is the additional application? I have Launchbox, RetroArch.

 

Share this post


Link to post
Share on other sites
6 hours ago, Wally said:

What is the additional application? I have Launchbox, RetroArch.

 

Click edit on any game, you will notice an "Additional Application" tab. I am referring to those. Basically another version of the same game all merged to the same game record.

  • Like 1

Share this post


Link to post
Share on other sites
On 1/16/2020 at 10:37 PM, Pixel said:

Clean up Media = no option to go to a file in a folder and no option to compare a file with other files to choose the version of the file we want etc.

Not sure how it works to decide if a file is a duplicate. What are the criteria? It's intended to be automatic. Good but it once deleted a lot of files that I needed.

 

If the Clean Up Media tool finds duplicate files, there's no reason at all to review them. It means that the files are 100% exactly the same, so there's literally no reason to keep both of them, or pick and choose which one to keep. Reviewing is really only going to helpful for peace of mind, or if you happen to be using the LaunchBox image folders for another frontend and want to make sure that you're not removing anything that affects anything else.

  • Like 1

Share this post


Link to post
Share on other sites

Hey! Maybe not directly related to the beta versions, I've had this for quite some time. 

Whenever I launch BigBox I sometimes see the Start Menu, and I have to click or alt-tab to make it go away.

It doesn't happen every time, maybe 1/5 times perhaps? I have my Start Menu on the left hand site, could that have something to do with it?

Or could it be some other application claiming focus?

It looks like this.

Any ideas?

 

Edit: Seems like it's only happening on my TV, which in this case is my third monitor, connected via HDMI. My other two displays are connected via DVI.

I launched BB about 5 times on my main monitor with only the main and second monitor connected, HDMI pulled out, didn't see the start menu once.

Connected the TV via HDMI, extended my desktop and used only the TV. Launched BB 4 times, 3/4 the Start Menu is visible.

You can see how it looks here as well.

https://photos.app.goo.gl/hw3uYqLscAhYuqu46

 

 

BB.png

Edited by e2zippo

Share this post


Link to post
Share on other sites

Have you tested it with the start menu in the normal position?

Share this post


Link to post
Share on other sites

I've just updated from LaunchBox 10.9 to 10.10 and experimented with the Blur Amount and Blur Fade sliders.
I notice that changing the Fade works straight off, but changing the Amount needs a LaunchBox restart in order to take effect. Is this normal or am I not doing it right?
I'm using the original Bad Old Monkey theme.

Share this post


Link to post
Share on other sites
2 hours ago, e2zippo said:

Hey! Maybe not directly related to the beta versions, I've had this for quite some time. 

Whenever I launch BigBox I sometimes see the Start Menu, and I have to click or alt-tab to make it go away.

It doesn't happen every time, maybe 1/5 times perhaps? I have my Start Menu on the left hand site, could that have something to do with it?

Or could it be some other application claiming focus?

It looks like this.

Any ideas?

 

Edit: Seems like it's only happening on my TV, which in this case is my third monitor, connected via HDMI. My other two displays are connected via DVI.

I launched BB about 5 times on my main monitor with only the main and second monitor connected, HDMI pulled out, didn't see the start menu once.

Connected the TV via HDMI, extended my desktop and used only the TV. Launched BB 4 times, 3/4 the Start Menu is visible.

You can see how it looks here as well.

https://photos.app.goo.gl/hw3uYqLscAhYuqu46

 

 

BB.png

I too have this happen at times, and even sometimes I have where it while force me back to BigBox in the middle of a game in which I have to Alt+Tab back to it, or sometimes things like VirtualJaguar or some other random Emulator will launch behind BigBox to where you have to either try and Alt+Tab over to it or press Esc to back out of the game and try to launch it again. I have also times where I will exit a game and come to a black screen in which I have to Alt+Tab back to BigBox. Much of the time when I start BigBox I found if I mess with the volume control that it somehow speeds up the waiting too. Some of these I've stated before, and some of these I keep forgetting to mention until someone here with something similar reminds me enough to state the issue or issues I'm having. Hopefully @Jason Carr or @C-Beatswill have a solution for any or all of these, but for now I kinda am dealing with it all as I currently am.

Share this post


Link to post
Share on other sites

@e2zippo Generally this happens when something else is focused during the Big Box startup process. But between different systems, setups, and drivers, it could be anything. Windows focus stuff is a very complicated beast these days, and Windows purposefully tries to remove that control from app developers, so there's probably not a lot we can do to fix that particular issue. At least it's easy enough to fix just with an Alt+Tab.

21 hours ago, spycat said:

I've just updated from LaunchBox 10.9 to 10.10 and experimented with the Blur Amount and Blur Fade sliders.
I notice that changing the Fade works straight off, but changing the Amount needs a LaunchBox restart in order to take effect. Is this normal or am I not doing it right?
I'm using the original Bad Old Monkey theme.

It shouldn't need a restart, but it does need to update the background. So it should work to just click on a new game with a different background.

19 hours ago, RULLUR said:

I too have this happen at times, and even sometimes I have where it while force me back to BigBox in the middle of a game in which I have to Alt+Tab back to it, or sometimes things like VirtualJaguar or some other random Emulator will launch behind BigBox to where you have to either try and Alt+Tab over to it or press Esc to back out of the game and try to launch it again. I have also times where I will exit a game and come to a black screen in which I have to Alt+Tab back to BigBox. Much of the time when I start BigBox I found if I mess with the volume control that it somehow speeds up the waiting too. Some of these I've stated before, and some of these I keep forgetting to mention until someone here with something similar reminds me enough to state the issue or issues I'm having. Hopefully @Jason Carr or @C-Beatswill have a solution for any or all of these, but for now I kinda am dealing with it all as I currently am.

Pretty much all of this is related to the startup and/or pause screens, which have always been hacks, because that's straight up the only way to implement them (unfortunately they fly in the face of how Windows wants apps to work). On most systems all these features work fine, but there are still some systems that have occasional trouble. In that case, unfortunately your best option is to just disable the startup or pause screens, or try updating drivers, as it's often caused by driver issues. I wish I had a better solution for this, but there really isn't one. We held off on implementing startup and pause screens for ages for this very reason, but eventually went ahead with them due to user demands. There really aren't any better solutions out there for those features, so we did the best that we could.

  • Like 3

Share this post


Link to post
Share on other sites
4 hours ago, Jason Carr said:

Pretty much all of this is related to the startup and/or pause screens, which have always been hacks, because that's straight up the only way to implement them (unfortunately they fly in the face of how Windows wants apps to work). On most systems all these features work fine, but there are still some systems that have occasional trouble. In that case, unfortunately your best option is to just disable the startup or pause screens, or try updating drivers, as it's often caused by driver issues. I wish I had a better solution for this, but there really isn't one. We held off on implementing startup and pause screens for ages for this very reason, but eventually went ahead with them due to user demands. There really aren't any better solutions out there for those features, so we did the best that we could.

@Jason CarrVery understandable, and I know you mean well in trying your best in giving us as much of a flawless product as you can too. I will see about updating some drivers, and if not I will just hang in there and try do what I've been doing to get around it.

  • Like 1

Share this post


Link to post
Share on other sites
13 hours ago, Jason Carr said:

@e2zippo Generally this happens when something else is focused during the Big Box startup process. But between different systems, setups, and drivers, it could be anything. Windows focus stuff is a very complicated beast these days, and Windows purposefully tries to remove that control from app developers, so there's probably not a lot we can do to fix that particular issue. At least it's easy enough to fix just with an Alt+Tab.

@Jason Carr No worries! It's really a non issue.  I thought I'd just report in case I could help with some troubleshooting or something, but I also think this something on my end.

You're doing an amazing job with LB and BB! 

  • Like 1

Share this post


Link to post
Share on other sites

image.thumb.png.07e14e4e8c75dd01535e7dd1ed4e7b0f.pngNot sure what happened, but after playing Perfect Dark while using the new Hyperkin Admiral controllers it decided to freeze like this. I had to Alt+Tab and close the window on it

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...