Jump to content
LaunchBox Community Forums
Shalashaskka

Mupen64 Retro Achivements Error

Recommended Posts

When launching N64 games through Launchbox/BigBox, I get an error message saying that "achievements cannot be loaded with this core." The weird thing is that when I launch the same games through Retroarch outside of Launchbox (i.e., on its own), achievements load up in said core just fine. I'm thinking that there's something in Launchbox that's messing around with Mupen64's ability to sync with the retroachivements server or something. 

The funny thing is that my other cores load up achievements fine (so far). Its just the N64 one(s) that are giving me trouble. I have updated to the latest stable build of Retroarch (1.8.4) and Launchbox (10.9)

Also, don't know if this is relevant or not, but I noticed that when launching my games through Launchbox, Retroarch shows the old style of verbose text rather than the new style since updating to 1.8.4. It further makes me think there's something in Launchbox that isn't playing nicely with it.

Share this post


Link to post
Share on other sites

Have you double checked that your N64 games are all using the proper install and Retroarch and the correct core ?

I have often "run into issues" and after a while of troubleshooting only to realize I was pointing LB to and older install or incorrect core. 

Share this post


Link to post
Share on other sites

I only have a single install of Retroarch so there's no other installation for it to point to. I've checked and doubled checked the cores their launching with in both Launchbox as well as the emulator without using Launchbox. 

Share this post


Link to post
Share on other sites
13 minutes ago, Shalashaskka said:

I only have a single install of Retroarch so there's no other installation for it to point to. I've checked and doubled checked the cores their launching with in both Launchbox as well as the emulator without using Launchbox. 

Just tested here through Launchbox with the mupen64-plus core and they are working just fine.

1832439061_RetroArchScreenshot2020_01.20-21_58_45_55.thumb.png.89692c01947d1038ef314b8df32959f5.png

Share this post


Link to post
Share on other sites

I'm going to go through my settings just in case I missed something but it just seems so strange to me that Launchbox is opening an older version of Retroarch despite updating both.

Thanks for the help so far!

Share this post


Link to post
Share on other sites
4 minutes ago, Shalashaskka said:

Launchbox is opening an older version of Retroarch despite updating both.

Launchbox is opening what you pointed it to, nothing more, nothing less. What you are saying simply isnt possible, launchbox has no control over Retroarch other than passing it a rom. So if you are seeing the old text notifications rather than the new widgets then that is how the Retroarch you have pointed Launchbox to is setup.

Share this post


Link to post
Share on other sites

If that's the case, why do I see the new widgets if I run the shortcut in the installation folder, but the same shortcut running through Launchbox brings up the older text popups?

Share this post


Link to post
Share on other sites

Update: So I seem to have figured out that Launchbox is indeed somehow messing with how Retroarch is interacting with Retroachievements, or at least with how Retroarch is launching. I've attached two video files to demonstrate what I'm talking about.

The first is merely me launching Retroarch from my desktop shortcut and quick selecting the last game on my list. It happens to be Banjo-Kazooie for the sake of this demonstration. You'll notice that the widget popups occur as normal, and it successfully manages to load achievements.

The second video is me doing the exact same action (launching Retroarch from my desktop shortcut), however this time, I have Launchbox in the background. You can clearly see that the widget popups look different, and that it fails to load up those achievements. Therefore I can only conclude that something inside of Launchbox is interfering with this function, as its the only changed variable between the two launches.

What baffles me is how or why its doing this. As I've said before, I've got a single installation of Retroarch and a single installation of Launchbox. The directories are all lined up, and in fact have no changed in the 2-3 years I've been using this program (which I'd like to add is amazing and I've had zero other issues with thus far). I've tried removing and re-adding the emulator, I've tried tinkering with the executable, and I've even completely rebuilt the Retroarch configuration files, and nothing had changed this launch pattern.

Anyway, I'll continue to look into this. Thanks for help thus far!

Retroarch Alone.mkv Retroarch with Launchbox Open.mkv

Share this post


Link to post
Share on other sites
7 minutes ago, Shalashaskka said:

The second video is me doing the exact same action (launching Retroarch from my desktop shortcut), however this time, I have Launchbox in the background. You can clearly see that the widget popups look different, and that it fails to load up those achievements. Therefore I can only conclude that something inside of Launchbox is interfering with this function, as its the only changed variable between the two launches.

Im just about to look at the videos attached, but of the bat this concerns me, the quote above, you are launching Retroarch via its shortcut, with launchbox in the background. If you are launching it from its own shortcut, then Launchbox has ABSOLUTELY NO IDEA that you have launched Retroarch at all, so there is no way at all it is changing anything (not that it does anyway).

Ill look at the videos and get back to you though.

Share this post


Link to post
Share on other sites

Are you 100% certain you have the correct core selected for LB to use ? There is more than 1 core and maybe you have the 1 selected that is wrong.screenshot_604.jpg.54d7cb6b7f3fc8055893b3bc09fbb4bb.jpgscreenshot_605.thumb.jpg.a6123cebd164ddec7e0a0c6f47981401.jpg

Share this post


Link to post
Share on other sites
1 minute ago, Lordmonkus said:

Are you 100% certain you have the correct core selected for LB to use ? There is more than 1 core and maybe you have the 1 selected that is wrong.

100%. If I had it set to another core, then Retroarch would just fail to launch.

JLtLZ01.thumb.png.0f184ae40eb993f18c1408d71e6e3d94.pngoY4re0v.thumb.png.fa2c809351eeb8e9da188e172f754699.png

6 minutes ago, neil9000 said:

Im just about to look at the videos attached, but of the bat this concerns me, the quote above, you are launching Retroarch via its shortcut, with launchbox in the background. If you are launching it from its own shortcut, then Launchbox has ABSOLUTELY NO IDEA that you have launched Retroarch at all, so there is no way at all it is changing anything (not that it does anyway).

Ill look at the videos and get back to you though.

I hear what you're saying and I agree. Which is why I'm so confused. There's no reason why it *should*, but something is clearly happening.

Thanks again!

Share this post


Link to post
Share on other sites

So, this is a side by side screengrab from both your videos, the first one (on the left launched alone) list's time played, the second one (on the right launched with LB in the background) does not. So i am leaning more towards a Retroarch bug to be honest. Launchbox does not monitor or interfere with anything on your PC, it has no idea that you have run Retroarch in either occasion, so the only variable i see there is retroarch itself.

Screenshot (272).png

Share this post


Link to post
Share on other sites
1 minute ago, neil9000 said:

So, this is a side by side screengrab from both your videos, the first one (on the left launched alone) list's time played, the second one (on the right launched with LB in the background) does not. So i am leaning more towards a Retroarch bug to be honest. Launchbox does not monitor or interfere with anything on your PC, it has no idea that you have run Retroarch in either occasion, so the only variable i see there is retroarch itself.

Screenshot (272).png

Interesting. I didn't even notice that. Well, thank you for looking into it. I'll try to tinker it some more on the Retroarch side of things and see if I can come up with anything.

This is by far the strangest thing I've encountered using emulation software.

Share this post


Link to post
Share on other sites

I had this issue with recent update of Retroarch just wouldn't login to Retroachievements on any core working fine before that couldn't find a solution so downloaded a fresh copy of the new Retroarch and setup and works a treat now, love to know if you find out what was wrong Shalashaskka 

Share this post


Link to post
Share on other sites
On 1/22/2020 at 4:28 PM, Napalm2016 said:

I had this issue with recent update of Retroarch just wouldn't login to Retroachievements on any core working fine before that couldn't find a solution so downloaded a fresh copy of the new Retroarch and setup and works a treat now, love to know if you find out what was wrong Shalashaskka 

I deleted my old Retroarch folder and reinstalled it like you did, and it doesn't seem to have fixed it. My SNES cores still work (even though it still has that yellow text verbose detailed popup when I boot up), but not N64. Still the same issue as before. 

Share this post


Link to post
Share on other sites

Sorry to hear that mine works fine now although sometimes it has the yellow text pop up and sometimes the new icons pop up I don't get it either very strange that it does that but have accepted it as the cores themselves seem to work with retroachievements now on mine

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...