Jump to content
LaunchBox Community Forums
YVRPC

Launchbox / BigBox "Close active window" via controller kills Wiimote Bluetooth connection

Recommended Posts

Hello all,

Just spent a couple days setting up LB/BB and I think I have found an obscure yet annoying bug. I am using a genuine Wii bluetooth module wired up to usb and connected using dolphins bluetooth passsthrough feature (more info here). The module allows basically perfect Wiimote behavior, no dropped connections or "re-syncing" required.

My ideal set up is using an 8bitdo Xinput controller to navigate and launch, (as well as play Gamecube games) then pick up a Wiimote to play Wii games. When it is time to quit or switch games i use the Xinput controller to close the active window.

The problem is when using Launchbox or BigBox, if i try to quit a game using the "Close active window" controller mapped button it kills the bluetooth, and it does such a number on it that reinstalling the libusbk driver is required to get it working again.

One thing to note is that hitting ESC on the keyboard or using the mouse to "X" out the window does not kill the bluetooth, it only happens when using the controller to close the active window. So is "Close the active window" essentially mapped to Alt+F4? Anyway to change that to ESC? Any reason to not do that?

I bought Bigbox mostly for playing Wii games and it is quite annoying to have another peripheral on the couch with me (Controller, Wiimote, and now wireless keyboard to hit ESC) so hopefully there is an easy fix.

Thanks in advance.

 

 

 

Share this post


Link to post
Share on other sites
3 hours ago, YVRPC said:

Hello all,

Just spent a couple days setting up LB/BB and I think I have found an obscure yet annoying bug. I am using a genuine Wii bluetooth module wired up to usb and connected using dolphins bluetooth passsthrough feature (more info here). The module allows basically perfect Wiimote behavior, no dropped connections or "re-syncing" required.

My ideal set up is using an 8bitdo Xinput controller to navigate and launch, (as well as play Gamecube games) then pick up a Wiimote to play Wii games. When it is time to quit or switch games i use the Xinput controller to close the active window.

The problem is when using Launchbox or BigBox, if i try to quit a game using the "Close active window" controller mapped button it kills the bluetooth, and it does such a number on it that reinstalling the libusbk driver is required to get it working again.

One thing to note is that hitting ESC on the keyboard or using the mouse to "X" out the window does not kill the bluetooth, it only happens when using the controller to close the active window. So is "Close the active window" essentially mapped to Alt+F4? Anyway to change that to ESC? Any reason to not do that?

I bought Bigbox mostly for playing Wii games and it is quite annoying to have another peripheral on the couch with me (Controller, Wiimote, and now wireless keyboard to hit ESC) so hopefully there is an easy fix.

Thanks in advance.

 

 

 

The exit command should be sending "Escape" not "Alt+F4". There are some emulators that only close with Alt+F4 so we instruct users to put an AHK in the emulator tab to have "ESC" send "ALT+F4" because of this.

You mentioned hitting "Escape" on the keyboard during gameplay does not cause this issue. Is this done when you launched the game through BigBox?

Share this post


Link to post
Share on other sites

 

1 hour ago, Retro808 said:

You mentioned hitting "Escape" on the keyboard during gameplay does not cause this issue. Is this done when you launched the game through BigBox?

That is correct. I am using the controller in Bigbox to navigate and launch the game, connecting the Wiimote, then hitting ESC on my keyboard. When i relaunch a game it reconnects the Wiimote 100% of the time. When i use the controller mapped shortcut to exit the game in Bigbox then relaunch a game the Wiimote almost always fails to connect. Maybe a 5% success rate over 10 hours of testing and head scratching, the only thing that fixes it is reinstalling the drivers, which works every time.

I should also mention that the shut down sequence(??) of the game looks a little bit different to me.  Hitting ESC seems to take a second or two longer to close the game than the controller. That being said that part could just be my imagination, i would have to screen record it to be sure.

Thanks.

 

Edited by YVRPC

Share this post


Link to post
Share on other sites
53 minutes ago, YVRPC said:

 

That is correct. I am using the controller in Bigbox to navigate and launch the game, connecting the Wiimote, then hitting ESC on my keyboard. When i relaunch a game it reconnects the Wiimote 100% of the time. When i use the controller mapped shortcut to exit the game in Bigbox then relaunch a game the Wiimote almost always fails to connect. Maybe a 5% success rate over 10 hours of testing and head scratching, the only thing that fixes it is reinstalling the drivers, which works every time.

I should also mention that the shut down sequence(??) of the game looks a little bit different to me.  Hitting ESC seems to take a second or two longer to close the game than the controller. That being said that part could just be my imagination, i would have to screen record it to be sure.

Thanks.

 

OK. Will have to check with the team to confirm what it is sending.

Share this post


Link to post
Share on other sites
20 hours ago, Retro808 said:

OK. Will have to check with the team to confirm what it is sending.

Thanks, I appreciate that.

I was able  to replicate the issue on my laptop today as well as another PC, exact same behavior.  Unfortunately I only have the one controller to test this with as my Switch Pro Controller doesn't work with LB/BB. I did try using the controller wired USB as well and unfortunately it was the same, exiting the game via controller broke the Wiimote connection.  I also tested closing the game from Alt+f4  on the keyboard and it behaves the same as ESC, it has no effect on the Wiimote.

Share this post


Link to post
Share on other sites

We worked out on discord a few days ago that BB controller automation does send alt f4.

We also worked out that the emulators "exit autohotkey script" over rides the controller automation. Although we didn't do much testing.

If escape closes... I'm assuming your using dolphin? Try putting 

Send {Esc Down}{Esc Up}

In dolphins exit autohotkey script. And then try the controller automation. Not sure if it will work but worth a try. 

  • Thanks 1

Share this post


Link to post
Share on other sites

To clarify as I knew I had read somewhere before the automation sent “Escape”. It actually sends that first and then tries Alt+F4 If the emulator has not closed. It can send different commands based on emulator as well. I found the post I was thinking about with Jason’s clarification here
 

I would definitely try @jayjay recommendation. 

Share this post


Link to post
Share on other sites
1 hour ago, jayjay said:

Try putting 

Send {Esc Down}{Esc Up}

In dolphins exit autohotkey script. And then try the controller automation. Not sure if it will work but worth a try. 

Auto Hot Key is something I have never used so I'm kinda flying blind on this one.  Am I even in the right part of Dolphin?

I received an error when applying the code, and it didn't change anything (still breaks the Wiimote BT) but I'm not convinced I did what you suggested correctly. Can you clarify a bit? Thanks.

Edit: Or is this something to add in Launchbox?

ahk.thumb.JPG.ea3f0b3c74626abc02583b22db6b453a.JPG

Edited by YVRPC

Share this post


Link to post
Share on other sites

No, you will want to put it in Launchbox. Go to manage emulators and edit Dolphin. In the Running AHK tab paste the code @jayjay gave you. 
 

Be mindful the “Exit AHK” tab is used by the Exit option in Launchbox Pause Theme options. So if exiting from the Pause them using the menu item does not work also paste the code there. 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

 

1 hour ago, Retro808 said:

No, you will want to put it in Launchbox. Go to manage emulators and edit Dolphin. In the Running AHK tab paste the code @jayjay gave you. 

Bingo. I think this one can be marked as solved.

The auto hot key seems to have fixed it. Pretty cool! I was dreading having to explain to my partner that starting, playing, and exiting all the Just Dance games required three different controllers. She can handle two I hope. hehe

Thanks again to both of you, I owe you both a beer.

Cheers

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...