Jump to content
LaunchBox Community Forums
Sign in to follow this  
DeadVoivod

RetroArch MAME core mapping issue

Recommended Posts

I decided to eventually use the RetroArch MAME core for MAME as I only have huge problems with the standalone MAME build, always deleting my controller mappings, didn't find any solution in the end. 

Here it runs fine, the only little problem I have, is the on controller 1, when pushing the A button, it does the action it should, but it also opens me the MAME config menu at the same time. I don't find where this binding of that key is, searched everywhere, only thing I find is that the config menu is bind to L3, which on the other hand does NOT work. So basically games are unplayable, as pressing A pops up the menu over and over again. 

Edited by DeadVoivod

Share this post


Link to post
Share on other sites
3 hours ago, DeadVoivod said:

I decided to eventually use the RetroArch MAME core for MAME as I only have huge problems with the standalone MAME build, always deleting my controller mappings, didn't find any solution in the end. 

By chance are you controllers dynamic? (Can be unplugged sometimes)

If so, MAME erases mappings for controllers that aren't attached. The simplest solution is once you set your mappings up, make the file read-only.

Edited by Headrush69

Share this post


Link to post
Share on other sites

I’m using 2 of the same 8BitDo SN30 Pro Plus controllers, thus Bluetooth. 
Setting the mappings configuration file to read only was one of the first things I tried, but strangely that didn’t work either. 
Does MAME use the default.cfg file from the cfg folder, or from the MAME root folder? I’m also quite happy with the RetroArch version, only this one little problem that prevents me from gaming. 

Share this post


Link to post
Share on other sites

Did you check in the mame config menu for the bindings as it can conflict with retroarch bindings as I found out

Share this post


Link to post
Share on other sites

Ha, that was the next thing I wanted to check once I'm home, and it was indeed the case, the config of MAME itself had the TAB key, and button 2 from that controller set up to menu. Good call mate!

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, DeadVoivod said:

Setting the mappings configuration file to read only was one of the first things I tried, but strangely that didn’t work either. 
Does MAME use the default.cfg file from the cfg folder, or from the MAME root folder? I’m also quite happy with the RetroArch version, only this one little problem that prevents me from gaming. 

Sounds like it was the wrong file then as that can't be possible.

MAME standalone uses the default.cfg in the cfg folder, not the root MAME folder.

If you are using Retroarch, that changes everything. I only use standalone MAME because it has much better multi device handling. The only advantage for me with Retroarch MAME core would be shaders, but I use Lordmonkus HLSL settings which I am happy with.

Share this post


Link to post
Share on other sites

I was using the standalone, but like I said, had big problems with the mapping, might give it another try, but it definitely reset the mapping even though the cfg file was set to read-only.

Now I'm using it with RetroArch, and that seems to work fine, but like I said, I might try standalone version again with cfg set to read-only, only to be sure. 

Share this post


Link to post
Share on other sites
44 minutes ago, DeadVoivod said:

I was using the standalone, but like I said, had big problems with the mapping, might give it another try, but it definitely reset the mapping even though the cfg file was set to read-only.

Now I'm using it with RetroArch, and that seems to work fine, but like I said, I might try standalone version again with cfg set to read-only, only to be sure. 

Were you setting the default.cfg read only or the game specific cfg read only? Game specific cfgs will override the default.cfg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...