Jump to content
LaunchBox Community Forums
Sign in to follow this  
Ble3azy

selecting games eats Memory

Recommended Posts

Posted (edited)

Hey all,

Context: I have around 1500 games total in the library, and I use playlists to sort them into various chunks ("party night", "currently playing" etc).

Action performed: just the act of highlighting games, or ctrl clicking several (before even adding or getting to any further action) eventually leaves launchbox unresponsive, slows my machine to a crawl, and ultimately shows the low memory error and launchbox force closes itself. (I have 16gb ram)

A quick look at task manager shows that each select click is stacking approx 30-100mb to used memory, which is never flushed. meaning after 50~ish games have been clicked on the exe is showing over 6gb use. These are not new images either, they have already been cached as far as I can tell as scrolling through the games without selecting shows box art images instantly. So I presume the accompanying extra art is all being loaded in and kept?

FYI this isn't specific to 10.1, as It's been happening for a few versions now. Is this normal behaviour?

Cheers.
B

 

Edited by Ble3azy

Share this post


Link to post
Share on other sites

First, just so we are clear what version are you on? I seem you mention 10.1, is that ACTUALLY 10.1, or  10.10? Current live version is 10.11.

Secondly, if you aren't adding any more games to the playlists you are referring to I would check and make sure they aren't auto-generated playlists. Auto-generated playlist take a considerable amount more of resources than manual ones, and cause extra calculations in many processes. If you know those playlists will not be changing much in the future I would make sure to untick that box.

Share this post


Link to post
Share on other sites
Posted (edited)

It's version 10.11. but like I say this has been happening for a long time, including v9.

I think you may have confused the issue, regardless of playlists or not, I'm just talking about literally selecting games, with a single left click on the mouse, or ctrl clicking a few, not within a playlist. (my example was to then add to playlists but it could be for any reason like mass editing etc).

FYI none of the playlists are auto generated anyway,

(Edit: I just did an experiment and deleted all playlists and it still does it. If fact I also noticed whilst selecting games, Task manager not only shows the memory stacking up, but just selecting random games (this time I was actually using the "select random game" tool shortcut ctrl+alt+Q) the CPU was over 85% on my i5 7300HQ during the selections)

My point is just clicking and looking at games seems to be taking up an unbelievably unreasonable amount of resources/overhead. which is obviously a huge concern, as then deciding to run a game after looking at a few, even with 16gb installed my game then has no Ram left to use!

Edited by Ble3azy

Share this post


Link to post
Share on other sites

Just tried to reproduce this and I cannot see any change my ram usage. Launchbox hovers around 730-760 MB of ram usage  on average and clicking around games sometimes the ram goes up a little and other times it goes down a little. Changing platforms and clicking around did make it spike up to around 800 MB but it then quickly dropped back down to 700 MB

Share this post


Link to post
Share on other sites
3 minutes ago, Lordmonkus said:

Just tried to reproduce this and I cannot see any change my ram usage. Launchbox hovers around 730-760 MB of ram usage  on average and clicking around games sometimes the ram goes up a little and other times it goes down a little. Changing platforms and clicking around did make it spike up to around 800 MB but it then quickly dropped back down to 700 MB

Weird.

I have the blur function on could it be that? Or the fact it's a portable instillation on an external HDD (7200) ?

Share this post


Link to post
Share on other sites

I suppose it could maybe be one of those 2 things, I use my own custom LB which has no blur and it's on an internal drive.

Here is the theme I use: 

 

Share this post


Link to post
Share on other sites

Hmmm, I'm on the default theme, so looks like I'm gonna have to do some experiments.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...