Jump to content
LaunchBox Community Forums
Tackett1980

Marquees driving me nuts. Can’t get them to fill the screen.

Recommended Posts

10 hours ago, drewjbx said:

Nice so you figured it out.. whenever you have time if you could share the code/steps to do this that would be great!

Well I got it working. Still have not figured out a few things I want it to do. 

My hope was to have it use an existing marquee image and if one does not exist use the static background option. Problem is the way marquee support is coded into LB/BB, if a marquee image is not present it will default to your box priorities. So if a marquee is not present it reverts there and the code will always have an image to show which means the fallback is never triggered to the static image option. So for now I have to forego the existing marquee option and just use static image. Hoping Jason one day adds image priorities for marquee images.

My goal is to release it on the forum, but not until I have it working right. 

@Headrush69 I will see if I can remote into my pc and get a video of it. Away from the house for a couple days helping family get land taken care of.  

Share this post


Link to post
Share on other sites
33 minutes ago, Retro808 said:

 

@Headrush69 I will see if I can remote into my pc and get a video of it. Away from the house for a couple days helping family get land taken care of.  

Absolutely no rush, family always first.

For my purposes I prefer platform marquees when playing console/computer games, sort of like a history lesson for younger people watching. I can always just duplicate a platform image to each game using a simple script. Obviously a little more resource hunger, but not terrible in the grand scheme of things.

Share this post


Link to post
Share on other sites
22 minutes ago, Headrush69 said:

Absolutely no rush, family always first.

For my purposes I prefer platform marquees when playing console/computer games, sort of like a history lesson for younger people watching. I can always just duplicate a platform image to each game using a simple script. Obviously a little more resource hunger, but not terrible in the grand scheme of things.

I was trying to accomplish a similar purpose. Arcade systems would show their actual marquee images (or their HD recreations) and then those games that did not have one would default to the static w/clear logo and then all platforms/pc games use the static image/clear logo style.

Disregard the video sizes as OBS from remote was not working right. Also disregard the platform marquees as I have not finished the images so it is just using whatever is in the folder.

 

Share this post


Link to post
Share on other sites
1 hour ago, Retro808 said:

Well I got it working. Still have not figured out a few things I want it to do. 

My hope was to have it use an existing marquee image and if one does not exist use the static background option. Problem is the way marquee support is coded into LB/BB, if a marquee image is not present it will default to your box priorities. So if a marquee is not present it reverts there and the code will always have an image to show which means the fallback is never triggered to the static image option. So for now I have to forego the existing marquee option and just use static image. Hoping Jason one day adds image priorities for marquee images.

My goal is to release it on the forum, but not until I have it working right. 

@Headrush69 I will see if I can remote into my pc and get a video of it. Away from the house for a couple days helping family get land taken care of.  

OK will keep an eye out for that release, much appreciated. Something I noticed was if there is no marquee image BB will display the boxart in my case... something to do with the image priorities, for now maybe I can put just a clear logo.. will play around with it. 

Share this post


Link to post
Share on other sites
4 minutes ago, drewjbx said:

OK will keep an eye out for that release, much appreciated. Something I noticed was if there is no marquee image BB will display the boxart in my case... something to do with the image priorities, for now maybe I can put just a clear logo.. will play around with it. 

Yeah. In my post earlier I mentioned how the marquee image if not present will follow your box image priorities. So the issue is you would have to change box priorities list. Which then affects box priorities. 

Share this post


Link to post
Share on other sites
On 4/5/2020 at 6:35 AM, Retro808 said:

Well I got it working. Still have not figured out a few things I want it to do. 

My hope was to have it use an existing marquee image and if one does not exist use the static background option. Problem is the way marquee support is coded into LB/BB, if a marquee image is not present it will default to your box priorities. So if a marquee is not present it reverts there and the code will always have an image to show which means the fallback is never triggered to the static image option. So for now I have to forego the existing marquee option and just use static image. Hoping Jason one day adds image priorities for marquee images.

My goal is to release it on the forum, but not until I have it working right. 

@Headrush69 I will see if I can remote into my pc and get a video of it. Away from the house for a couple days helping family get land taken care of.  

Hey Retro.. did you ever get this ironed out? Hoping to get marquee image displays fine tuned as you have mentioned....  with use of a static background if a marquee image doesn't exist and the option of having a background static image and being able display clear logo image on top of it. 

Share this post


Link to post
Share on other sites
2 hours ago, drewjbx said:

Hey Retro.. did you ever get this ironed out? Hoping to get marquee image displays fine tuned as you have mentioned....  with use of a static background if a marquee image doesn't exist and the option of having a background static image and being able display clear logo image on top of it. 

Honestly, I have not messed with it in a while. Issue I was having is the LB Arcade - Marquee images defaults to a users Box - Front image priority is a marquee is not present and no matter what I tried it always displayed either the existing marquee image or the priority fallback. Even if I coded in a FallBackValue it still gave LB built in priorities preference. Hopefully next poll go round Marquee update can get voted more and it gets some updates.

I can get it to work if Arcade - Marquee images are in a custom folder location, but that is just an unneeded workaround. I will mess with it again. Maybe I have learned more in the time and can get it to work.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...